Hello Everyone,

I set up a IP Cam over at another location on an apple time capsule router. I mapped port 80 so external users ie. you guys could access it.

You can view the camera here:
Username: guest Password: guest

My problem is using a Macbook air running OS Snow Leopard, QuickTime X and the latest build of Safari I can't get a video feed from the camera. The feed works fine on a PC and my GFs Macbook Pro running 10.4.

Basically what happens is when the QuickTime plug in tries to connect to the video feed it says "negotiating" forever. Then eventually the video feed never loads. This one has me stumped, I tried calling apple care and they gave me the whole shpeal on how that my problem was not covered my apple care. A few days ago when I called them with a similar issue and one of their tier 2 guys was able to help me out. Any ideas on what is going on here? I don't have any antivirus or firewall blocking it. I already downloaded QuickTime 7 as an alternative to X but no luck. I cleared my cache, history and .plist files and still no solution. I also tried connecting to the cam on my bosses MacBook Air virtually the same as mine and he had the same problem I did.

MacBook Air Mac OS X (10.6.5)