New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus • Advice and insight from world-class Apple enthusiasts • Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Apps and Games Discussion of applications and games available for Mac OS X.

Disk Utility causes problems?


Post Reply New Thread Subscribe

 
Thread Tools
Al.Pothoof

 
Member Since: Jun 23, 2010
Posts: 3
Al.Pothoof is on a distinguished road

Al.Pothoof is offline
I'm posting this here and using Disk Utility in the title mostly because it seems to be related, in time, with my problem. I don't know that it really was the cause of my problems.

My wife has a G4 MAC, running OS X, 10.4.11. I ordered a 2TB Seagate FreeAgent Desktop external drive last week and it came in on Tuesday. (She does a LOT of photo restoration and movie work and pretty much filled up a 1TB drive in the last year or so.)

Since I am a "migratory engineer" and wouldn't be home until Friday night, she decided to try to install it. I got a call when she got lost on the Seagate site. I eventually got her onto the page where it gives directions for formatting and partitioning the new drive and started walking her through it.

So, with both of us, literally, on the same page, it went like this:

Run Disk Utility
Select the new drive
Select the partition tab
Set the name as Portable-2
Select the format for Mac OS Extended
She left the volume scheme as "current" (which is how it came up)
Set the checkbox to install Mac OS 9 disk drivers (don't know if we'll ever need that but didn't seem like a biggie)
Clicked Partition
got the warning box
Clicked Partition from the warning
Disk Utility went away...

She didn't get any indication that it was creating a filesystem and the new drive wasn't mounted when she checked (directions said it would be).

So we go through it again:

Run Disk Utility
Select the new drive
Select the partition tab
Set the name as Portable-2
Select the format for Mac OS Extended
She left the volume scheme as 1 partition (change here as having one ginormous partition was the point of the new drive)
Set the checkbox to install Mac OS 9 disk drivers
Clicked Partition
got the warning box
Clicked Partition from the warning
creating filesystem
when it was finished, the drive was mounted.

Everything looked good and my wife started copying files from the smaller portable drive to the new drive. Don't know how much she got moved but she shut the system down fairly soon as a thunderstorm started to move through the area.

Called me at work this morning and she was about ready to throw the Mac out the window:

When she booted it up:
her desktop was empty (both display and directory)
Safari had lost all bookmarks
the Finder window "looked different"
the i-movie icon in the dock was now the question mark icon (don't know if it's just the icon or if the file is gone, too)

Isn't much I can do at this point so I told her I'd look around for ideas and see what I could do this weekend.

She called me after lunch nearly crying; she'd tried to use e-mail and got the "Welcome to..." window and all her e-mail addresses appear to be gone. At this point, she's afraid to touch it for fear of making things even worse. And I can't blame her but I also can't tell the extent of the problem.

Caveat: I was helping her remotely so I couldn't look over her shoulder. It's possible she hit something she didn't realize but that doesn't make a lot of sense to me.

I'm reasonably sure she selected the right drive; if she had gotten the wrong one, I would expect that drive to have been wiped and both external drives seems ok and the system did boot. Or would Disk Utility protect the system enough that some things would work but she'd lose options and data other than some system files?

So I guess 2 questions to start with:

What is the effect of leaving the partition scheme as "current" when you try to partition a new drive?

Most importantly, is there any way to recover? My only thought, at this point, is to run Disk Utility in verify mode and see what it thinks about the boot disk. If it decides there are problems, I can boot to the install disk and have Disk Utility try to repair it.

Any chance this is a case of "invisibles?" PinkMutant says drives and folders can go invisible but doesn't mention files. That's another thing I can check this weekend.

Sorry for the long post but thanks in advance.
QUOTE Thanks
hughvane

 
hughvane's Avatar
 
Member Since: May 18, 2008
Location: Banks Peninsula, New Zealand
Posts: 3,259
hughvane is just really nicehughvane is just really nicehughvane is just really nicehughvane is just really nicehughvane is just really nice
Mac Specs: MacMini 2.4, 4 Gb, OS 10.8 and 10.6; MacBook 2.4, 2 Gb, OS 10.5.8; G4 eMac 1.25, 2 Gb, OS 10.4.11

hughvane is offline
Congratulations on a fulsome post - plentiful information on which to work.

Quote:
Originally Posted by Al.Pothoof View Post
What is the effect of leaving the partition scheme as "current" when you try to partition a new drive?
What was the current scheme? I assume it applies to the old drive. Was it a single partition drive?

Quote:
Most importantly, is there any way to recover?
Yes. Your wife can try booting into Safe mode by holding down the Shift key on startup chime. That may give access to non-OS files.

Quote:
run Disk Utility in verify mode and see what it thinks about the boot disk ... I can boot to the install disk and have Disk Utility try to repair it.
Hopefully that's not necessary, but it won't hurt.

I can't comment on "invisibles".

ABCDEFGHIJKLMNOPQRSTUVWXYZ
Please post your Mac (or other) specs and MacOS version in your post, your profile or your signature. It helps us to help you better.

I'm leaving now to go and find myself. If I should return before I get back, please ask me to wait.
QUOTE Thanks
harryb2448

 
harryb2448's Avatar
 
Member Since: Nov 28, 2007
Location: Nambucca Heads Australia
Posts: 16,836
harryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond repute
Mac Specs: iMac i5 2.7GHz OS X.9.4

harryb2448 is offline
Depends on the model G4 which is about the only thing you never supplied and the most important. Early G4's will handle up to 128GB hard drives, and need to be formatted Apple Partition Map. To do this start Disk Utility from the install disc, Tiger OS X.4, go into partitions, select options and click Apple Partition Map, the number of partitions, and click Mac OS Extended (Formatted).
QUOTE Thanks
Al.Pothoof

 
Member Since: Jun 23, 2010
Posts: 3
Al.Pothoof is on a distinguished road

Al.Pothoof is offline
hughvane:

My assumption is that "current" scheme was 1 partition; the other two drives (system disk and 1TB external) are both single partition drives. If she had selected one of those by accident, wouldn't it have been wiped completely? It appears only "some files" from the system disk are missing.

But you raise an interesting question: what is "current" on a fresh drive formatted for a PC?



harryb2448:

The format selected was for Mac OS extended (the only option since we didn't want DOS and can't use GUID: this is a Motorola Mac, not an Intel Mac). That was selected both times.

I don't think this is the issue as I already had a 1TB external drive hooked up. And the problem isn't with the new drive, it's with the system disk.
QUOTE Thanks
chas_m

 
chas_m's Avatar
 
Member Since: Jan 22, 2010
Location: Victoria, BC
Posts: 16,191
chas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond repute
Mac Specs: 2009 MBP, Black speakers, Black Benq second monitor, black(ish) iPhone 5s, Black 2012 iPad, etc.

chas_m is online now
As for why all her "stuff" disappeared, its because she's either overwritten her old user account or (much more likely) accidentally created a dupe of it, which the Mac will set to default values.

With you not there to help, I'd strongly recommend a visit to an authorised Apple repair centre asap. I'd avoid using the computer further until that has happened.
QUOTE Thanks
Al.Pothoof

 
Member Since: Jun 23, 2010
Posts: 3
Al.Pothoof is on a distinguished road

Al.Pothoof is offline
chas_m, you nailed it!

I got home Friday night, booted the Mac into safe mode and started rooting around on the disk. I found that the User folder had 3 subfolders: Public, <wife’s user ID> and 0. A cursory examination of the 0 subfolder left me fairly certain it was my wife’s original folder.

I spent most of Saturday backing up the subfolders labeled 0 and <wife’s user ID>. The 0 folder had a number of files with “special” permissions, which resisted being copied from a higher folder although there seemed to be no problem copying them individually. There were also a surprising (at least to me) number of files which the copy command identified as “in use”; these had to be tracked down individually and unlocked. As we had another thunderstorm moving in, I called it a night after I got everything backed up.

Sunday morning I booted the system and tried something I didn’t really expect to work: I renamed the <wife’s user ID> subfolder to 1, then renamed the 0 folder to <wife’s user ID>. I didn’t expect it to work as I was logged in to that account but, apparently, OS X doesn’t have a problem with renaming a folder its working out of.

Then I rebooted the system.

VIOLA!

Wallpaper back to normal and about a gazillion icons on the desktop. Loaded up Safari and the bookmarks were there. Called my wife over and she verified that the desktop was looking the way it should. She played around a few minutes and said most things looked normal but there were some customizations in the Finder window that weren’t back. She said that was no big thing.

At this point, nothing has been deleted and I have a full backup of these 2 subfolders. I’ve told her to not only do her normal work this week but to poke around a bit and see if anything else seems like it hasn’t been restored.

I don’t think she’ll find anything missing, except perhaps some customizations like the Finder window but, if she does, it should still be available. If everything is back to normal, I’ll get rid of the new folders this weekend and clean up the disk.

Still not sure what got fat-fingered to cause this issue in the first place but at least it wasn’t terminal.

Thanks to everyone who helped me out by taking a look at the issue..
QUOTE Thanks

Post Reply New Thread Subscribe


« Download Logger Needed | Messenger on Macbook Pro Help!! »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
External HD, not mounting but shows in Disk Utility Dermiroth Other Hardware and Peripherals 3 01-06-2010 09:11 AM
Disk Drive Problems KeithTeeple Apple Desktops 2 02-15-2009 10:34 PM
disk utility probs... rikin Apple Notebooks 5 12-28-2008 08:14 AM
problems with running disk utility in 10.3 kyrre OS X - Operating System 4 05-09-2006 12:31 PM
problem with disk utility Maul Apple Notebooks 5 01-26-2006 10:59 PM

All times are GMT -4. The time now is 06:42 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?