New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Apps and Games Discussion of applications and games available for Mac OS X.

Anyone Know Why Youtube Is So Strange On My New Macbook


Post Reply New Thread Subscribe

 
Thread Tools
thorneorama

 
Member Since: Apr 10, 2010
Posts: 1
thorneorama is on a distinguished road

thorneorama is offline
Hi, I don't know if I have posted in the correct discussion area, but here goes.

About a month and a half ago I purchased a new Macbook with Snow Leopard.

I downloaded firefox 3.6 for browsing, things were pretty good.

Then a few weeks later Youtube and sometimes ebay would take forever to load.
I can watch videos on Youtube but the pages and channels take forever to load, most of the time the pages don't load at all. I can see the text that accompanies the video but I can't see the thumbnails or screenshots that your supposed to see all over youtube, also backgrounds for Youtube Channels rarely appear.
The load bar never seems to get to 100%

I have contacted my ISP all line tests show I get very decent speeds.
I have also checked my speed using online tests.
I have cleared history, cache, cookies.
I have downloaded the most recent Flash Player.
I have made the repairs in Disk Utility
I have tried Safari (same problem)
I have Reset Routers & connections.

It doesn't matter what time of day I use the site I get the same problem.

I also have a XP PC at home and can still use youtube perfectly well.
I also have an XP PC in work with a poor connection and can still use Youtube ok.

Any help would be most appreciated

Thorneorama
QUOTE Thanks

Post Reply New Thread Subscribe


« Safari wont access a site | 10.5, Mail.app, why is it contacting imap server about unrelated mail? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
19 Days with a Macbook Pro b.hicks Switcher Hangout 23 03-01-2010 01:49 AM
macbook acting strange narayani OS X - Operating System 0 02-11-2009 02:48 AM
Macbook strange behaviour with streaming video rmj89 Apple Notebooks 2 02-05-2009 09:53 AM
strange screen fault - macbook pro powis Apple Notebooks 1 02-04-2009 01:40 AM
Macbook (late 2008) youtube performance? Och OS X - Apps and Games 4 12-01-2008 09:52 PM

All times are GMT -4. The time now is 09:54 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?