Get those error messages on youtube or foxnews etc about needing to update flash ? Just update Click2Flash and fixed.

ClickToFlash 1.6b7 solves YouTube's "Old Flash? Go upgrade!" message


Clay