ok, so I'm using OSX Leopard and within Mail, I have two mailboxes linked to a different gmail account each.

On sunday, one of the mailboxes stopped working in the sense that when retrieving messages, it would just retrieve the other account. Accessing via web, I could see that there were messages on the server but Mail would not prompt for download.

So monday night after still no news, I decide to set up the non-working account again and voila, it would download the messages on the server. Fine I thought, so then I just moved the messages that were already in the mailbox that quit working to the new mailbox. Everything looked fine then.

Today I notice that the messages that I moved from one mailbox to the other would not open anymore, i.e. I can see subject, date, etc but I can't read the content of the message, neither in the preview panel or when opening the message. Tried to delete one of them and it would not be deleted, but would only be marked grey with a strange arrow in the front...

Did somebody have a similar problem? Could you solve it?

Many thanks for hints in any direction.