Results 1 to 3 of 3
  1. #1


    Member Since
    Nov 22, 2009
    Posts
    16
    GimpShop and/or X11 not working
    Greetings, I did a search and could not find this problem/answer. I did post this in the operating section, but perhaps it is better suited for this forum.

    I downloaded and installed GimpShop for my macbook os 10.5 Leopard
    I followed instructions on a website to install X11, but when I run the gimpshop app, it won't launch and gives me a message that X11 is required. I then get a message to Reset and relaunch X11. I do this, but still nothin.

    When I get the option to click a "report" button, I see a line in it that reads, "Library not loaded: /usr/X11/lib/libpixman-1.0.dylib".

    I open a cmd window and cd to /usr/X22/lib and I can grep and see that very file. listing:
    -------
    john-cowans-macbook:lib johncowan$ ls -la | grep libpixman-1.0.dylib
    lrwxr-xr-x 1 root wheel 19 Nov 22 17:57 libpixman-1.0.11.8.dylib -> libpixman-1.0.dylib
    lrwxr-xr-x 1 root wheel 19 Aug 30 19:33 libpixman-1.0.12.0.dylib -> libpixman-1.0.dylib
    -rwxr-xr-x 1 root wheel 946960 Jul 31 2008 libpixman-1.0.dylib
    lrwxr-xr-x 1 root wheel 19 Nov 22 17:57 libpixman-1.dylib -> libpixman-1.0.dylib
    -------

    Any ideas on how to get this to work? I'm new to the mac world, so please forgive any obvious ignorances. ;o(

    Thanks for the help!
    YankeeFan

  2. #2


    Member Since
    Nov 22, 2009
    Posts
    16
    I should have added more info on this problem. I found that the x11 is looking for a newer version of my libpixman-1.0.dylib.

    Dyld Error Message:
    Library not loaded: /usr/X11/lib/libpixman-1.0.dylib
    Referenced from: /Applications/Utilities/X11.app/Contents/MacOS/X11.bin
    Reason: Incompatible library version: X11.bin requires version 13.0.0 or later, but libpixman-1.0.dylib provides version 12.0.0

    I'm not sure I understandt this message. Do I need to get a newer version of the libpixman-1.0.dylib? I tried to google on this with no luck.

    Any ideas?

  3. #3


    Member Since
    Nov 22, 2009
    Posts
    16
    i upgraged to snow-leopard and that seems to solve my x11 problem. There is very little help on this on the web. This, I think, was the only way to get the version that gimpshop needed. I still don't understand all that.

    Now I have a new problem. How to start GimpShop? I double click on the application and I see a popup that reads, caching fonts, then a command window "xterm" with the line:
    bash-3.2$

    What is this for? Do I need to run a command-line statement to start Gimpshop? If so, does anyone know what it is. Should I uninstall gimpshop and start over?

    Thanks for any tips.
    YankeeFan

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. gimpshop on osx lion
    By faisal_sherry in forum OS X - Operating System
    Replies: 2
    Last Post: 08-28-2011, 01:17 AM
  2. Applescript and X11 not working. need help
    By deathnomore in forum OS X - Operating System
    Replies: 2
    Last Post: 01-04-2010, 01:56 AM
  3. GimpShop and X11 not working
    By YankeeFan in forum OS X - Operating System
    Replies: 0
    Last Post: 11-22-2009, 06:22 PM
  4. Running Gimpshop in Leopard
    By NolaWegs in forum Images, Graphic Design, and Digital Photography
    Replies: 2
    Last Post: 12-25-2007, 06:37 PM
  5. New to gimpshop
    By Ryan13 in forum Images, Graphic Design, and Digital Photography
    Replies: 1
    Last Post: 06-17-2007, 10:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •