I recently upgraded to Adobe Reader version 9.2. I use a drm software on my machine from Oracle that is not compatible with 9.2. I need to roll back to 9.1

I went into my applications folder and deleted Adobe Reader 9.2. searched for all recently updated Adobe foldered and deleted those as well. I emptied my trash can and restarted machine.

Whenever I try to install Adobe Reader 9.1 I get an error message that says "Cannot install Adobe 9 to this disk. A new version of this software already exists on the disk" or something to that affect and it will not let me install 9.1.

Any suggestions or hidden files I should look for on my Mac? I really need 9.1 to view my drm material.