I tried to upgrade samba to Samba 3.4.1(which is ipv6 compatible) in Mac 10.5, but it had lot of installation dependency(gcc) issues. Please could someone help me in this.