Results 1 to 5 of 5
  1. #1


    Member Since
    Aug 19, 2009
    Posts
    2
    Duplicate Message using Gmail Imap and Mac Mail
    I have set up imap for Gmail on my Mac OSX mail and receive duplicate emails and duplicate mail counts. The first in my personal inbox and the second in the Allmail folder. Does anyone know how to turn off the duplicates?

  2. #2

    cwa107's Avatar
    Member Since
    Dec 20, 2006
    Location
    Lake Mary, Florida
    Posts
    26,953
    Specs:
    15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD
    I ran into this a bit early on. Check this article on Google's site and see if it helps:

    Recommended IMAP client settings - Gmail Help
    Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!

    https://youtu.be/KHZ8ek-6ccc

  3. #3


    Member Since
    Aug 19, 2009
    Posts
    2
    changed settings
    I tried all of the settings and suggested settings and it didn't work. What I finally determined would work was:

    1) Choose settings within the gmail application on the web
    2) click the labs section and enable advanced imap controls.
    3) unclick the show in imap for all mail

    Official Gmail Blog: New in Labs: Advanced IMAP Controls

  4. #4

    Mojokaiser's Avatar
    Member Since
    Apr 05, 2011
    Location
    Tennessee
    Posts
    1
    I also tried the same settings mentioned above for apple mail behaviors from Gmail site:

    Recommended IMAP client settings

    All IMAP clients differ, and you can configure your mail client's settings to best suit your needs. However, to work optimally with Gmail, we recommend certain settings. Click on your client below to view our recommended configuration.
    Apple Mail
    • From the Mail menu, click Preferences > Accounts > Mailbox Behaviors
    ◦ Drafts:
Store draft messages on the server > do NOT check
Sent:
Store sent messages on the server > do NOT check
Junk:
Store junk messages on the server > checked
Delete junk messages when > Never
Trash:
Move deleted messages to the Trash mailbox > do NOT check
Store deleted messages on the server > do NOT check

    And I also removed the preference plist and evelope index files, still to no avail. Upon restarting mail to receive my account creation here at forums I have the same 800 emails i just manually deleted. ug!
    it's only from one gmail accnt, of which I have 3 gmail accnts total, and they are concurrently being "saved" as duplicates, minute by minute, in the "all mail" folder on the said accnt, which is set up as IMAP not Pop.
    This is an everyday theater here deleting mail I cannot find even going to gmail directly and searching all folders/mail i have stored there on gmail server. Where is apple mail finding these?

    re: one reply i sent once, is copied every minute, sometimes twice in same minute from 3:01 PM to 4:58 PM, total of over 200 copies of one reply, which was sent March 22, 2011, and still "finding" it somewhere, after I cleaned out gmail's server of this reply. Going on third set just today, of same duplicates being created from mail, deleted off gmail servers way back, over 800 mails to manually remove.. 3x's a day.

    Image of partial list of a reply duplicated:

    http://i853.photobucket.com/albums/a...ialduplist.jpg

  5. #5


    Member Since
    Oct 03, 2011
    Posts
    1
    Solved (in My Case), Ignoring Google's Suggestions
    Quote Originally Posted by RWL1900 View Post
    I have set up imap for Gmail on my Mac OSX mail and receive duplicate emails and duplicate mail counts. The first in my personal inbox and the second in the Allmail folder. Does anyone know how to turn off the duplicates?
    I tried the suggestions listed on Google's Gmail forum on what to do within Mail under Accounts / Mailbox Behavior. It did not work.

    This is what worked for me, after much trial and error:

    1) Go to your gmail mail in your browser
    2) Click on "Mail Settings" (gear symbol)
    3) Click on "Labels"
    4) uncheck: Click as many of the "Show in IMAP" selections as necessary. For me, as I feed four accounts into my Gmail, I unchecked the following:

    - "Important"
    - "All Mail"
    - All the four accounts feeding to my primary mailbox

    5) If you want to test each uncheck, simply quit Mail, and restart it with each setting change to see the changes take effect. I saw how each email when from 2-4 duplicates to elimination, one notch at a time

    6) Return your Mail's Account / Mailbox Behavior to the default settings

    See picture of my settings. Note, I also have some folders in my gmail that I left checked for IMAP. Personal choice to have those duplicates as it allows those folders to show up in Mail.
    Attached Images Attached Images

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mail vs IMAP Gmail
    By WHB in forum OS X - Apps and Games
    Replies: 2
    Last Post: 06-14-2012, 11:50 PM
  2. Mac Mail 4.5 (Entourage) - GMail IMAP
    By John Greer in forum Switcher Hangout
    Replies: 2
    Last Post: 06-26-2011, 04:35 AM
  3. Mac Mail POP IMAP Multiple Computer Duplicate E-Mail Problem on Laptop
    By killertofu in forum OS X - Apps and Games
    Replies: 1
    Last Post: 02-11-2011, 07:15 PM
  4. Gmail IMAP and Mail.App -- All mail ANNOYANCE!
    By ehmjay in forum OS X - Apps and Games
    Replies: 0
    Last Post: 08-25-2008, 09:57 AM
  5. 10.5: Mail with Gmail IMAP
    By kao in forum OS X - Apps and Games
    Replies: 2
    Last Post: 11-19-2007, 08:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •