New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Apps and Games Discussion of applications and games available for Mac OS X.

iPhoto not connecting to Facebook


Post Reply New Thread Subscribe

 
Thread Tools
bungy

 
Member Since: May 11, 2009
Location: London
Posts: 132
bungy will become famous soon enough
Mac Specs: 2009 Macbook White 2Ghz 2Gig RAM 120Gig HDD

bungy is offline
Is any-one else having trouble connecting iPhoto to Facebook?

I first of all struggled to get iPhoto to let me enter my facebook user name. I got the detail entry form up, i could click on the text box, but no matter what i did on the keyboard no letters would appear in the text box.

after a lot of messing around i got my username in the box, enter my password and click login. but all the happens is i get a blue circle mouse pointer and nothing else happens.

any-one else experiencing this?

i think that a software update recently must have upgraded iPhoto as it wanted to upgrade my library when i started iPhoto tonight so wonder if this bug has not been introduced by a new version?
QUOTE Thanks
beefman

 
Member Since: Jul 17, 2008
Location: Canada eh
Posts: 30
beefman is on a distinguished road
Mac Specs: 24" iMac 3.06Ghz

beefman is offline
I just went through that too. Did you download the iPhoto Exporter for Facebook?...Then look under the export photo tab in iPhoto you must log into Facebook from there...hope you understand. Good luck.
QUOTE Thanks
neiltony

 
Member Since: Jun 11, 2009
Posts: 1
neiltony is on a distinguished road

neiltony is offline
While the above stated problem does install a new tab in export, the user above is obviously using '08, not '09. '09 has the "nifty" facebook button at the bottom of the page that you just hit.... and wahlah, you're uploading... i too have EXACTLY the same problem, and have tried many attempts at fixing this including using a different facebook email address, and different facebook password. NO GO! The tab that the facebook installer program installs does work, but so what! I want that button to work dagnabit!
QUOTE Thanks
bungy

 
Member Since: May 11, 2009
Location: London
Posts: 132
bungy will become famous soon enough
Mac Specs: 2009 Macbook White 2Ghz 2Gig RAM 120Gig HDD

bungy is offline
yup, using iPhoto 9. My Macbook is only 6 weeks old.

thing is, it was working fine a week or two ago, but since i got some updates over the week-end it won't work anymore.

the wierd bit is when you click the button and then it asks you to set up an account (my account was previously setup, but it seems to have forgotten this), i can't actually type anything in the username box. the cursor just sits there and flashes. I can enter a password though, but what good is that without a username.
QUOTE Thanks
jordya

 
Member Since: Jun 15, 2009
Posts: 2
jordya is on a distinguished road

jordya is offline
I too am having the same problem. However, I am able to upload photos to my account. But, I tried the "change accounts" button so my wife could upload photos to her account...and thats when I noticed the problem. I can't type in the login box (the cursor just blinks). I tried a copy-paste that seemed to work, but then I just get the blue circle. I am using iPhoto 09. Is there a fix coming out or do we have to download the iPhoto Exporter?
QUOTE Thanks
bradyh1

 
Member Since: Jun 16, 2009
Posts: 2
bradyh1 is on a distinguished road

bradyh1 is offline
Actually guys, just figured it out, at least for me - Quit iPhoto, go to your Home folder / Library / Preferences / com.apple.iphoto and delete that preference file. Then restart iPhoto and it was suddenly fixed for me!

Tons of other threads back it as well.
QUOTE Thanks
spiffypyaaz

 
Member Since: Jun 16, 2009
Posts: 3
spiffypyaaz is on a distinguished road

spiffypyaaz is offline
bradyh1, i tried looking for the com.apple.iphoto file in the preference folder, but there isn't one in my preference folder. have any of you run across anything else that would be helpful?

i noticed that it automatically populates the email address that you used to log into facebook from safari (i have been using mozilla so it took a while to figure that out, since my husband used facebook in safari last).

PLEASE ADVICE!
QUOTE Thanks
Tony LaF

 
Member Since: Jun 16, 2009
Posts: 1
Tony LaF is on a distinguished road

Tony LaF is offline
thanks brother...that worked...all the best. tony LaF

devilsdentattoo.com
QUOTE Thanks
bradyh1

 
Member Since: Jun 16, 2009
Posts: 2
bradyh1 is on a distinguished road

bradyh1 is offline
spiffypyaaz... not sure why your not seeing it. If you've updated your mac with the latest software, and updated iphoto as well... that .pst file should be found by just following that path I gave.

MAKE SURE... to close iphoto before going hunting and then delete that file and remove from trash. Then open iphoto back up.

Go Finder / Home folder / Library / Preferences / com.apple.iphoto.pst (i believe that is the extension to the file you need to delete) It's defiantly in there if you've recently updated your OS.

You may also want to try rebuilding iphoto by closing down iphoto and then pressing & holding the Apple and Option key's will clicking to open iphoto again. Then just select on the pop up screen all the boxes to help rebuild iphoto. That may help too.
QUOTE Thanks
alpha04

 
Member Since: Feb 05, 2009
Posts: 3
alpha04 is on a distinguished road

alpha04 is offline
Having the same problem too. I have iPhoto 09 as well and I often use it to upload photos directly to my facebook account. After I updated iphoto a few days ago, the problem started. Mine displays my email address, though, but can't edit it... after I put in my password, I get that blue circle pointer as well. I waited it out (fell asleep, actually) and still nothing. Still to try bradyh1's suggestion... thanks!
QUOTE Thanks
alpha04

 
Member Since: Feb 05, 2009
Posts: 3
alpha04 is on a distinguished road

alpha04 is offline
It worked! Thanks bradyh1.
QUOTE Thanks
bungy

 
Member Since: May 11, 2009
Location: London
Posts: 132
bungy will become famous soon enough
Mac Specs: 2009 Macbook White 2Ghz 2Gig RAM 120Gig HDD

bungy is offline
This has now been fixed properly by Apple. The problem has been caused by Safari 4.

Do a software update and download the new Safari 4.0.1 and the facebook upload from iPhoto will work again :-)
QUOTE Thanks
MrElvey

 
Member Since: Feb 22, 2010
Posts: 6
MrElvey will become famous soon enough

MrElvey is offline
I thought I was getting this problem now in iPhoto.

I last uploaded stuff to facebook via iPhoto about 11 months ago.

The two facebook albums in iPhoto have little warning triangles indicating a connection problem, and I get this error when I click on an album:
"An error occurred with the publication of album <the name of the album>
Authentication with server failed. Please check your login and password information."

If I click the settings button, the Change Settings button is greyed out.
That's where the login and password go, no?* If I click Remove Account from iPhoto, wil that delete the facebook albums in iPhoto? It seemed that there was no way to change the password. (I wondered if the feature had been partly removed from iPhoto!)

I planned to try bradyh1's suggestions.

*NO! SOLUTION: The password settings are only accessible by clicking on the right kind of photo in order to make the "f" button visible and clickable, and then clicking it, and then pressing "Change Accounts". (Odd this isn't in Preferences!)
QUOTE Thanks
maccamenzies

 
Member Since: Nov 17, 2011
Posts: 2
maccamenzies is on a distinguished road

maccamenzies is offline
Here we are in 2012 and still no fix for the iphoto uploader problem.Or is it a facebook problem. Or is it a problem with the safari(but im using version 5).

Tried all the suggested fixes with no luck.

Any other comments???
QUOTE Thanks
chas_m

 
chas_m's Avatar
 
Member Since: Jan 22, 2010
Location: Victoria, BC
Posts: 17,546
chas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond repute
Mac Specs: Mid-2012 MBP (16GB, 1TB HD), BenQ second monitor, iPhone 5s 32GB, iPad Air 2 64GB

chas_m is offline
Well:

1. You're commenting on a thread that ended three years ago, and

2. I upload photos to Facebook fairly routinely using iPhoto '11 without any issues at all, so it's not a universal problem. iPhoto and Safari have nothing to do with each other.
QUOTE Thanks

Post Reply New Thread Subscribe


« WANTED: Secure password manager for OSX 10.9.5 please | Have Office 365 but my Macs are running 2011 can i upgrade »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
uploading from iPhoto does not work with Facebook Macswitcha OS X - Apps and Games 17 03-25-2009 10:44 AM
iPhoto launches when connecting camera kahlil88 OS X - Operating System 2 10-22-2008 04:58 AM
iPhoto Facebook plugin MattSharp OS X - Apps and Games 1 03-18-2008 04:24 PM
Preventing iPhoto opening when connecting iPhone EvoRoadster iPhone Hardware and Accessories 3 02-22-2008 11:19 AM
iphoto plug in for facebook riegeronimo Switcher Hangout 7 10-15-2007 01:06 AM

All times are GMT -4. The time now is 02:36 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?