Results 1 to 6 of 6
  1. #1

    shaun89's Avatar
    Member Since
    Apr 09, 2004
    Posts
    1,072
    iTunes copying each song to...
    Ok. So i unload my library of songs from my PC to my new mac through a CD. Everything finishes copying to the Music folder in the Finder sidebar. Then i open iTunes with an empty library. I go to the "add files to library", and select all my songs. They import, but now my music folder is twice it's size in Finder. It's because iTunes made it's own copy of each song. So now there are songs in the default Music folder in Finder, and all the same songs in the iTunes library folder in Finder.

    How do i make it so iTunes doens't copy each song?
    I don't recall this happening on my old PC...

    Thanks in advance.

  2. #2

    fearlessfreap24's Avatar
    Member Since
    Feb 09, 2005
    Location
    Soon to be DFW
    Posts
    2,339
    Specs:
    MacBook Pro 13" | MacBook Pro 13" | Mac Mini 2GHz C2D
    did you try to import the file to iTunes from the CD? Itunes, as i have found out(just like iPhoto), make its own library.

  3. #3

    iWhat's Avatar
    Member Since
    Nov 11, 2004
    Location
    Toledo, Ohio
    Posts
    5,736
    Specs:
    Macbook, iMac G5, iPad, iPhone 4, iPod (MANY)!
    Well, since you already have your mp3s on a CD, why not just erase every song in the library in the Finder and start over. Just reimport the mp3s into iTunes.

  4. #4


    Member Since
    Feb 28, 2005
    Location
    Bagshot, Surrey, UK
    Posts
    198
    Specs:
    Powerbook 17" 1.5GHz, 2GB, 160GB Momentus; iMac 24" 3.06GHz, 2GB; iPhone 2.5G 8GB; iPod 5G 60GB
    In iTunes Preferences, under Advanced, try unchecking "Keep iTunes Music Folder Organised". I've not tried this, but my understanding is that iTunes then leaves your music where you left it, instead of duplicating it into its own file structure.

    Please post if this works, as I'm interested to know if I'm right!

  5. #5

    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    28,898
    Specs:
    iMac 2010 27" QuadI7 OSX10.11, iMac 2008 OSX10.11, MBP Late2011OSX10.11 , iPad Air, iPhone 3GS
    It's not the "Keep ITunes Music Folder Organized" but the on the same Advanced tab, Uncheck "Copy Files to Itunes Music Folder When Adding to Library". Then it won't make dupes. The PC version has the exact same option.

  6. #6

    shaun89's Avatar
    Member Since
    Apr 09, 2004
    Posts
    1,072
    Thanks guys.... i uncheck that box, and re copyed my library and it worked... i freed up 900 mb with this. thanks again

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. iTunes Song Order
    By ASUGeog in forum Music, Audio, and Podcasting
    Replies: 1
    Last Post: 01-16-2009, 12:15 PM
  2. Most played song in iTunes...
    By moosegoose in forum iPod Hardware and Accessories
    Replies: 60
    Last Post: 05-19-2007, 03:47 PM
  3. Most played song in iTunes...
    By moosegoose in forum Schweb's Lounge
    Replies: 49
    Last Post: 05-03-2007, 01:14 PM
  4. Itunes - song info etc.???
    By iBlinded in forum OS X - Apps and Games
    Replies: 8
    Last Post: 11-27-2006, 09:22 AM
  5. Want a free iTunes song?
    By MacAddikt in forum Schweb's Lounge
    Replies: 49
    Last Post: 04-10-2005, 07:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •