Results 1 to 5 of 5
  1. #1

    Member Since
    Feb 04, 2009
    iWeb Templates Accidentally Deleted
    I have a website published with iWeb '08. I have since purchased and installed iWeb '09. Everything was fine until yesterday when I decided to delete thousands of duplicate pictures I have on my Mac/external hard drive (long story). I used Araxis' Find Duplicate Files & recommend it.

    The problem is that I accidentally deleted a few templates that came with iWeb '08 that I used to build my site. I have tried using Time Machine (twice) to go back to earlier times and restore iWeb. I have even uninstalled iWeb '09 and reinstalled it. But when I open iWeb, it still says I am missing files. For example, some of the files that are missing are: LayeredPaper_01.jpg, Creme_sidebar_frame__05.png, etc.

    Any help or suggestions would be greatly appreciated!! Thanks...

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    Restoring iWeb 08 from Time Machine backups may not restore the missing files if they were not included in part or part of the iWeb 08 folder or program. What you're going to need to do is use Spotlight to search through your Time Machine backups that you made prior to the installation of iWeb 09. When you find the files that are missing, restore them.


  3. #3

    muso's Avatar
    Member Since
    Jan 15, 2003
    Whangarei, New Zealand
    I've done a bit of searching and it looks like the template files are stored within the iWeb package itself, so it's weird that a restore of the iWeb application doesn't give you the templates. Same deal with a reinstall.

    Spotlight searching won't necessarily work, since it won't search in packages. Maybe as a test, go back to before you deleted the photos, go to /Applications/iWeb, right-click or control click the icon and select show package contents. Have a dig around in there and see if you can find the missing template files.
    I'm in your forums, writing sentences in a grammatically acceptable manner.

  4. #4

    Member Since
    Feb 04, 2009
    Thank you so much for the quick responses... I'm going to try everything you suggested and as soon as I get it figured out, I'll let you know what worked! Again, Thank you!

  5. #5

    Member Since
    Jun 04, 2010
    Same Issue...
    Hello, I am having the same issue. I reinstalled iWeb with a new Domain.sites2 file, there were no issues. Then, when I placed my Domain.sites2 file back, the same issue.

    Did you ever get this fixed? Any help would be appreciated!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Free iweb templates?
    By #14 in forum Web Design and Hosting
    Replies: 1
    Last Post: 06-09-2010, 12:47 PM
  2. I've accidentally deleted OS X
    By ACL in forum OS X - Operating System
    Replies: 2
    Last Post: 02-05-2010, 05:33 PM
  3. I accidentally deleted my OS :-(
    By onlyafrika in forum OS X - Operating System
    Replies: 16
    Last Post: 10-07-2008, 06:58 AM
  4. iWeb Templates & Themes - Christmas
    By maplecate in forum Web Design and Hosting
    Replies: 1
    Last Post: 11-17-2007, 09:05 PM
    By dancekiama in forum Web Design and Hosting
    Replies: 1
    Last Post: 03-22-2007, 12:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts