New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Apps and Games Discussion of applications and games available for Mac OS X.

Itunes is driving me nuts


Post Reply New Thread Subscribe

 
Thread Tools
rohan

 
rohan's Avatar
 
Member Since: Feb 24, 2008
Posts: 309
rohan is on a distinguished road
Mac Specs: 15" MacBook Pro 2.7 GHz Quad i7, 16GB | 27" iMac 3.1 GHz Quad i5 12GB| OS X.x | iPhone 4 iOS 7.1.2

rohan is offline
itunes seems to have some kind of bug (& its bugging me)...cover art on some of my albums disappeared...fine...i thought it was a minor issue...so i went & tried to apply the appropriate art manually...on some albums it worked fine...or others...it asks me if i want to...but once i click ok...it does nothing....i just cannot apply album art to a few albums anymore...no idea why! & these are albums which had album art & were all fine before!

what is even more annoying is that it seems to automatically change some of my album genres randomly....suddenly itunes think a lot of my music is "blues" & its really isn't!

anyone else having any problems like this?
please check!

any suggestions on how to fix this would be great...thanks

<< i can explain it to you...but i can't understand it for you... >>
QUOTE Thanks
rohan

 
rohan's Avatar
 
Member Since: Feb 24, 2008
Posts: 309
rohan is on a distinguished road
Mac Specs: 15" MacBook Pro 2.7 GHz Quad i7, 16GB | 27" iMac 3.1 GHz Quad i5 12GB| OS X.x | iPhone 4 iOS 7.1.2

rohan is offline
nobody has any suggestions?

btw...i noticed on more thing...if i try to apply album art to an individual track (from an album on which i cant) the album art shows up...but disappears as soon as i click on another track...

just thought id add that incase it helps figuring this thing out...

<< i can explain it to you...but i can't understand it for you... >>
QUOTE Thanks
chjata87

 
Member Since: Dec 01, 2008
Posts: 17
chjata87 is on a distinguished road

chjata87 is offline
As to the disappearing album art- how are you applying the new art? Have you tried selecting all of the tracks in the album then right clicking to view info, then dragging artwork into that window?
QUOTE Thanks
rohan

 
rohan's Avatar
 
Member Since: Feb 24, 2008
Posts: 309
rohan is on a distinguished road
Mac Specs: 15" MacBook Pro 2.7 GHz Quad i7, 16GB | 27" iMac 3.1 GHz Quad i5 12GB| OS X.x | iPhone 4 iOS 7.1.2

rohan is offline
yes...ive tried all possible methods...its just not happening...i also checked if the files were locked...they weren't...i cant figure out what i can do...the worst part is till recently all these albums had album art & were showing up fine...i cannot figure out what has changed...i did upgrade to the new version of itunes...i dont know if that made this mess...

is there any official place on the apple website where i can post this question or get support...apart from discussions...that never seems to work out...

<< i can explain it to you...but i can't understand it for you... >>
QUOTE Thanks
clarkspe

 
Member Since: Dec 23, 2008
Posts: 1
clarkspe is on a distinguished road

clarkspe is offline
I have a problem that seems simillar. Been using itunes for a year without much of a problem. I like to try to get the album artwork for all my tracks and went to lot of trouble getting it all in place. Shortly after the upgrade to version 8 a couple of months ago, I started to notice that odd pieces of artwork would disappear. In the last few days it seems to have gone totally insane. It doesn't matter if it's downloaded through Gracenote, or if its (say) copies from google images.... it's just randomly disappearing and driving me crazy. If anyone can offer any suggestions, I'd appreciate it.
QUOTE Thanks
dbnoise

 
dbnoise's Avatar
 
Member Since: Dec 21, 2008
Posts: 314
dbnoise will become famous soon enough

dbnoise is offline
I'd try reverting back to itunes 7 and wait for an update for itunes 8 that fixes the bugs.
QUOTE Thanks

Post Reply New Thread Subscribe


« Record PhotoBooth video? | Mail Update 1.0 or OS X.5.6 »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Apple Releases iTunes 4, QT 6.2, and iPod Update schweb Apple Rumors and Reports 2 12-17-2008 02:47 AM
Proper way to reload iTunes library? pmouts Music, Audio, and Podcasting 0 11-03-2007 12:01 AM
iTunes & Shapeshifter Not Compatible? MacBurg OS X - Apps and Games 2 07-02-2007 10:10 PM
Accessing iTunes music on my PC dang0001 iPod Hardware and Accessories 0 06-30-2007 01:08 PM

All times are GMT -4. The time now is 08:21 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?