ibook G4 running OS X 10.4.11

From what I can work out, it looks like colloquy is having difficulty communicating with the IRC server I want it to.

I'll be on IRC, chatting or idling and it'll suddenly stop receiving messages, so it looks as if no-one is doing anything, the strange thing is that it seems to be sending my messages although they don't show on my screen(It's making me look like I'm being rude and ignoring everyone xD).

It is not this error:
KnownIssues - Colloquy - Trac
As it's not indicating that there are new messages/actions at all, although I have tried that solution anyway(didn't work).

When it happens, the console window has messages like this:

PING [servername]
PONG [servername]
(It should auto connect to some channels here, but it doesn't)

or it just keeps pinging
or it connects to some of the channels and stops, etc.

As my messages seem to be getting through, I'm assuming that it's still connected, it just thinks it isn't.

But...If I close the program and re-open it, it connects fine(for a while).

It's a new error(started yesterday) and I haven't made any changes that could have affected colloquy(I've also removed and reinstalled it a couple of times to see if that might work), so I'm not sure if it's even an issue with Colloquy at all, but there's nothing wrong with the server I'm on.

My internet connection seems okay, I can still browse the web as normal, use Adium, etc.

Stuff I've tried:
-removing and re-installing colloquy twice(from a fresh download each time)
-restarting my ibook
-Checking the preferences for anything obvious looking
-Checking the server is functioning okay for everyone else

I think that's everything...halp?