Results 1 to 4 of 4
  1. #1


    Member Since
    Dec 06, 2006
    Posts
    409
    HELP! Why doesnt iMovie 7 work with Mac OSX???
    when i try to open i movie 7 it tells me
    "you cannot use this version of imovie with this version of mac osx" ???

    what gives?

  2. #2

    Lifeisabeach's Avatar
    Member Since
    Sep 30, 2007
    Location
    The Republic of Neptune
    Posts
    7,740
    It would help if you'd tell us:

    1: What version of iMovie you have
    2: Where you got it from
    3: What version of Mac OS X you have

    Please verify and include the exact model/year of your Mac and OS X version number (available from "About This Mac", then "More Info" on the Apple menu).
    ------
    Links: Onyx | EasyFind | Apple Hardware Test | How to test your hard drive | The Safe Mac Adware Removal Guide | Uninstall MacKeeper
    ------
    Lifeisabeach - Mac-Forums Member of the Month June 2009, Feb 2012, and March 2013.

  3. #3


    Member Since
    Dec 06, 2006
    Posts
    409
    Quote Originally Posted by lifeisabeach View Post
    It would help if you'd tell us:

    1: What version of iMovie you have
    2: Where you got it from
    3: What version of Mac OS X you have
    its imovie 7 ...

    i hav mac os X 10.5.3

    my friend updated my computer with the new leopard thing and installed the new ilife..

  4. #4

    Lifeisabeach's Avatar
    Member Since
    Sep 30, 2007
    Location
    The Republic of Neptune
    Posts
    7,740
    Run Software Update... you should see an update for iMovie there. Make sure iMovie is in the Apps folder... not a subfolder.

    Please verify and include the exact model/year of your Mac and OS X version number (available from "About This Mac", then "More Info" on the Apple menu).
    ------
    Links: Onyx | EasyFind | Apple Hardware Test | How to test your hard drive | The Safe Mac Adware Removal Guide | Uninstall MacKeeper
    ------
    Lifeisabeach - Mac-Forums Member of the Month June 2009, Feb 2012, and March 2013.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. AV cable doesnt work ?
    By erdemd in forum iPod Hardware and Accessories
    Replies: 3
    Last Post: 09-02-2011, 09:03 AM
  2. Copy paste doesnt work as it used to work on windows :x
    By log_out in forum Switcher Hangout
    Replies: 0
    Last Post: 12-30-2008, 09:32 AM
  3. Whats uo with MobileMe and .Mac? Doesnt work for me.
    By Spartan117 in forum Switcher Hangout
    Replies: 5
    Last Post: 07-11-2008, 09:15 PM
  4. JVC Everio doesnt work in imovie
    By bigmof in forum Movies and Video
    Replies: 3
    Last Post: 06-11-2007, 03:45 PM
  5. Replies: 2
    Last Post: 12-14-2005, 12:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •