Results 1 to 4 of 4
  1. #1

    Member Since
    Jan 04, 2008
    Cannot Install The Sims. Help!
    2.2ghz MacBook
    OS_X 10.5.4

    So after installing "The Sims Complete" DVD, I try to open the application and get the following error message stating, "The Sims Complete requires Read/Write access to the "User folder". It go's on to say:

    ..."The current user does not have Read/Write privileges. Install The Sims Complete on this user or another user with sufficient privileges."

    I am the only user on this computer, the "user data" folder is read/write (I even went back and unchecked/then checked it again), and I can't figure out why this will not open.

    Anyone with any help would be greatly appreciated! Thanks.

  2. #2

    Member Since
    Jan 04, 2008
    Solved! The ole' uninstall and re-install. I guess a file wasn't copied right in the initial process.

    Thanks Guys!

  3. #3

    Member Since
    Jan 04, 2008
    Well, I thought that solved the problem. It did, for one sitting. The G/F went to play it again today and it displayed the same error. I guess I will call tech support Monday, but any help in the meantime would be much appreciated.


  4. #4

    Lifeisabeach's Avatar
    Member Since
    Sep 30, 2007
    The Republic of Neptune
    Download ACL Fix and run that. With its drop-window open, drag and drop your home folder on it, then click "Fix". Hopefully that will do the trick.

    Please verify and include the exact model/year of your Mac and OS X version number (available from "About This Mac", then "More Info" on the Apple menu).
    Links: Onyx | EasyFind | Apple Hardware Test | How to test your hard drive | The Safe Mac Adware Removal Guide | Uninstall MacKeeper
    Lifeisabeach - Mac-Forums Member of the Month June 2009, Feb 2012, and March 2013.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Install Sims 1 on Mac
    By dolliest_chelle in forum Apple Desktops
    Replies: 3
    Last Post: 02-10-2013, 08:06 PM
  2. Botched Sims 3 Install Taking Up Space
    By beebie in forum Apple Notebooks
    Replies: 2
    Last Post: 07-13-2010, 06:46 AM
  3. The Sims (original) - can't install on OSX
    By RONE in forum OS X - Apps and Games
    Replies: 0
    Last Post: 08-09-2007, 04:54 PM
  4. Install The Sims 2 PC version on Mac Book?
    By siaku in forum Switcher Hangout
    Replies: 5
    Last Post: 09-03-2006, 04:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts