Results 1 to 4 of 4
  1. #1

    Member Since
    Aug 24, 2008
    Error when installin on mac OS X
    Hi guys,

    I tried to install wine on mac OS X but got below error. Please tell me how to resolve it and get wine installed.

    1) I installed MacPorts-1.6.0-10.5-Leopard. That was installed successfully.
    2) Then in terminal i ran below command.
    sudo port install wine
    3) Then i got below error.

    ---> Configuring expat
    Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/ _release_ports_textproc_expat/work/expat-2.0.1" && ./configure --prefix=/opt/local --mandir=/opt/local/share/man " returned error 77
    Command output: checking build system type... i386-apple-darwin9.2.1
    checking host system type... i386-apple-darwin9.2.1
    checking for gcc... /usr/bin/gcc-4.0
    checking for C compiler default output file name... configure: error: C compiler cannot create executables
    See `config.log' for more details.

    Please help me

    Error: The following dependencies failed to build: expat fontconfig freetype zlib libiconv gperf fontforge gettext ncurses ncursesw giflib jpeg libpng libxml2 autoconf help2man p5-locale-gettext perl5.8 m4 libtool automake tiff libxslt openssl pkgconfig render xrender
    Error: Status 1 encountered during processing.

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    What do you need WINE for? Even if you get WINE installed correctly it can be troublesome. If you need to run certain Windows programs the best solution may be to use Parallels or Fusion.

    But, if you really want or need to install WINE, follow these directions:


  3. #3

    lifeafter2am's Avatar
    Member Since
    Aug 25, 2006
    Central Florida
    MacBook Pro Unibody
    I love how everyone hates on WINE, lol. I use it almost everyday to run little stupid .exe's, installing and maintaing a Windows system via Parallels etc is too much of a hassle.

    Anyway ... do you have your $PATH set correctly? If it is looking for libraries and such that MacPorts uses and your $PATH isn't set correctly it will fail. You obviously have the Developer Tools installed with GCC, since it finds it, but I can't think of why it wouldn't be able to create an executable.
    masakatsu agatsu


  4. #4

    Member Since
    Aug 24, 2008

    For parallels we need to have windows installed and i don't have.

    In the terminal I first set the path like this.

    echo export PATH=\$PATH:/opt/local/bin:/opt/local/sbin$'\n'export MANPATH=\$MANPATH:/opt/local/man | sudo tee -a /etc/profile

    and the result after entering the admin password is

    export PATH=$PATH:/opt/local/bin:/opt/local/sbin
    export MANPATH=$MANPATH:/opt/local/man

    So, i guess all the path are set correctly? Is it of some help?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Warcraft 3 Frozen Throne Error Building Click error
    By Elayne in forum OS X - Apps and Games
    Replies: 0
    Last Post: 12-18-2011, 02:12 PM
  2. installin windows 7
    By pastle in forum Running Windows (or anything else) on your Mac
    Replies: 1
    Last Post: 12-01-2009, 01:52 PM
  3. Entourage:mac -16997 error mac OX Tiger
    By starfish2000 in forum OS X - Apps and Games
    Replies: 0
    Last Post: 10-09-2009, 07:00 AM
  4. Mac OS error?????
    By mphubbar in forum OS X - Operating System
    Replies: 2
    Last Post: 07-17-2008, 12:48 AM
  5. Installin MAC OS to a MacBook Pro
    By utawakevou in forum OS X - Operating System
    Replies: 4
    Last Post: 04-30-2007, 10:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts