New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Apps and Games Discussion of applications and games available for Mac OS X.

Problem word:mac 2008 language settings


Post Reply New Thread Subscribe

 
Thread Tools
frike

 
Member Since: Apr 01, 2008
Posts: 9
frike is on a distinguished road

frike is offline
I've recently started learning Russian and wanted to make a table in Word containing a vocabulary list.
Now, I do have the Russian keyboard and I can switch between the russian and (my usual) german keyboard in the menu.

This usually works fine, also when I write a text in word.

However, when i create a table and my russian keyboard is selected, it imediately switches back to german once I leave the first 'box' of the table.

Is there any way I can change the settings in word, so that it is set to Russian and stays that way?

Any help is aprreciated!
QUOTE Thanks
MacMan7

 
Member Since: Aug 23, 2008
Location: Salt Lake City, UT
Posts: 7
MacMan7 is on a distinguished road
Mac Specs: iMac 2GHz, Intel Core Duo; Mac OSX 10.5.4

MacMan7 is offline
I'm see that someone else is having the same problem as I am. When I write Russian in WORD it keeps changing back to my initial language (English), almost at random. I'm looking for a way to lock the text in Russian rather than going back every minute to change the little flag at the top of the screen back to Russian when it switches to American English.
If I find the answer first, I'll let you know. If you find a solution, please let me know, and together we'll solve this stupid problem.

By the way, when you're typing Russian, have you found that your Russian font has no period? That is extremely frustrating. The Russian font that comes with the OSX 10.5 has no period. They must think that the Russians never take a breath after each sentence (and, I know, it sometimes sounds that way!) Желаю вам успеха!
QUOTE Thanks
MacMan7

 
Member Since: Aug 23, 2008
Location: Salt Lake City, UT
Posts: 7
MacMan7 is on a distinguished road
Mac Specs: iMac 2GHz, Intel Core Duo; Mac OSX 10.5.4

MacMan7 is offline
Hi, Frike,

I found at least a partial solution to your problem (and mine).
If you are typing in WORD and set up a table with two columns, you can type Russian in one and German (or English) in the other. HOWEVER, you must type each column separately, for the entire length of the column. THEN you can go back and type the other column in the same way.

Here's how you do it:

1) Ensure that you have both German and Russian selected in the "International" section of "System Preferences" as languages that you entend to use
2) Open a new document in WORD.
3) Create the table in a format you desire.
4) Select from the FONT menu the CS Roman Cyrillic font.
5) When you want to enter Russian words, say in the left column, select that language by going to the small flag icon at the top of the screen. It has a drop-down menu with "English," "English Extended," "Russian," "German," and whatever other languages you have selected in "System Preferences." Select "RUSSIAN" from the list.
6) Move your cursor to the row and column in which you intend to type in Russian. Type your COMPLETE COLUMN of Russian words, phrases, etc., without trying to add anything in a neighboring column.
7) Go back to the first row and the column which you intend to type in German. Select "German," or if you want the other column to be in English, select the "ENGLISH EXTENDED" flag from the drop-down menu described above. In that case, don't select "ENGLISH" BUT "ENGLISH EXTENDED."
8) Move the cursor to the column you want to type in German and proceed down the column. All words will then be in the language you select.

This method is not as handy as it would be if you could add both the Russian and the German (one after the other) on the same row. But at least it's a work-around until someone can figure out how to do it otherwise.

Желаю вам успеха!

MacMan7
QUOTE Thanks
frike

 
Member Since: Apr 01, 2008
Posts: 9
frike is on a distinguished road

frike is offline
Thanks, but it doesn't completely work for me.
Maybe it's because I don't have the font CS Roman Cyrillic,but this method only works for me if I only have one row that extends as I type.
If I make a table with two collums and more than one row, it jumps back to German as soon as I select the row below the first one, even if I don't select the other collum, or try to type anything there.

I just do without tables now, type the entire words in Russian and then add the German translations.

Oh, and you can find the period on shift + 7  
QUOTE Thanks
thomasdenhaan

 
Member Since: Jan 17, 2009
Posts: 1
thomasdenhaan is on a distinguished road

thomasdenhaan is offline
Hi!

I was having the same problem as you do now, and I found a solution. Go to the Preferences menu, then to Edit, and then uncheck the box named 'Match font with keyboard'. It solved the problem on my computer, so I guess it will do so on yours as well. Good luck!

Thomas
QUOTE Thanks

Post Reply New Thread Subscribe


« Mac settings for WoW connectivity | I need to archive and install. How do i transfer applications from my external drive? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Intermittent Startup Problem (hardware) j3sp Apple Desktops 3 05-19-2008 11:50 AM
Language problem 11213 Switcher Hangout 2 04-21-2006 03:48 AM
language problem with Outlook Exp..help Zippy Running Windows (or anything else) on your Mac 3 09-02-2005 06:07 PM
HELP wierd iMac startup problem iluvmacs Apple Desktops 8 09-13-2004 07:47 AM
G5 Video problem WilliS Apple Desktops 3 05-05-2004 10:16 AM

All times are GMT -4. The time now is 12:53 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?