Results 1 to 3 of 3
  1. #1


    Member Since
    Jun 06, 2008
    Posts
    2
    Please, need help with Nicotine+
    I've been trying to install Nicotine+ on my Intel Mac. Everything seems to install fine, but when I go to run nicotine I get the following error.

    Nicotine supports "psyco", an inline optimizer for python
    code, you can get it at http://sourceforge.net/projects/psyco/

    Can not find required PyGTK. The current search path is
    ['/Users/ryanfortier/nicotine+', '/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python23.zip', '/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3', '/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/plat-darwin', '/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/plat-mac', '/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/plat-mac/lib-scriptpackages', '/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/lib-tk', '/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/lib-dynload', '/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/site-packages', '/System/Library/Frameworks/Python.framework/Versions/2.3/Extras/lib/python']


    I've been searching everywhere on how to fix this and have yet to find a solution, partially because most of the forums containing this problem are for Linux.

    I have run Nicotine 1.0.8, but the bugs have gotten me away from it and figured I would try Nicotine+. If all else fails I guess I could try SoulseeX, but the UI keeps doesn't thrill me.

    Thank you in advance

    p.s. I'm fairly n00bish.

  2. #2


    Member Since
    Jun 06, 2008
    Posts
    2
    I Installed PyGTK using Darwin according to the instructions here http://nicotine-plus.sourceforge.net...allation-Apple

    I am now trying to install it using MacPorts but run into little errors here and there. Cleared them up until:

    *** A new enough version of pkg-config was not found.
    *** See http://www.freedesktop.org/software/pkgconfig/
    configure: error: maybe you want the pygobject-2-4 branch?

    Error: The following dependencies failed to build: py25-gtk py25-gobject
    Error: Status 1 encountered during processing.


    downloaded pkgconfig and followed instructions, when it comes to "make install" I get the following:

    /bin/sh ./mkinstalldirs /usr/local/bin
    mkdir -p -- /usr/local/bin
    mkdir: /usr/local: Permission denied
    make[2]: *** [install-binPROGRAMS] Error 1
    make[1]: *** [install-am] Error 2
    make: *** [install-recursive] Error 1


    Thats currently where i am stuck now, if you could help with this that would be great too.

  3. #3


    Member Since
    Feb 09, 2009
    Posts
    1
    nicotine+
    Quote Originally Posted by fluno24 View Post
    mkdir: /usr/local: Permission denied
    make[2]: *** [install-binPROGRAMS] Error 1
    make[1]: *** [install-am] Error 2
    make: *** [install-recursive] Error 1[/COLOR]

    Thats currently where i am stuck now, if you could help with this that would be great too.
    Do make install as a root (Admin) account.

    See:
    How to Enable the "root" Account on Mac OS X

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. nicotine+ on a 2005 powerbook
    By v0llrath in forum OS X - Apps and Games
    Replies: 0
    Last Post: 08-08-2014, 10:07 AM
  2. P2P-Nicotine ??
    By robbiemullen in forum Switcher Hangout
    Replies: 0
    Last Post: 05-17-2006, 04:20 PM
  3. nicotine p2p
    By jkritch in forum OS X - Apps and Games
    Replies: 0
    Last Post: 09-09-2005, 11:52 PM
  4. Help installing Nicotine, Fink, & Soulseek for OS 10.3.9
    By munkism in forum OS X - Apps and Games
    Replies: 2
    Last Post: 08-17-2005, 08:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •