Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   OS X - Apps and Games (http://www.mac-forums.com/forums/os-x-apps-games/)
-   -   Problem with Mail need help! (http://www.mac-forums.com/forums/os-x-apps-games/102923-problem-mail-need-help.html)

Josh_MacMan 03-31-2008 12:26 AM

Problem with Mail need help!
 
I've been using Mail for a while now without issue but today I went to look at some older emails maybe one month old and notice everything from about 3 weeks ago and older is blank, the emails are listed with subjects intact but when I open them they are totally blank...
I really need to access the information in these emails any help would be greatly appreciated. I have not made any changes to anything in quite a while so I'm not sure whats up.

Ok, heres an update on something I did just after posting this, I imported everything from mail to entourage (which I never used) and everything is fine, so why is mail not showing my older emails properly...

sbvishal 03-31-2008 09:13 AM

Reply
 
May be there was some setting regarding keeping the mail for a predefined time and you set it to 3 weeks

Thanks

Quote:

Originally Posted by Josh_MacMan (Post 625200)
I've been using Mail for a while now without issue but today I went to look at some older emails maybe one month old and notice everything from about 3 weeks ago and older is blank, the emails are listed with subjects intact but when I open them they are totally blank...
I really need to access the information in these emails any help would be greatly appreciated. I have not made any changes to anything in quite a while so I'm not sure whats up.

Ok, heres an update on something I did just after posting this, I imported everything from mail to entourage (which I never used) and everything is fine, so why is mail not showing my older emails properly...


Josh_MacMan 03-31-2008 10:28 AM

Could be, but I kinda doubt that, I figured if something like that was enabled the emails wouldn't be there at all but I'll take a look at that tonight.

Soulwar 03-31-2008 11:16 AM

First, have you tried the Rebuild command? (under Mailbox menu)

You can also go to homefolder~Library/Mail/your Account/(inbox, sent, etc..)/messages and select them there. (long way, but good to know) ;)

Josh_MacMan 03-31-2008 03:51 PM

Soulwar, I haven't tried that, I will when I get home tonight.

Josh_MacMan 03-31-2008 06:27 PM

I did the rebuild command and all those messages are now gone, they dont even show up...plus i dont see anywhere where I set Mail to delete any messages after a certain amount of time....

ugh this is terrible I am missing so much email now...this is not good at all, so only email from 3/10/2008 and newer is showing....wheres my last years worth of email?!!?!?!? ugh!

Josh_MacMan 04-02-2008 02:54 PM

No one else has any other input? I have a hard time believing at least a years worth of email just disappeared. I'm afraid to even use Mail anymore.

Soulwar 04-02-2008 05:14 PM

Did you follow the path I posted and see if they are still there?
Maybe post all your mail settings and see if we can't find the problem. If everything is set properly, something may have become corrupted.

Josh_MacMan 04-02-2008 06:36 PM

I did check the path and the only emails listed are the ones in mail, so all the missing emails are also missing from that folder as well...

m2nk2 04-03-2008 07:46 AM

I have the exact same problem. But for me its all mails except the ones i recieved today. I can see the topic etc, but i can't see the message it self. And i really really need to read one of the mails.

Has anyone, i haven't really tried anything yet as i don't want to lose the mails completely.

Aptmunich 04-03-2008 08:18 AM

How do you access your mails, via POP or IMAP?
Which provider?

Josh_MacMan 04-03-2008 08:36 AM

It's POP and it's through my website host. Mail was set up to just download all the emails and set not to leave any on the server.

Aptmunich 04-03-2008 11:00 AM

Quote:

Originally Posted by Josh_MacMan (Post 627525)
It's POP and it's through my website host. Mail was set up to just download all the emails and set not to leave any on the server.

Hmm weird...

Oh well, just restore them from your Time machine backup!

m2nk2 04-03-2008 11:02 AM

Quote:

Originally Posted by Aptmunich (Post 627580)
Hmm weird...

Oh well, just restore them from your Time machine backup!

Haven't got one :/

Josh_MacMan 04-03-2008 11:55 AM

Yeah, that is my problem as well. I started using Time Machine and then went back to doing regular full backups of my HD, and by the time I realized the problem my backup had the same issue because I overwrite my backups after a certain amount of time. Now I am using Time Machine again as I figure'd it would have saved me from this issue.

It just bothers me that this has happened in the first place and I cannot figure out why. I work in IT and I am very diligent when it comes to taking care of my computers and usually when someone says "something disappeared" it is usually user error, however in my case I am almost completely sure I did nothing wrong to cause this.


All times are GMT -4. The time now is 02:34 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.