New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
OS X - Apps and Games Discussion of applications and games available for Mac OS X.

Mail Filters...


Post Reply New Thread Subscribe

 
Thread Tools
The Tsar

 
Member Since: May 13, 2007
Posts: 34
The Tsar is on a distinguished road

The Tsar is offline
So....I am having trouble with my "hard delete" filter in Mail (I'm using Leopard). This is what my filter looks like:

If any of the following conditions are met:

To Contains rsfc@domain.com

Perform the following actions:

Move Message to Trash
Delete Message
Stop Evaluating Rules


But the message keeps showing up in my Spam folder instead of the Trash folder. I've also got a few other things in my "hard kill" rule such as the words "Viagra" and similar stuff, but they still get through.

What am I doing wrong? Why aren't the rules catching these even after I have defined them?
QUOTE Thanks
hndcvcboi

 
hndcvcboi's Avatar
 
Member Since: Sep 07, 2007
Posts: 126
hndcvcboi is on a distinguished road
Mac Specs: iMac 24" 2.8Ghz 4GB LEOPARD

hndcvcboi is offline
Quote:
Originally Posted by The Tsar View Post
So....I am having trouble with my "hard delete" filter in Mail (I'm using Leopard). This is what my filter looks like:

If any of the following conditions are met:

To Contains rsfc@domain.com

Perform the following actions:

Move Message to Trash
Delete Message
Stop Evaluating Rules


But the message keeps showing up in my Spam folder instead of the Trash folder. I've also got a few other things in my "hard kill" rule such as the words "Viagra" and similar stuff, but they still get through.

What am I doing wrong? Why aren't the rules catching these even after I have defined them?
Why not just delete the message directly and not even have to move it to trash first? That is how mine is setup and it seems to work.
QUOTE Thanks
The Tsar

 
Member Since: May 13, 2007
Posts: 34
The Tsar is on a distinguished road

The Tsar is offline
Quote:
Originally Posted by hndcvcboi View Post
Why not just delete the message directly and not even have to move it to trash first? That is how mine is setup and it seems to work.
I've tried that. What it does is, it sends it to my Spam folder instead of deleting it. I wonder whether there is some conflict with Spam Sieve?
QUOTE Thanks
hndcvcboi

 
hndcvcboi's Avatar
 
Member Since: Sep 07, 2007
Posts: 126
hndcvcboi is on a distinguished road
Mac Specs: iMac 24" 2.8Ghz 4GB LEOPARD

hndcvcboi is offline
Quote:
Originally Posted by The Tsar View Post
I've tried that. What it does is, it sends it to my Spam folder instead of deleting it. I wonder whether there is some conflict with Spam Sieve?
Do you have all the latest updates? I was having trouble with it until 10.5.2 came out.

Also, there are at least 2 possible ways to make this work. One is under the Junk Mail Advanced settings and the other is to create a rule. Mine is setup in the Junk Mail Advanced settings.
QUOTE Thanks
Kilted1

 
Kilted1's Avatar
 
Member Since: Sep 22, 2006
Location: Norway
Posts: 1,133
Kilted1 is just really niceKilted1 is just really niceKilted1 is just really niceKilted1 is just really niceKilted1 is just really nice
Mac Specs: 2 iMacs 17+20" 2.16GHz 2GB RAM 500MB HDD 256MB Graphic card. 60Gig 5th gen iPod with Video

Kilted1 is offline
If you are using spam sieve maybe it's in conflict with mail. I have used SS for over a year now and let it take care of my spam. It dumps it in the spam folder and I trash it from there.

Go to the mail pref pane and under Rules uncheck any rule that isn't spam sieve.
I have never had to make any complicated rules for my mail I just let Spam sieve do it for me

Now with Leopard

I was Member of the month April 08
QUOTE Thanks

Post Reply New Thread Subscribe


« Clear Google search | iPhoto .mac sign-in not working »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Mail mycough OS X - Apps and Games 4 09-20-2009 08:24 PM
My Mail isn't working! dragonflame8184 OS X - Apps and Games 2 04-12-2007 02:38 PM
Mail question fasheezy OS X - Apps and Games 2 01-29-2007 01:57 PM
Mail Mail, oh my poor mail... Steve1 OS X - Apps and Games 0 05-12-2006 10:14 AM
Mail Folder "exclusively locked" by user klippe OS X - Apps and Games 3 09-06-2005 08:20 PM

All times are GMT -4. The time now is 07:25 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?