Results 1 to 7 of 7

Thread: Garageband sux

  1. #1


    Member Since
    Oct 03, 2009
    Posts
    9
    Garageband sux
    So, how am I supposed to record and overdub with garageband when the playback has a slight delay. It is impossible to play like this. Garageband sux. Its really not made to do home recording other than using the samples I guess.

    I hate it. Is there any way to get rid of the delay. When I hit a note on the guitar or keyboard the playback has a delay and it is IMPOSSIBLE to follow the metronome.

  2. #2

    chrmoody's Avatar
    Member Since
    Dec 28, 2009
    Location
    Texas
    Posts
    16
    What kind of Mac do you have? It could be a wiring error. What kind of set up you have, provide more info dude.

    You using a mixer? Is it Firewire, or through line in, are you using a direct connect, or have a subline box to go through, whats up?

    I use my 27" iMac for producing, got a 24 channel mixboard, firewire box, etc.. I use Logic for everything, but I have used Garageband before without any problems.

    As far as the metronome, if you can figure out what the source is of your troubles, it'll be easier to follow. I usually turn the metronome off, and provide my own click track via program like Fruity Loops Studio
    "do what you like, like what you do"
    Apple Arsenal: 27" iMac, Macbook Pro 13.1", iPad, Mac Mini, iPod Touch, Shuffle
    Used Mostly For: Music/Video Production, Work, Utility

  3. #3


    Member Since
    Oct 03, 2009
    Posts
    9
    Leopard version 10.5.8
    Quote Originally Posted by chrmoody View Post
    What kind of Mac do you have? It could be a wiring error. What kind of set up you have, provide more info dude.

    You using a mixer? Is it Firewire, or through line in, are you using a direct connect, or have a subline box to go through, whats up?

    I use my 27" iMac for producing, got a 24 channel mixboard, firewire box, etc.. I use Logic for everything, but I have used Garageband before without any problems.

    As far as the metronome, if you can figure out what the source is of your troubles, it'll be easier to follow. I usually turn the metronome off, and provide my own click track via program like Fruity Loops Studio
    Ok, here are some specifics. 4 gigs of ram, 320 gig hd. Leopard 10.5.8. I use a converter jack that plugs in usb to the mac. Its just a usb connection, basically guitar goes direct.


    When I initially record its dead on but if I have to re-record a track when I play a note on the guitar there is a delay before I hear it coming out of the speakers.

    Yes, I turn off the metronome also. Its totally impossible to overdub a second track because I can't follow with the echo. I can turn the volume down and just hear the guitar but I want to hear what Im playing over the system.

    I can't figure it out but so far garageband is turning out to be crap band.

  4. #4

    chrmoody's Avatar
    Member Since
    Dec 28, 2009
    Location
    Texas
    Posts
    16
    Interesting...

    Granted I never really use Garage Band, Logic fan myself. But I never had issues you like that, even when layering up to 20 to 30 tracks.

    Hmm, good GPU? dual chip kinda thing?
    "do what you like, like what you do"
    Apple Arsenal: 27" iMac, Macbook Pro 13.1", iPad, Mac Mini, iPod Touch, Shuffle
    Used Mostly For: Music/Video Production, Work, Utility

  5. #5

    zacman's Avatar
    Member Since
    Feb 23, 2006
    Location
    Barbados
    Posts
    143
    Specs:
    PowerBook G4, 1.5Ghz, 768Mb RAM, 80gb hard drive-imac G4-ipod touch 32Gb 3g-Macbook 2.4ghz, 2BG RAM
    Go into Garageband>preferences>audio/midi>select 'minimum delay when playing instruments live'.

  6. #6

    Aptmunich's Avatar
    Member Since
    Mar 09, 2004
    Location
    Munich
    Posts
    9,073
    Specs:
    Aluminium Macbook 2.4 Ghz 4GB RAM, SSD 24" Samsung Display, iPhone 4, iPad 2
    The delay is unavoidable, but the length of the delay is determined by the audio interface you're using.

    I can record and overdub just fine with the setup I use, so I'd suggest you play around with your setup and settings a bit.

    Is the audio interface connected directly or to a hub? Do you have a lot of other USB peripherals connected? All factors that could slow down the data rate...

  7. #7


    Member Since
    Oct 03, 2009
    Posts
    9
    will try
    Quote Originally Posted by zacman View Post
    Go into Garageband>preferences>audio/midi>select 'minimum delay when playing instruments live'.
    I will try that, thanx.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. garageband?
    By adz in forum OS X - Apps and Games
    Replies: 1
    Last Post: 02-24-2009, 05:53 PM
  2. Safari Sux :(
    By soundsystem00 in forum Switcher Hangout
    Replies: 22
    Last Post: 10-16-2007, 09:53 PM
  3. Help with GarageBand 08
    By blinkdude182 in forum OS X - Apps and Games
    Replies: 0
    Last Post: 08-25-2007, 06:01 PM
  4. this sux but is kinda funny......
    By munkism in forum Movies and Video
    Replies: 0
    Last Post: 09-12-2005, 09:04 AM
  5. iSkin EVo2 sux
    By Texasmeat in forum iPod Hardware and Accessories
    Replies: 11
    Last Post: 06-26-2005, 10:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •