I've had my setup working properly for over a year now, and within the last month or so it decided to quit working. I have a Macbook with OSX 10.5.8, and my controller keyboard (Yamaha S80) is hooked up to it via M-Audio MIDISport 2x2. I have my MIDI cables hooked up properly, and Audio MIDI Setup (under Utilities) recognizes both my MIDI interface and my keyboard, and I get a positive result from the "test connection" button. I've got line-in selected under system prefs, and in the Garageband preferences I've set it to line-in as well. Garageband tells me that 2 MIDI inputs are detected, yet it does not show any MIDI input (when I play the keys I get no sound or signal indication from the software instruments). My volume sliders are on in GB (when I try the "musical typing" feature I get sound from the software instruments). I've downloaded the latest driver for my M-Audio interface (3.4.0 off of the MAudio website) and rebooted. I've repaired disk permissions (and rebooted), I've deleted the Garageband Preference files (and rebooted GarageBand FAQ: Odd Ball Probs), and still no luck. I've updated my software, reloaded programs, and nothing seems to work. I feel like I've tried everything... Does anybody have any ideas?