Results 1 to 5 of 5

Thread: itunes 9 libary cannot be saved

  1. #1

    Member Since
    Oct 25, 2009
    Unhappy itunes 9 libary cannot be saved
    i keep on getting an error for itunes

    the itunes library file cannot be saved.An unknown error occurred (-48)

    i tried changing folder and file permissions but that didn't work. And my computer has been starting up really slowly since this started, and has been sluggish.(Also i cannot get to, nor the itunes store, i wonder if it has something to do with genius. in fact ill turn it off see if that helps)

    also i am using itunes 9.0.1 on a 2 ghz aluminum macbook, and i recently upgraded my HDD, but it was working before the problem started.

    any help would be greatly appreciated

  2. #2

    Member Since
    Oct 25, 2009
    lol i closed it and restarted it to see if the genius idea worked, and now i get

    the itunes application could not be opened. An unknown error occurred (13014)

    tried it twice and on the third time it opened. wtf

    ANd i turns out the genius idea didn't work

  3. #3

    memopad's Avatar
    Member Since
    Feb 18, 2009
    I got the same error for the itunes... unknown error occurred (13014)
    Can any one help?

  4. #4

    memopad's Avatar
    Member Since
    Feb 18, 2009
    Solved... here is how...
    Had the same issue. My iTunes Library is located on a NAS and after a recent restart, I got the 13014 error when attempting to start iTunes. Following the suggestions in this thread, I deleted the following two Genius related files in my iTunes Library folder:

    iTunes Library Genius.itdb
    iTunes Library Genius.itdb-journal

    Once they were removed, iTunes started up without issue. No restart necessary.
    I know it's a repeat of the previous suggestion, but I hope this helps.

  5. #5

    Member Since
    Feb 07, 2010
    I have been trying to find a solution to this problem for months (heres to hoping for an Apple update fix). Thanks memopad for a successful solution.

    Also, I found that the iTunes Library Genius.itdb file can stay. It seems to be just files with the extension *.itdb-journal that cause the problem. This includes any other files with that extension, not just Genius files (eg, I had to delete the file iTunes Extras.itdb-journal). As far as I can tell, the problem is with the journaling function of Mac OS formatted drives (HFS+), which windows format drives (such as FAT32 and DOS) do not support.

    My drive was a network attached FAT32 drive, accessed from a Mac, however NAS HFS+ drives worked fine, and the FAT32 drive had the same problems when connected directly via USB. It would seem that this problem would be specific to a setup with a non-HFS drive used by iTunes run from a mac.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Where is iTunes Libary
    By robpopper in forum Switcher Hangout
    Replies: 20
    Last Post: 10-07-2014, 06:35 PM
  2. itunes 9 libary cannot be saved
    By Frezzingaces in forum Music, Audio, and Podcasting
    Replies: 1
    Last Post: 10-29-2009, 02:50 AM
  3. Itunes Libary dissappeared!!
    By JMG1983 in forum iPod Hardware and Accessories
    Replies: 0
    Last Post: 05-12-2007, 08:42 AM
  4. Problem with my itunes libary being split into 2
    By gizmo2k2k in forum iPod Hardware and Accessories
    Replies: 1
    Last Post: 09-13-2006, 11:07 AM
  5. transfering Itunes libary from pc to mac without an Ipod
    By battleship in forum Schweb's Lounge
    Replies: 3
    Last Post: 10-19-2005, 05:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts