New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Music, Audio, and Podcasting Do you use your Mac to create music? This is the place for discussions on creating and editing music on the Mac!

No Sound


Post Reply New Thread Subscribe

 
Thread Tools
tazlad

 
Member Since: May 18, 2009
Posts: 3
tazlad is on a distinguished road

tazlad is offline
I'm fairly new to macs so I hope you can help a newbee at this. Today i played music from my Macbook Pro via a cable plugged into my headphone port and into my amp. Everything was great until i unplugged and now no sound will play out of my macs own speakers. What have i done wrong? There is a red light on in the headphone port if that helps anyone?
QUOTE Thanks
dtravis7

 
dtravis7's Avatar
 
Member Since: Jan 04, 2005
Location: Modesto, Ca.
Posts: 27,446
dtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond repute
Mac Specs: iMac 2.4 C2D 10.9.4, iMac 2.16 C2d 10.6.8, Macbook2007 10.8.4, Mac Mini 10.8.4, iPhone 3GS IPad1

dtravis7 is online now
It's stuck in Optical Digital mode for the Tos-Link cable. Try plugging the plug back in and out a couple of times and see if the sound comes back.
QUOTE Thanks
tazlad

 
Member Since: May 18, 2009
Posts: 3
tazlad is on a distinguished road

tazlad is offline
Tried that. Still no luck. Any other ideas?
QUOTE Thanks
dtravis7

 
dtravis7's Avatar
 
Member Since: Jan 04, 2005
Location: Modesto, Ca.
Posts: 27,446
dtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond repute
Mac Specs: iMac 2.4 C2D 10.9.4, iMac 2.16 C2d 10.6.8, Macbook2007 10.8.4, Mac Mini 10.8.4, iPhone 3GS IPad1

dtravis7 is online now
Try this tip:

It sounds like it is jammed in optical audio out mode.

There's a microswitch that turns the port on and off. Looking into the port, the switch is a small metal thing near the back of the port, on the right side. Take a toothpick or some similar object and poke at the switch until it unsticks and the light goes off.

Also I saw it suggested to try the headphones in and out 10 or more times.

Also another Tip was to reset the PMU. Shut down your Macbook Pro, disconnect the magsafe adapter, and remove the battery. Press and hold the power button for at least 5 seconds.
QUOTE Thanks
tazlad

 
Member Since: May 18, 2009
Posts: 3
tazlad is on a distinguished road

tazlad is offline
A bit more in and out and its working. Thanks for your help.
QUOTE Thanks

Post Reply New Thread Subscribe


« Internet Radio Broadcasting | No Audio »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Macbook Sound Driver Question webzila OS X - Operating System 1 10-16-2012 09:11 PM
Tinny sound in Bootcamp XP vs lush sound in OS X wlow Running Windows (or anything else) on your Mac 2 10-14-2009 06:07 PM
Sound Card/ 5.1 Speaker system issues--please help! phiscobisco Apple Notebooks 0 10-01-2007 01:17 AM

All times are GMT -4. The time now is 09:27 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?