New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Music, Audio, and Podcasting Do you use your Mac to create music? This is the place for discussions on creating and editing music on the Mac!

Random crackles/pops with GarageBand recording


Post Reply New Thread Subscribe

 
Thread Tools
wyattb

 
Member Since: Aug 12, 2008
Posts: 7
wyattb is on a distinguished road

wyattb is offline
Hey guys,

I'm having this problem with my Mac that is going to make me go crazy. First, the specs - I have a relatively new (bought in April) MacBook Pro running OS 10.5, I use GarageBand for recording, and I use a Behringer mixing board that plugs into the computer via USB (CD/tape). I use a couple mics and sometimes plug a keyboard or guitar directly into the board, but in any case, all my musical equipment is very high end stuff and I know that the problem isn't stemming form cheap mics or cables.

So after getting all of these goodies hooked up to the computer, I started the recording process. After messing with the mics and settings on the board I got a great sound for the instruments I was trying to record, so sometimes when I record it sounds absolutely fantastic. THEN, for no reason at all, I'm listening to my recording on playback and this hideous symphony of crackles and pops takes over the otherwise great sounding audio recording. So this problem comes completely randomly and I have NO idea of knowing when it will happen: I might do a bunch of takes in a row, each 5 minutes long, and listen to each one after and, even though the audio is perfect, I make my own error and decide I don't want the take so I delete it. Then on the 5th, 10th, 15th, or whatever take it is, say I finally get it right and go to play it back - for 10 seconds, 20 seconds, 1 minute (it's always random!) it sounds perfect but then out of nowhere come these crackles! It's annoying not knowing how to predict when they'll happen, so if I'm trying to record a 30 minute jam session with my band I have no idea of knowing whether my recording will be ruined by the time I come back to listen to it.

I've researched this a lot online and found different fixes for different people's problems but so far nothing has worked for me. I've tried turning the airport off and messing with computer settings but nothing has worked. I don't understand how the audio going into the computer can be so perfect for a while then just randomly go to sh*ts.

This also does not only happen in GarageBand- it happens in any program I've tried making audio recordings in. The other night I wanted to make a short video of me drumming and screwed up the first couple takes (the audio was perfect, my playing was not). And whaddya know, the first time I get a take I'm happy with, there are those awful crackles sabotaging me. I have a link the actual video - I recorded it with PhotoBooth and built-in Mac camera; the audio is coming from the mics hooked up to the mixing board.
http://www.youtube.com/watch?v=1AQyJ8_bRUw

I bought the Mac and all the recording equipment in hopes of creating a decent enough studio for my band to use for serious recording but the random presence of the crackles has ruined all my attempts to make anything quality. If anyone has any idea how to fix it or can shed any light on the problem it would be most appreciated - thank you so much!
QUOTE Thanks
Henvan20

 
Henvan20's Avatar
 
Member Since: Sep 30, 2007
Posts: 81
Henvan20 is on a distinguished road
Mac Specs: 2x 2.4GHz MBP. 1x old school Mac Mini.

Henvan20 is offline
Hi, my first guess would be the behringer starting to drift, but we can get to that later.

Does this only happen when you record though USB? When you take a line out from the desk into the analog input of your mac, does it give the same problem?
QUOTE Thanks
boneheadz

 
boneheadz's Avatar
 
Member Since: May 22, 2005
Location: Calgary AB
Posts: 378
boneheadz will become famous soon enough
Mac Specs: ibook G4, 17 inch intel imac

boneheadz is offline
I've had the same issue with my Alesis multimix 8 and the little bit of research I did suggested it was a usb interface problem. (not limited to behringer) I never found a decent fix so I monitor and restart when happens.
QUOTE Thanks
wyattb

 
Member Since: Aug 12, 2008
Posts: 7
wyattb is on a distinguished road

wyattb is offline
Hey man, thanks for the reply. It does only happen when I record through USB - what is the analog input on the Mac? It looks like the only possible input I can use to plug anything from the mixing board into the Mac is the USB port.

I know it's not a problem with the built-in mic, but of course that thing can't handle stuff much louder than voice...

I posted the same message in another audio forum and it looks like the USB ports in Macs were designed poorly for use with USB audio inputs. From what I've heard elsewhere, there's really nothing I can do about the problem until Apple announces some sort of fix. Hopefully somebody can prove me wrong... I can't believe how much hype Macs get about being great for producing audio and this is the problem I have. For a $2500 computer there's gotta be a solution to this problem, I know I can't be the only one recording via USB.


Thanks in advance for anyone who has any input, I'm really desperate.
QUOTE Thanks
Henvan20

 
Henvan20's Avatar
 
Member Since: Sep 30, 2007
Posts: 81
Henvan20 is on a distinguished road
Mac Specs: 2x 2.4GHz MBP. 1x old school Mac Mini.

Henvan20 is offline
The analog input it the plug next to your headphone jack on the mac.

What model desk is it? At what sampling rate are you recording? Try 44.1, 48 and also maybe 96khz. Let us know if the problem persists.

I record through USB on both my macbook pros with a lexicon unit without any problems. Not that it matters, but just so you know that its not as if the mac isnt capable of doing this.
QUOTE Thanks
wyattb

 
Member Since: Aug 12, 2008
Posts: 7
wyattb is on a distinguished road

wyattb is offline
The desk is a Behringer 1622FX. I looked through the technical specs and found the sampling rate to be 40KHz. I'll adjust GarageBand's rate to match this (as many have suggested) but given the fact that the crackles appear randomly and are not constantly present, could a sample rate mismatch still be the culprit?

Some have suggested it's as simple as plugging the USB into a different port on the computer. Are Macs really that temperamental??
QUOTE Thanks
Henvan20

 
Henvan20's Avatar
 
Member Since: Sep 30, 2007
Posts: 81
Henvan20 is on a distinguished road
Mac Specs: 2x 2.4GHz MBP. 1x old school Mac Mini.

Henvan20 is offline
Often its not the machine being tempramental, but just really really dodgy drivers. Im not saying this is the case, but often the lower end stuff doesnt have solid mac drivers.

Anyway, as far as the sampling rate goes; 40khz? Are you sure? Thats a strange samling rate, but ok, try to match that and see if it helps. Go to AUDIO MIDI SETUP (its an app in the utilities folder) and make sure that the sampling rate is set to 40k. Make absolutely sure that the settings there match the specs of the unit. Check if it needs to be 16 or 24 bit also. I would guess 16 bit. The clicks you hear are caused by overruns . This can be caused by many things, but this is often caused when a unit starts to drift and the timings get screwed up.

If that doesnt work and you dont want to experiment further, I would use line out on that desk and record analog. The desk should have a tape out or something similar with RCA outs. You can use a normal minijack to RCA cable. On that desk, no one will hear the difference anyway I suspect. The RCA end goes into the mixer and the minijack side into your mac's line in.

Ill try to source one of those desks locally so I can have a look at the problem for myself. Just for interest sake.

Feel free to ask if you have any more questions.
QUOTE Thanks
wyattb

 
Member Since: Aug 12, 2008
Posts: 7
wyattb is on a distinguished road

wyattb is offline
Henvan, I really appreciate all your responses. Everything you said seemed to make sense- Although I don't know much about audio production, 40Khz did not appear to be a familiar sampling rate. I got that information from this document
http://www.behringerdownload.de/1622...INFO_Rev_A.pdf
It can be found on the middle right-hand side of the 3rd page. I feel like I was looking the wrong place though.

So if I were to buy a cable that I could connect to the CD/tape RCA outputs and plug into the analog input of the computer that would work as well without noticeable sound quality difference? I have a small analog mic I used to use for recording with my Windows machine (for an analog mic its recording quality was excellent, it captured my drums perfectly) but it did not work with the Mac because apparently the analog input was not compatible with recording mics - with this being said, would recording analog still work with the mixer?
QUOTE Thanks
Henvan20

 
Henvan20's Avatar
 
Member Since: Sep 30, 2007
Posts: 81
Henvan20 is on a distinguished road
Mac Specs: 2x 2.4GHz MBP. 1x old school Mac Mini.

Henvan20 is offline
Hello once again. Yes, that 40K sampling rate is only for the DSP - not what we are looking for. True to Behriner, the documentation isnt that great. Don't worry though, thats still a pretty decent desk for your purposes!

You need a cable like this one: http://www.amazon.com/Monster-JM-REP.../dp/B00003CWC8 or this one: http://www.amazon.com/Monster-Cable-...ref=pd_sim_e_3

Don't skimp on quality with that cable. Buy something that has nice and thick insulation and don't buy a unnecessary long one. This minimizes noise. You can ask any decent electronics store for a RCA TO STEREO MINIJACK cable. Maybe run down to best buy and get something cheap to check if you get satisfactory results.

When you get the cable, connect the RCA side (the two larger plugs) to the tape output or something similar on the desk. The other side goes into the line input of the mac. (next to the headpone output) Then, go to the sound prefrences pane in system prefs and select 'built in input' for input.

Next, play something through the desk and set your main output levels on the desk so that the meter goes to the 0db mark. Now set the input sensitivity on the mac so you get nice level, but dont distort. Its very important to ensure that you get nice loud level, but not too much for the machine to handle. You have that little meter showing you your input level. Having it at about 3/4 is safe, because you still leave some headroom for when a loud snare comes through or something. Garageband should also show you your levels. Always keep an eye on those.

Following these steps, you should get a pretty decent sound out of your setup! Let me know how it sounds or if you have any more questions.

PS: As far as that old windows mic goes, yes, macs want line level, not mic level. You may think its stupid now, but you will realize later that its actually a good thing.
QUOTE Thanks
wyattb

 
Member Since: Aug 12, 2008
Posts: 7
wyattb is on a distinguished road

wyattb is offline
If 40khz isn't the sample rate then I can't find out what it is. There's nothing on the mixer or in any of the manuals that I can find that indicates the rate, which is either kind of ridiculous or I'm just an idiot.

I just ordered an analog cable - are you confident that'll solve the problem or is that just an idea? Either way I don't mind throwing down $15 for the cable. As long as the sound quality is basically the same as the USB (when it works correctly) then I'll be happy...
QUOTE Thanks
Henvan20

 
Henvan20's Avatar
 
Member Since: Sep 30, 2007
Posts: 81
Henvan20 is on a distinguished road
Mac Specs: 2x 2.4GHz MBP. 1x old school Mac Mini.

Henvan20 is offline
Youre not an idiot, thats just the way behringers are. Good products for the money, but rahter useless manuals and drivers.

As for the $15 cable solution: Im a sound engineer with 16 years experience and a degree in electronic engineering who does tech consulting on $250 000+ large scale audio rigs, so yes, im pretty sure that will work. ;-) The input on the macbook pro's are nice and clean. Output not so much, but still good for a laptop.

Have fun.
QUOTE Thanks
wyattb

 
Member Since: Aug 12, 2008
Posts: 7
wyattb is on a distinguished road

wyattb is offline
that is excellent i can't wait to get the rig really up and running. i'll report back in a week when i get home from vacation on how it all works. thanks a lot man.
QUOTE Thanks

Post Reply New Thread Subscribe


« External Sound System Advice. | m4v to mp3 »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
console thread from a random restart in Leopard webbyhere@gmail OS X - Operating System 0 06-13-2008 11:31 AM
Random kernal panic after 'erase and install' _sm OS X - Operating System 9 05-01-2008 03:28 PM
random questions: volume III eric Schweb's Lounge 18 01-27-2008 04:47 PM
MacPro - XP on bootcamp random freezes karab Running Windows (or anything else) on your Mac 0 09-07-2007 08:39 PM
Make it more random? TangoCharlie iPod Hardware and Accessories 5 07-26-2007 11:01 AM

All times are GMT -4. The time now is 06:38 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?