New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Movies and Video For people making movies and editing video with their Mac.

can't play .wmv videos


Post Reply New Thread Subscribe

 
Thread Tools
bluethunder

 
Member Since: Apr 15, 2011
Posts: 36
bluethunder is on a distinguished road
Mac Specs: Sept. '07 white 13" MacBook 8,2 - 10.7.5

bluethunder is offline
I have a mid '07 MacBook, 10.6.8, Flip4Mac is installed. I can see the video playing but I have no sound. Sound is set to play through internal speakers. Other things play fine. Why do I have no sound on a .wmv video? What can I look for?
QUOTE Thanks
chas_m

 
chas_m's Avatar
 
Member Since: Jan 22, 2010
Location: Victoria, BC
Posts: 17,586
chas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond repute
Mac Specs: Mid-2012 MBP (16GB, 1TB HD), BenQ second monitor, iPhone 5s 32GB, iPad Air 2 64GB

chas_m is offline
It's not wmv generally, it's the audio codec used in the particular wmv you're trying to play. You can add Perian (no longer supported but still works) to fix this issue.
QUOTE Thanks
bluethunder

 
Member Since: Apr 15, 2011
Posts: 36
bluethunder is on a distinguished road
Mac Specs: Sept. '07 white 13" MacBook 8,2 - 10.7.5

bluethunder is offline
I have Perian installed. It doesn't work. I tried uninstalling and reinstalling it. It still doesn't work. What else can I check?
QUOTE Thanks
chas_m

 
chas_m's Avatar
 
Member Since: Jan 22, 2010
Location: Victoria, BC
Posts: 17,586
chas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond repute
Mac Specs: Mid-2012 MBP (16GB, 1TB HD), BenQ second monitor, iPhone 5s 32GB, iPad Air 2 64GB

chas_m is offline
You're correct. It still works with QuickTime 7 Pro, but not with the Mavericks install of QuickTime X. Sorry about that.

Alternatives: download and install VLC (free) and see if that will play the file in question. Alternatively, use a converter program like iFFmpeg etc to convert the audio codec portion into something standard.
QUOTE Thanks
KeswicKomputing

 
Member Since: Mar 01, 2014
Posts: 10
KeswicKomputing is on a distinguished road

KeswicKomputing is offline
The best thing to do in my opinion is download the latest compatible version of vlc player for mac.
QUOTE Thanks
bluethunder

 
Member Since: Apr 15, 2011
Posts: 36
bluethunder is on a distinguished road
Mac Specs: Sept. '07 white 13" MacBook 8,2 - 10.7.5

bluethunder is offline
I have Snow Leopard (mentioned in the first post) and can't even install Mavericks.

I hadn't heard of VLC. When I tried it, it threw me for a couple seconds as I had the opposite problem, sound and no video. When I clicked in the video area, then it showed up, so I guess it works. Thanks! I appreciate it.
QUOTE Thanks

Post Reply New Thread Subscribe


« How do I digitize my dvd's | .AVI movies in iMovie »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Can't play videos from iphoto '08 on Leopard mrsfliss Movies and Video 5 08-21-2012 06:40 PM

All times are GMT -4. The time now is 01:13 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?