New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Movies and Video For people making movies and editing video with their Mac.

Can't play iPhone video on MBP?


Post Reply New Thread Subscribe

 
Thread Tools
mr.cotton

 
Member Since: Apr 04, 2012
Posts: 33
mr.cotton is on a distinguished road
Mac Specs: iPhone 4S iPod Nano 6th Gen MacBook Pro (2011) -OS: OS X v.10.6.8 -Processor: 2.3 GHz Intel Core i5

mr.cotton is offline
iPhone 4S (iOS 6.0.1) video will not play on MacBook Pro (early 2011, 10.6.8).

QuikTime = opens but time shows -00:00:00 and won't play
iMovie - won't allow as an option
Final Cut Pro X =won't allow as an option
iTunes = won't open

I've scoured the web and found nothing but nebulous ramblings that talk a lot but say nothing. Anyone know anything concrete on this? Very frustrating.
QUOTE Thanks
Flavacraze

 
Member Since: Feb 05, 2013
Location: Corona Del Mar, CA
Posts: 75
Flavacraze is on a distinguished road
Mac Specs: MBP 15" 2.8 GHz Intel Core i7 16GB 1600 MHz DDR3 10.9.4

Flavacraze is offline
What's the file extension?
QUOTE Thanks
mr.cotton

 
Member Since: Apr 04, 2012
Posts: 33
mr.cotton is on a distinguished road
Mac Specs: iPhone 4S iPod Nano 6th Gen MacBook Pro (2011) -OS: OS X v.10.6.8 -Processor: 2.3 GHz Intel Core i5

mr.cotton is offline
All of them are .mov
QUOTE Thanks
Flavacraze

 
Member Since: Feb 05, 2013
Location: Corona Del Mar, CA
Posts: 75
Flavacraze is on a distinguished road
Mac Specs: MBP 15" 2.8 GHz Intel Core i7 16GB 1600 MHz DDR3 10.9.4

Flavacraze is offline
How big is it?
You could try just renaming the extension to .mp4 and see if that works (make a copy first)....
Try MxPlayer...
Try re-importing it as well... maybe the import didn't go according to plan.
QUOTE Thanks
mr.cotton

 
Member Since: Apr 04, 2012
Posts: 33
mr.cotton is on a distinguished road
Mac Specs: iPhone 4S iPod Nano 6th Gen MacBook Pro (2011) -OS: OS X v.10.6.8 -Processor: 2.3 GHz Intel Core i5

mr.cotton is offline
I appreciate all of your suggestions, but I'm still unsuccessful.

None of the files are very big - all less than 2MB (they're short clips...2min or less). I'm fairly certain that's smaller than they were on the camera.

I renamed to mp4 and the only thing that happened is the file now opens with Adobe Fireworks - in AF, it's being treated like an image. I tried opening with QuikTime and it still shows -00:00:00 and won't play.

I can't re-import as I already deleted those files from my phone (before I knew they wouldn't play). It's the same case for multiple different imports though...all of them in fact. This seems to be a common issue...all the more reason to be baffled by the ubiquity of the issue.

Thoughts?
QUOTE Thanks
Flavacraze

 
Member Since: Feb 05, 2013
Location: Corona Del Mar, CA
Posts: 75
Flavacraze is on a distinguished road
Mac Specs: MBP 15" 2.8 GHz Intel Core i7 16GB 1600 MHz DDR3 10.9.4

Flavacraze is offline
Did use iPhoto, do they playback in it?
If not, then your compression / import settings must be importing it as some .mov codec that sucks the big one. Try changing the import settings in your presences for future imports...

Does it open in compressor? Or Adobe Media Encoder? Cuz then you could try exporting it as something else....
If it doesn't open in them, then I'm fresh outta ideas...
QUOTE Thanks
mr.cotton

 
Member Since: Apr 04, 2012
Posts: 33
mr.cotton is on a distinguished road
Mac Specs: iPhone 4S iPod Nano 6th Gen MacBook Pro (2011) -OS: OS X v.10.6.8 -Processor: 2.3 GHz Intel Core i5

mr.cotton is offline
I don't import into iPhoto (whole different post) but just tried importing one of the files and it did same thing.

Would I change compression/import settings on MBP or iPhone?

I don't know what compressor is and never used Adobe Media Encoder before but just tried it and didn't work. Thanks for hanging with me on this bro!
QUOTE Thanks
mr.cotton

 
Member Since: Apr 04, 2012
Posts: 33
mr.cotton is on a distinguished road
Mac Specs: iPhone 4S iPod Nano 6th Gen MacBook Pro (2011) -OS: OS X v.10.6.8 -Processor: 2.3 GHz Intel Core i5

mr.cotton is offline
The Adobe Media Encoder file opens and shows that it's playing 8 seconds but it's just showing the initial image as if it were a photo...the file is also larger now 2.7MB as opposed to 892kb.
QUOTE Thanks
Flavacraze

 
Member Since: Feb 05, 2013
Location: Corona Del Mar, CA
Posts: 75
Flavacraze is on a distinguished road
Mac Specs: MBP 15" 2.8 GHz Intel Core i7 16GB 1600 MHz DDR3 10.9.4

Flavacraze is offline
Compressor came with Final Cut on my install... its like Adobe ME but by Apple.
For Adobe ME I had to download ProRes codecs to read some Apple codecs.

What application do you use to import video from your iphone?
You would need to change the import settings in that application.
QUOTE Thanks
Flavacraze

 
Member Since: Feb 05, 2013
Location: Corona Del Mar, CA
Posts: 75
Flavacraze is on a distinguished road
Mac Specs: MBP 15" 2.8 GHz Intel Core i7 16GB 1600 MHz DDR3 10.9.4

Flavacraze is offline
Also, does it have an image as the icon? (clip from the movie)
Better yet, whats the icon look like?
QUOTE Thanks
mr.cotton

 
Member Since: Apr 04, 2012
Posts: 33
mr.cotton is on a distinguished road
Mac Specs: iPhone 4S iPod Nano 6th Gen MacBook Pro (2011) -OS: OS X v.10.6.8 -Processor: 2.3 GHz Intel Core i5

mr.cotton is offline
I'll have to do some reading on codecs, etc. Fairly new to all this. Thanks for the suggestions though.

I use Image Capture. I import them all into a "New Uploads" folder until I can get to them later and sort. When I double click on them in Finder, QuickTime opens.
QUOTE Thanks
mr.cotton

 
Member Since: Apr 04, 2012
Posts: 33
mr.cotton is on a distinguished road
Mac Specs: iPhone 4S iPod Nano 6th Gen MacBook Pro (2011) -OS: OS X v.10.6.8 -Processor: 2.3 GHz Intel Core i5

mr.cotton is offline
It does have image (clip from movie) as the icon and file name example is MVI_0289.MOV

The icon is square and and just an image clip from the video. Not sure if that's what you're looking for?
QUOTE Thanks
Flavacraze

 
Member Since: Feb 05, 2013
Location: Corona Del Mar, CA
Posts: 75
Flavacraze is on a distinguished road
Mac Specs: MBP 15" 2.8 GHz Intel Core i7 16GB 1600 MHz DDR3 10.9.4

Flavacraze is offline
I just looked on iPhoto how big some of my video files are and the only one comparable was 3:35mins long as was almost 300mb... if your file is less than 1mb for 2:00min clips, I'm under the impression when you imported them, they only imported as picutres...
I just recorded a 30sec clip and plugged it in to image capture and it was 21mb...
Just to see if this works, try downloading some free camera with video app, record something with it and then plug into image capture and see how big the file is to begin with... try using the apple camera as well... see how big they are before you import them...
Also, can you play the files on your phone after you record them?
I await the results...
QUOTE Thanks
mr.cotton

 
Member Since: Apr 04, 2012
Posts: 33
mr.cotton is on a distinguished road
Mac Specs: iPhone 4S iPod Nano 6th Gen MacBook Pro (2011) -OS: OS X v.10.6.8 -Processor: 2.3 GHz Intel Core i5

mr.cotton is offline
On it...will have an answer in a couple minutes...
QUOTE Thanks
mr.cotton

 
Member Since: Apr 04, 2012
Posts: 33
mr.cotton is on a distinguished road
Mac Specs: iPhone 4S iPod Nano 6th Gen MacBook Pro (2011) -OS: OS X v.10.6.8 -Processor: 2.3 GHz Intel Core i5

mr.cotton is offline
I took a 13 second clip, uploaded it via Image Capture to my desktop. It plays fine and is 36 MB. Crazy. Must be something with my iPhone video then?
QUOTE Thanks

Post Reply New Thread Subscribe


« MPEG Steamclip problem- plug-in? | RED Digital Cinema »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 08:48 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?