Results 1 to 7 of 7
  1. #1


    Member Since
    Oct 25, 2011
    Posts
    6
    Videos no longer playing in Youtube....help please
    Hi,
    I have an old Macbook using version 10.5.8. And in the last three days I can no longer play videos on youtube. The video 'screen' remains black and with no transport controls visible (see attached screenshot). This is happening with every video I look at now. Before it always worked fine. Even my old Powerbook still plays videos (albeit slowly!). My new MacBook Pro is also fine. So it's just this Macbook. I have checked if I need any software updates but none are showing up.
    Some help would be much appreciated.
    Thanks,
    Gordon
    Attached Images Attached Images

  2. #2


    Member Since
    Jan 22, 2010
    Location
    Victoria, BC
    Posts
    20,911
    Specs:
    Mid-2012 MBP (16GB, 1TB HD), Monoprice 24-inch second monitor, iPhone 5s 32GB, iPad Air 2 64GB
    Update your Flash.

  3. #3


    Member Since
    Oct 25, 2011
    Posts
    6
    yeah, I did that....but that's not working either.

    The longer I look around, the more I'm finding this is happening to other people too. I have added to a similar thread on macrumors.com

    YouTube videos won't load - MacRumors Forums

  4. #4

    cwa107's Avatar
    Member Since
    Dec 20, 2006
    Location
    Lake Mary, Florida
    Posts
    26,901
    Specs:
    15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD
    Maybe try switching YouTube over to HTML5?

    YouTube - HTML5
    Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!

    https://youtu.be/KHZ8ek-6ccc

  5. #5


    Member Since
    Oct 25, 2011
    Posts
    6
    ah yes, I had that in mind actually after seeing someone else mention this yesterday....but haven't had the chance to get back on my other mac (I'm on my MacBook Pro at the moment).

    but yes....will give that a try.....thanks for reminding me.

    any ideas why this is happening now to people? Did youtube change something recently?

  6. #6

    cwa107's Avatar
    Member Since
    Dec 20, 2006
    Location
    Lake Mary, Florida
    Posts
    26,901
    Specs:
    15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD
    Quote Originally Posted by mach1ne View Post
    ah yes, I had that in mind actually after seeing someone else mention this yesterday....but haven't had the chance to get back on my other mac (I'm on my MacBook Pro at the moment).

    but yes....will give that a try.....thanks for reminding me.

    any ideas why this is happening now to people? Did youtube change something recently?
    It's probably Flash, not YouTube. Flash gets updated constantly for stability and security problems. That's part of the reason there is such a push to get rid of it.
    Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!

    https://youtu.be/KHZ8ek-6ccc

  7. #7


    Member Since
    Oct 25, 2011
    Posts
    6
    Bingo.....look what I found here:

    YouTube

    I'd been selected automatically to be part of a trial for html 5 which I'm guessing was done just a few days ago without telling me.

    At the bottom of the page it says 'leave the html 5 trial' and hey presto...the videos now work.....I will share this on the other forums

    Thanks all

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can longer view videos on FB or YouTube
    By Rivergull in forum OS X - Operating System
    Replies: 1
    Last Post: 09-24-2012, 11:40 PM
  2. YouTube Videos Not Playing
    By sandrajohnson54 in forum OS X - Operating System
    Replies: 2
    Last Post: 08-29-2012, 07:32 PM
  3. Playing YouTube Videos in VLC
    By I.M.O.G. in forum News and Community Announcements
    Replies: 0
    Last Post: 05-07-2012, 01:57 PM
  4. Help! Internet videos, YouTube, etc., no longer playing on my Mac.
    By Navigator in forum OS X - Operating System
    Replies: 7
    Last Post: 04-23-2011, 12:40 PM
  5. youtube videos not playing properly
    By 69camaro in forum OS X - Operating System
    Replies: 0
    Last Post: 04-30-2009, 04:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •