Hello, I bought a new 13" Macbook Air two months ago. I am trying to make a movie with iMovie 11. I made several practice movies using video clips, no problems there. I then made a couple short practice movies using photos with no problem. Now I am trying to make a longer movie using around 100 photos and text. I was able to drag several dozen photos to the timeline with no problems. However, now when I try to add additional photos to the end of the timeline it does not show the added photo, but instead shows the previous photo. Adding any other photo to the end of the timeline shows the same result, I can only get a duplicate of the previous photo and not the photo I am trying to drag! I closed the project and opened one of my other practice iMovie projects and I am able to transfer the same photos to the project with no problems at all. I then tried the original longer Imove project and the problem persists. I tried creating a new project and starting over and immediately I have the same problem. Nothing I have tried seems to work. Any ideas? Help! thanks in advance.....jim