Results 1 to 15 of 15
  1. #1


    Member Since
    May 30, 2010
    Posts
    5
    Nikon D90 iMoive best video quality settings? HELP!
    Okay, I created a short film using a D90 and I'm editing it on iMovie6 since mac is really old. Before I started editing I changed my video format settings to HD 720p.

    I'm having a tough time exporting. I do share > share > (quicktime) expert settings

    But I think my expert settings are set wrong because once I save the quality of my video sucks a lot! It's really pixely and bad quality. Can someone help me? I've seen other people upload videos on youtube using imovie and a d90 and it's a lot better quality then my own.

    PLEASE HELP! This has been bothering me for a really long time. I don't understand why my d90 can't produce a clean non pixely video..

  2. #2


    Member Since
    Feb 25, 2009
    Posts
    2,112
    Specs:
    Late 2013 rMBP, i7, 750m gpu, OSX versions 10.9.3, 10.10
    Did you click to change any of the settings for video? If I recall correctly, the default settings for quicktime export has a REALLY low bitrate - like 350Kbit/s (if you're exporting to an mp4 at least) - go into the settings and check the resolution (make sure it's still 1280x720) and check that the bitrate is set to 5000-6000Kbit/s and that you're saving to an H.264 codec.
    My Macs: Late 2013 rMBP w/ 750m, 16Gig ram; 2013 Mac Pro 6 core w/ D700, 16Gig Ram; Mac mini G4, 1.25 GHz, 512m ram (server); Late 2011 11" MBA, 1.8GHz i7, 4Gig Ram, 256Gig SSD, HD3000; Powerbook 12" G4 1.33GHz running Linux; Apple TV (1080p version)

  3. #3


    Member Since
    May 30, 2010
    Posts
    5
    Thanks! that helped. it was on 1000 kbits/s and changed it to 5000 kbits/s

    but now i have another problem.. on imovie the audio is perfect but after I save it and turn it into an .mp4 with the said settings above my audio is off. The audio is not aligned with the video. Help? what did I do wrong?

  4. #4


    Member Since
    May 30, 2010
    Posts
    5
    Here's a screen shot of my settings! I'm guessing my audio setting is wrong...?
    Attached Images Attached Images

  5. #5


    Member Since
    Feb 25, 2009
    Posts
    2,112
    Specs:
    Late 2013 rMBP, i7, 750m gpu, OSX versions 10.9.3, 10.10
    It's the frame rate.

    1280x720 has a variety of frame rates - 60p (59.94), 30p (29.97) and 24p (23.976). The Nikon D90 records at 720p24 - you're attempting to output at 720p30. The quicktime export in this case isn't actually converting from 24p to 30p, so you need to change your frame rate to either 23.976 or 23.98 if they have the option or custom if you have to and key in your appropriate frame rate. That should fix your audio sync issue.
    My Macs: Late 2013 rMBP w/ 750m, 16Gig ram; 2013 Mac Pro 6 core w/ D700, 16Gig Ram; Mac mini G4, 1.25 GHz, 512m ram (server); Late 2011 11" MBA, 1.8GHz i7, 4Gig Ram, 256Gig SSD, HD3000; Powerbook 12" G4 1.33GHz running Linux; Apple TV (1080p version)

  6. #6


    Member Since
    May 30, 2010
    Posts
    5
    I tried changing my FPS to 23.967 but I still have problems with the audio.. I'm now trying FPS 24 or 29.97... (sigh)

    Here's another screenshot of my work space. On the top it says (HD-720p-30) That 30 up there does that mean I have to be at FPS 29.97?
    Attached Images Attached Images

  7. #7


    Member Since
    Feb 25, 2009
    Posts
    2,112
    Specs:
    Late 2013 rMBP, i7, 750m gpu, OSX versions 10.9.3, 10.10
    That's weird - according to the docs I've seen the camera itself records in p24, not p30 (unless there was some sort of firmware change to add support for p30). you can try exporting to 29.97, a difference of 30 and 29.97 can add a cumulative offset, but it's usually more noticeable as the final output goes on rather then initially.
    My Macs: Late 2013 rMBP w/ 750m, 16Gig ram; 2013 Mac Pro 6 core w/ D700, 16Gig Ram; Mac mini G4, 1.25 GHz, 512m ram (server); Late 2011 11" MBA, 1.8GHz i7, 4Gig Ram, 256Gig SSD, HD3000; Powerbook 12" G4 1.33GHz running Linux; Apple TV (1080p version)

  8. #8

    xstep's Avatar
    Member Since
    Jun 25, 2005
    Location
    On the road
    Posts
    3,231
    Specs:
    2011 MBP, i7, 16GB RAM, MBP 2.16Ghz Core Duo, 2GB ram, Dual 867Mhz MDD, 1.75GB ram, ATI 9800 Pro vid
    Than D90 manual says the camera records at 24fps. So try setting the export at exactly 24. Or perhaps 'Current'. I'm assuming iMovie HD can handle 24fps.

    Which audio is out of sync. It looks like you have a music track on that project.

    If the audio from the video track is out of sync, that may be due to it not being 48kHz. If so, I'd try exporting into a 48kHz AIFF file and reimport that. Open one of the source movies in QuickTime Player and do a command-I to look at the specs.

    Oh, where are you getting that 30fps number from? I can't see a project info window.
    CameraTime - Time lapse photography for novice and advanced users.

    When asking questions, post the version of your software. You'll receive better answers.

    Please post your results to the thread as it is good feedback.

  9. #9

    xstep's Avatar
    Member Since
    Jun 25, 2005
    Location
    On the road
    Posts
    3,231
    Specs:
    2011 MBP, i7, 16GB RAM, MBP 2.16Ghz Core Duo, 2GB ram, Dual 867Mhz MDD, 1.75GB ram, ATI 9800 Pro vid
    Oh, my iMovie export guide may be helpful to you.
    CameraTime - Time lapse photography for novice and advanced users.

    When asking questions, post the version of your software. You'll receive better answers.

    Please post your results to the thread as it is good feedback.

  10. #10


    Member Since
    Feb 25, 2009
    Posts
    2,112
    Specs:
    Late 2013 rMBP, i7, 750m gpu, OSX versions 10.9.3, 10.10
    Take a look at the screen cap at the top xstep - (HD - 720p - 30) I'm assuming that's the setup he's currently using. I'm wondering if that's the problem - he's plunking a 24p clip into a 30p sequence.
    My Macs: Late 2013 rMBP w/ 750m, 16Gig ram; 2013 Mac Pro 6 core w/ D700, 16Gig Ram; Mac mini G4, 1.25 GHz, 512m ram (server); Late 2011 11" MBA, 1.8GHz i7, 4Gig Ram, 256Gig SSD, HD3000; Powerbook 12" G4 1.33GHz running Linux; Apple TV (1080p version)

  11. #11

    xstep's Avatar
    Member Since
    Jun 25, 2005
    Location
    On the road
    Posts
    3,231
    Specs:
    2011 MBP, i7, 16GB RAM, MBP 2.16Ghz Core Duo, 2GB ram, Dual 867Mhz MDD, 1.75GB ram, ATI 9800 Pro vid
    Oh, you mean the title bar on the second image. I missed that. Yep, the 30 is the frame rate. You set what it will be for new projects in iMovie HD preferences. I can't see a way to change it after the fact, and for some reason I only have 29.97 and 25 as options. Weird?

    My iMHD is the last version Apple released, version 6.0.4.
    CameraTime - Time lapse photography for novice and advanced users.

    When asking questions, post the version of your software. You'll receive better answers.

    Please post your results to the thread as it is good feedback.

  12. #12


    Member Since
    May 30, 2010
    Posts
    5
    Haha I'm a girl by the way.

    And whenever I create a new movie (File > New > Video Format > HDV 720P) it automatically sets it at HD-720p-30

    I need to change that 30 to 24, correct? Since D90 shoots at 24p and I'm inserting clips in a 30p. How do I change 30p to 24p?

    My video is a music video. The audio clip you see is a song. That's not out of sync. The clips in the music video has audio and that's out of sync. The clip's audio is out of sync when I export it. In imovie the video is fine! But after I export the audio of the clips are off.

  13. #13


    Member Since
    Feb 25, 2009
    Posts
    2,112
    Specs:
    Late 2013 rMBP, i7, 750m gpu, OSX versions 10.9.3, 10.10
    It's very possible that's the entire reason - I've heard some versions of iMovie don't support all frame rates - but I don't know all of the combinations which versions support.

    You may need to find another way to import the footage then convert it to 30p from 24p to get it to work with that version of iMovie... The other thing you can do is locate where the footage is stored on your system (xstep would know better then I where the default locations are for iMovie storage) and play the master footage back with quicktime to see if it plays like it should (audio in sync and all) - you can pull up the inspector/information window while playing back in quicktime and it should tell you the framerate - if it shows a framerate of ~24fps (24 or 23.976 or 23.98) then all you need to do is convert that master file to 30fps then import it into iMovie.

    In terms of what tool to use... honestly I'm not sure without using compressor on a Mac...
    My Macs: Late 2013 rMBP w/ 750m, 16Gig ram; 2013 Mac Pro 6 core w/ D700, 16Gig Ram; Mac mini G4, 1.25 GHz, 512m ram (server); Late 2011 11" MBA, 1.8GHz i7, 4Gig Ram, 256Gig SSD, HD3000; Powerbook 12" G4 1.33GHz running Linux; Apple TV (1080p version)

  14. #14

    xstep's Avatar
    Member Since
    Jun 25, 2005
    Location
    On the road
    Posts
    3,231
    Specs:
    2011 MBP, i7, 16GB RAM, MBP 2.16Ghz Core Duo, 2GB ram, Dual 867Mhz MDD, 1.75GB ram, ATI 9800 Pro vid
    As I said, you can't change the project fps. You have to change the preferences before creating a new project, and I don't know if 24fps is available as I don't see it on my system. Perhaps Apple thought 30 was a better choice for their consumer software expecting the conversion to be smooth. I don't know.

    Also, as I said, check the original source specs. The import should be inside the project file. Do a right-click (or control-click) on the project file and choose "Show Package Contents" to open it as a folder.

    The reason I mention the audio kHz issue is that it is a known problem. The added difference of frame rate adds to the confusion. Without access to the material, all we can do is suggest things to try. You have to act on those suggestions.
    CameraTime - Time lapse photography for novice and advanced users.

    When asking questions, post the version of your software. You'll receive better answers.

    Please post your results to the thread as it is good feedback.

  15. #15


    Member Since
    Jun 01, 2010
    Location
    Bristol
    Posts
    1
    Xstep

    Thanks for guide, just the job for my needs right now.

    Cheers

    Mike

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 06-22-2011, 12:32 AM
  2. Nikon D90 and Aperture 3
    By lee634 in forum Images, Graphic Design, and Digital Photography
    Replies: 3
    Last Post: 08-02-2010, 11:08 AM
  3. Nikon d90 not being recognized by MacBook Pro
    By TheDen in forum Images, Graphic Design, and Digital Photography
    Replies: 8
    Last Post: 07-20-2010, 08:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •