Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Movies and Video (http://www.mac-forums.com/forums/movies-video/)
-   -   iMovie 09 not responding (http://www.mac-forums.com/forums/movies-video/196120-imovie-09-not-responding.html)

darren r 03-26-2010 10:00 AM

iMovie 09 not responding
 
I've had iMovie09 for well over a year with no problems. The other day, however, it just decided to stop responding. I was adding some sound to a clip and the beach ball began spinning...and spinning...and spinning and I had to Force Quit.
I've searched the internet to see if anyone else had the same problem and found a variety of different solutions, some rather weird, all of which I've tried. These solutions include : changing the screen colours and recalibrating the display, moving all movie files from iPhoto (didn't have any), letting my laptop work its way through (I left it for over 5 hours) and, the most popular one, deleting apple.iPhoto.plist from Preferences (actually I couldn't find this in Preferences - maybe that's the problem??). I'd hate to lose a project I've been working on for over 18 months (I make a lot of use of Greenscreen) so I would really appreciate any advice!

xstep 03-26-2010 03:29 PM

I don't know why some of those ideas would work with iMovie. Some seem just outright off.

If you were to remove a preference file, the right one would be named something like "com.apple.iMovie8.plist". Drag it/them to your desktop and restart iMovie. If it solves the problem, then trash the one(s) you moved to the desktop.

Another option may be to re-install iMovie. You'll need your original install disc for that process. These two Apple articles may be helpful; 1, 2.

Your description of "not responding" doesn't tell us much. Does iMovie start? There are logs you can review that may help. You run the "Console.app" in the Utilities folder before starting iMovie.

Bahja 03-26-2010 03:40 PM

I think i just installed an update for Imovie a few hours ago.................

darren r 03-26-2010 05:32 PM

xstep ; yes, iMovie opens as it should, but if I click onto a clip in the Project or Event libraries (to remove it, edit it, whatever), the beachball starts spinning and that's that.In fact, I don't even need to click - just pause the cursor for a few seconds. I can open a music and sound effects, transitions etc file but then the same thing happens - the whole thing hangs and I can't do anything with it.

xstep 03-26-2010 07:42 PM

I've never had this problem. I've seen people mention something like this a couple of times, but don't recall a fix. I think I saw someone mention that you shouldn't use the '&' symbol in any names, but that is grasping. If I run over those mentions, I'll link to them.

Another file you might want to try dragging to the desktop is 'com.apple.iMovie.LSSharedFileList.plist'. I don't know what it is used for, but what do you have to loose.

I'd also look at the logging via Console.app. It may give some clues. Do that.

If that doesn't help, try trashing iMovie and reinstalling it.

darren r 03-27-2010 07:37 PM

xstep : I can't find any iMovie p.list files in Preferences so that's a non-starter. I looked at the logging in the Console.app but it meant nothing to me unfortunately!

Removed and re-installed iMovie but no joy there either. Also tried another suggestion I found that seemed like it may offer the solution but, no. I'm really stumped now. But I thank you for your advice.

xstep 03-28-2010 03:44 AM

Just out of curiosity, which Preferences folder are you looking at?

Have you changed your username lately?

You can post some of the Console.app output here. Start it, click on 'All Messages' at the left, scroll to the bottom of the list, remember the time stamp, start iMovie and do something that causes that 'lack' of feed back, look at the console and copy and paste the feedback, if any, here.

darren r 03-28-2010 08:47 AM

HD/Library/Preferences - please don't tell me there's another one!!

No, haven't changed my username and nobody else uses my laptop.

The problem obviously lies in the Project file so I've trashed it. Fortunately I still have all the Event stuff on iMovie 08 so I haven't lost that. Just means I'll have to reconstruct my movie again and hope it goes better this time.

xstep 03-28-2010 02:19 PM

You are looking at the wrong Preferences folder. That is a global one that all users see. The one you want to examine is your personal one. It isn't a direct copy.

When you open a new Finder window, the display is opened to your home folder. In that folder is a Library folder and within that is a Preferences folder. They are part of the account. If your computer had another account, that account would have these folders too, but with settings that would be different. Never trash these folders because they hold a ton of information that is required.

Did trashing the project fix the problem?

darren r 03-28-2010 05:40 PM

Not too sure what you mean about the Preferences folder, but I will try to figure it out.

I've started reassembling my Project and so far it seems to be working OK.

Fingers crossed!

darren r 03-28-2010 05:47 PM

Ah, OK. Yes, I see what you mean. Finding that earlier might have solved the problem! At least, if it happens again, I'll know where to look.

Thanks for your help, xstep.

southportlandkk 01-28-2011 10:42 AM

It works now!
 
Quote:

Originally Posted by xstep (Post 1024601)
If you were to remove a preference file, the right one would be named something like "com.apple.iMovie8.plist". Drag it/them to your desktop and restart iMovie. If it solves the problem, then trash the one(s) you moved to the desktop.

IT WORKED! THANK YOU!!! EVERYONE TRY THIS ^^^

Click finder> library>preferences> and find the file com.apple.iMovie8.plist and move it to the desktop (I didn't delete mine, I just copied it to the desktop). Next, I opened I movie and it was working! Everything was back to normal! I can't believe this!

It finally works!!!! YES!!!! :'( tears of joy!!!

queenamanda 11-10-2012 10:13 AM

Thank you!
 
.....


All times are GMT -4. The time now is 12:36 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.