New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Movies and Video For people making movies and editing video with their Mac.

Motion Blurring with MPEG2 files from Sony Camcorder


Post Reply New Thread Subscribe

 
Thread Tools
Chris_Music

 
Member Since: Jan 14, 2010
Location: Salisbury, UK
Posts: 10
Chris_Music is on a distinguished road
Mac Specs: Mac pro (2nd gen) 14gb ram, 2500gb, Logic Pro 9, Final Cut

Chris_Music is offline
Hey guys

I have only just joined this forum, but i have had my Mac Pro for well over a year now, i would have joined sooner, but iv not had any problems with my mac (until now).

Yesterday i bought my self a Sony DCR-SR57 handycam, as i thought i would make a stab at making amateur movies (as im training to be a film composer). The camera is great, i cant fault it for the price. But when i connected the camera to my mac and played the video back in VLC, i noticed when ever i moved the camera, there would be a motion blur. The blur looked like small lines, and it only appeared on the object that was moving! I had already tried the movies on my PS3 prior to this and it didnt have this problem.

I called up sony and they said that their products are not mac compatible, so alot of use they were. So i figured it might be to do with the MPEG2 plugin for quicktime, so i reinstalled it (im using snow leopard by the way) and the problem still remains!

I tried the file in all the software i have that can play video and it worked fine in iMovie and Toast 10's own player, but it had the motion blur in VLC, quicktime and Final cut, which is no good, as i intend to use Final Cut for my editing!

I tried using handbrake to convert the file into something else, but it only copied the problem into another file format!

Im totally stumped, so hopefully someone could shed some light onto this for me, so i can enjoy the camera and do some video editing !

Thanks in advance !
QUOTE Thanks
BenB

 
BenB's Avatar
 
Member Since: May 22, 2009
Location: Southeast Louisiana
Posts: 144
BenB is on a distinguished road

BenB is offline
You're seeing "interlace" artifacts, nothing you can to about them. Your computer screen is a progressive format, TV screens are interlaced, so you won't see it on a TV screen. In film and video, you can't move things across the screen an just any old speed you want.

Apple Certified Master Trainer
bbalser.com
FCPXProUniversity.com
LouisianaCajunCutters.org
QUOTE Thanks
Nethfel

 
Member Since: Feb 25, 2009
Posts: 2,092
Nethfel is a glorious beacon of lightNethfel is a glorious beacon of lightNethfel is a glorious beacon of lightNethfel is a glorious beacon of lightNethfel is a glorious beacon of lightNethfel is a glorious beacon of light
Mac Specs: Late 2013 rMBP, i7, 750m gpu, OSX versions 10.9.3, 10.10

Nethfel is offline
You can use Handbrake to convert it and for the most part get rid of the interlaced artifacts, but you have to turn on either Deinterlace or Decomb.

They both work similarly, but they are mutually exclusive - otherwise you either use Decomb OR Deinterlace, but not both - if I recall correctly from how HB works, DeInterlace does its job on every frame for all portions of the frame where as Decomb is more of an intelligent deinterlace where it will only do it on the frames that require it. They recommend using the intelligent form because it won't mess with frames that don't have the artifacts leaving overall a sharper image (deinterlacing tends to blur the image a little). If your final output is to put it back on DVD tho, you might as well leave the footage the way it is, but if you want your output to be on a computer screen or uploading to a video service, you may want to convert it.

My Macs: Late 2013 rMBP w/ 750m; Mac mini G4, 1.25 GHz, 512m ram (server); Late 2011 11" MBA, 1.8GHz i7, 4Gig Ram, 256Gig SSD, HD3000; Powerbook 12" G4 1.33GHz running Debian as a server; Apple TV (1080p version)
QUOTE Thanks
Chris_Music

 
Member Since: Jan 14, 2010
Location: Salisbury, UK
Posts: 10
Chris_Music is on a distinguished road
Mac Specs: Mac pro (2nd gen) 14gb ram, 2500gb, Logic Pro 9, Final Cut

Chris_Music is offline
What i dont understand is why the video is fine when being played through iMovie and Toast, but not when being played with VLC, Quicktime and Final Cut.

I dont really fancy converting it all the time, as i dont want any quality loss!

There must be a solution for it!
QUOTE Thanks
Nethfel

 
Member Since: Feb 25, 2009
Posts: 2,092
Nethfel is a glorious beacon of lightNethfel is a glorious beacon of lightNethfel is a glorious beacon of lightNethfel is a glorious beacon of lightNethfel is a glorious beacon of lightNethfel is a glorious beacon of light
Mac Specs: Late 2013 rMBP, i7, 750m gpu, OSX versions 10.9.3, 10.10

Nethfel is offline
My only guess is that VLC, quicktime and final cut are not doing realtime/runtime de-interlacing. In VLC, with the file open, go to the Video menu, and you should see a deinterlace option near the bottom of the dropdown. Try different options in there to improve your output.

You can try to use: Download JES Deinterlacer for Mac - QuickTime deinterlacer. MacUpdate Mac Software Downloads for quicktime, but I doubt it works with quicktime X (only 7) and I don't know about 10.6 compatibility.

My Macs: Late 2013 rMBP w/ 750m; Mac mini G4, 1.25 GHz, 512m ram (server); Late 2011 11" MBA, 1.8GHz i7, 4Gig Ram, 256Gig SSD, HD3000; Powerbook 12" G4 1.33GHz running Debian as a server; Apple TV (1080p version)
QUOTE Thanks
Chris_Music

 
Member Since: Jan 14, 2010
Location: Salisbury, UK
Posts: 10
Chris_Music is on a distinguished road
Mac Specs: Mac pro (2nd gen) 14gb ram, 2500gb, Logic Pro 9, Final Cut

Chris_Music is offline
Quote:
Originally Posted by Nethfel View Post
My only guess is that VLC, quicktime and final cut are not doing realtime/runtime de-interlacing. In VLC, with the file open, go to the Video menu, and you should see a deinterlace option near the bottom of the dropdown. Try different options in there to improve your output.
That trick worked for VLC, everything plays fine now, but how do i go about doing it in final cut? i tried adding the de-interlacing filter onto the video and it made no difference!

Could it be todo with the PAL/NTSC differences as the camcorder is PAL?
QUOTE Thanks
Chris_Music

 
Member Since: Jan 14, 2010
Location: Salisbury, UK
Posts: 10
Chris_Music is on a distinguished road
Mac Specs: Mac pro (2nd gen) 14gb ram, 2500gb, Logic Pro 9, Final Cut

Chris_Music is offline
Just to finish this thread, i couldn't fix the problem in the end, so i took the sony camera back and got my self a Panasonic SD10 HD camcorder instead, which works perfect with both iMovie and Final Cut Express!

Also when i called up Sony they said the camera wasn't mac compatible, which is nice of them to tell me when it doesn't say it anywhere on the box or on their website!
QUOTE Thanks

Post Reply New Thread Subscribe


« motion 4 | Changing movie thumbnails? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 06:32 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?