New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Movies and Video For people making movies and editing video with their Mac.

Problem with iTunes and dvd digital copy


Post Reply New Thread Subscribe

 
Thread Tools
D-REW

 
Member Since: Jul 24, 2009
Posts: 6
D-REW is on a distinguished road

D-REW is offline
Hopefully someone can help me out. I bought the Fast and the Furious blue-ray box set which includes all of the digital copies for each movie. So I redeemed my code and downloaded the digital copy for the 1st movie. I noticed during the download, it only took like 2 minutes. Usually downloading a movie takes quite some time. However, after everything was done, I went to my movies library and click the movie file to play it to make sure its working. When it plays, all i see is a black screen, no video, no audio, but i see the 1 hour and 20 minutes counting down like a regular movie. how come its not showing anything though????

also my itunes folder is directly in an external hd. can that be the problem??
QUOTE Thanks
vansmith

 
vansmith's Avatar
 
Member Since: Oct 19, 2008
Location: Toronto
Posts: 18,352
vansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond repute
Mac Specs: 2012 13" MBP (2.5 i5, 8GB)

vansmith is offline
Sounds like a corrupted download. I suggest that you re-download the file. What format is the file? How big is the file?

Important Links: Community Guidelines : Use the reputation system if you've been helped.
M-F Blog :: Write for the blog
Writing a Quality Post
QUOTE Thanks
D-REW

 
Member Since: Jul 24, 2009
Posts: 6
D-REW is on a distinguished road

D-REW is offline
its an mpeg-4 format and 1.22 GB. sounds about right for any movie.

EDIT: i just redownloaded and its still doing the same thing. also i tried the 2nd movie and its doing the same thing.
QUOTE Thanks
vansmith

 
vansmith's Avatar
 
Member Since: Oct 19, 2008
Location: Toronto
Posts: 18,352
vansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond repute
Mac Specs: 2012 13" MBP (2.5 i5, 8GB)

vansmith is offline
I find it very hard that a 1GB+ file is downloading in 2 minutes. That's 8.5 MB/s (or greater) which I find very unlikely. Have you tried another computer?

Important Links: Community Guidelines : Use the reputation system if you've been helped.
M-F Blog :: Write for the blog
Writing a Quality Post
QUOTE Thanks
D-REW

 
Member Since: Jul 24, 2009
Posts: 6
D-REW is on a distinguished road

D-REW is offline
ehh no other computer around. i'll try when i go to my gf's house later. but does anyone have any other suggestions?
QUOTE Thanks

Post Reply New Thread Subscribe


« Downloading and Converting Video Clips Simply | rmvb »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 12:40 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?