Results 1 to 6 of 6
  1. #1


    Member Since
    Jul 20, 2007
    Posts
    23
    Specs:
    Black Macbook 2.16 GHz 1GB ram 160 GB HD
    iTunes keeps importing each song twice
    The past two times I've tried to import my music into iTunes, it imports each song twice. So I have to go through all my music and delete all the extra songs that loaded, one by one (a very long task).

    Well I'm about to get a new macbook (I use windows right now on my current laptop) and am going to have to import all my music on that computers iTunes.

    Am I doing something wrong? Does anyone know a way to prevent this?



    If it helps, this is how I load my music on itunes:
    I have an external hard drive that contains all my music. All my music is contained in one folder that contains 4 folders. One folder is music I've downloaded, one is music I've put on from CD's, the third folder is titled "Itunesloaded" and the fourth is titled "iTunes."
    The folders titled "iTunesloaded" and "iTunes" were not created by me but were made by my PC so I put it on the external hardrive in case it's important even though I'm not sure what it really is.
    So when I want to load my music on Itunes I just import all the music from the big folder that contains the 4 smaller folders.

  2. #2

    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    28,898
    Specs:
    iMac 2010 27" QuadI7 OSX10.11, iMac 2008 OSX10.11, MBP Late2011OSX10.11 , iPad Air, iPhone 3GS
    Uncheck "Copy Files to iTunes Music Folder when adding to Library." ITunes, Preferences, Advanced.
    See Pic below.
    Attached Images Attached Images

  3. #3

    Red Snapper's Avatar
    Member Since
    Oct 26, 2006
    Location
    California
    Posts
    167
    Specs:
    15" Macbook Pro, 2 GBs Ram, 250gb My Book, 500gb Lacie,40gb 3rd Gen ipod,60gb ipod video
    Also if you're dragging and dropping music from elsewhere make sure you aren't dragging any playlist with the files, that will add the songs twice also.

  4. #4


    Member Since
    Jul 20, 2007
    Posts
    23
    Specs:
    Black Macbook 2.16 GHz 1GB ram 160 GB HD
    Thanks for the advice, I'll give it a try

  5. #5


    Member Since
    May 29, 2009
    Posts
    1
    i've had the same problem....has really got on my t!ts cos i've copied 50gb of music over by USB and have about 10gb of duplicates! and I can't delete more than 8 tracks at a time (more than 8 just offers the option of removing from itunes lib and not the hard drive)
    the playlist file may just be the reason as to why this has happened! will be more careful in the future. thanks

    i find it easy to keep the copy to itunes library activated, when i have new music to add, i just drag it from finder into itunes and it does all the work for me! (can't believe I was so dedicated to WMP for so long - I am foolish!)

  6. #6


    Member Since
    Jun 25, 2009
    Location
    Canada
    Posts
    1
    Specs:
    issuehede
    the most interesting forum
    Hello
    I have long searched for a good forum
    I will stay here for long

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Most played song in your iTunes
    By iTodd in forum Music, Audio, and Podcasting
    Replies: 19
    Last Post: 01-29-2009, 10:45 PM
  2. every song i itunes i doubled??
    By bjorko in forum Music, Audio, and Podcasting
    Replies: 1
    Last Post: 11-21-2008, 09:34 AM
  3. Importing Song from File Transfer
    By theelbys in forum Switcher Hangout
    Replies: 1
    Last Post: 08-08-2008, 04:51 PM
  4. Most played song in iTunes...
    By moosegoose in forum iPod Hardware and Accessories
    Replies: 60
    Last Post: 05-19-2007, 03:47 PM
  5. What is the first and last song in your iTunes library
    By zeppster in forum Schweb's Lounge
    Replies: 10
    Last Post: 12-30-2004, 08:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •