New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
iPod Hardware and Accessories All iPod hardware discussions.

iTunes 7.1.1 Upgrade Loses My Entire Music Library


Post Reply New Thread Subscribe

 
Thread Tools
mac57

 
mac57's Avatar
 
Member Since: Apr 29, 2006
Location: St. Somewhere
Posts: 4,560
mac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant future
Mac Specs: iMac 27" 3.4 GHz, 256 GB SSD, 2 TB HDD, 8 GB RAM

mac57 is offline
Well, I have to join the unhappy throng. I did the full 10.4.9/iTues 7.1.1/iPhoto update. All seems to have gone well - I experienced none of the problems everyone else seems to have with the 10.4.9 part of the upgrade.

BUT, iTunes has lost its mind. Well, more to the point, it has lost my music. I can see it all sitting there in my Music->iTunes folder. The music is still there, but iTunes won't show it.

Any ideas from anyone on how to get iTunes to reestablish its link with the music that is very clearly there? Thanks.

My Macs: iMac 27" 3.4 GHz, Mac Pro 3.2 GHz, PowerMac G5 Quad 2.5 GHz, G4 Cube with 1.2 GHz Upgrade
My iStuff: 64GB iPhone 5, 64GB iPad4, 30GB iPod Video, 16GB iPod Touch
My OS': Mac OS X Lion, Mac OS X Snow Leopard, Mac OS X Tiger, Mac OS 9.2.2, openSUSE 10.3
I was on the Mac-Forums honor roll for September 2007
QUOTE Thanks
baggss

 
baggss's Avatar
 
Member Since: Oct 10, 2004
Location: Margaritaville
Posts: 10,309
baggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond repute
Mac Specs: 27" 3.4 Ghz i7 iMac-13" C2D Macbook-OSX 18.8.2-64Gb iPad 2-32 Gb iPhone 5-ATV 2-14Tb of Storage

baggss is offline
Dump your iTunes Library file and start again.

Also, I would delete the file:

com.apple.itunes.plist


QUOTE Thanks
mac57

 
mac57's Avatar
 
Member Since: Apr 29, 2006
Location: St. Somewhere
Posts: 4,560
mac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant future
Mac Specs: iMac 27" 3.4 GHz, 256 GB SSD, 2 TB HDD, 8 GB RAM

mac57 is offline
Hi baggss, thanks. Actually, I simply downloaded iTunes and installed it again, and all is well. I think the issue was Aqua4iTunes, an addition that returns iTunes to a nicer Aqua theme. I just ran that as a matter of course after the initial upgrade, as I really don't like the default iTunes theming now.

This time, after I reinstalled, I did not run the Aqua4iTunes package, and all is well. iTunes now sees my full library again, and if it is a little uglier than before, at least it works again!

Thanks for the help, and I hope that this little tidbit of info about Aqua4iTunes may help a few others.

AND baggss, welcome back man, we really missed you around here!

My Macs: iMac 27" 3.4 GHz, Mac Pro 3.2 GHz, PowerMac G5 Quad 2.5 GHz, G4 Cube with 1.2 GHz Upgrade
My iStuff: 64GB iPhone 5, 64GB iPad4, 30GB iPod Video, 16GB iPod Touch
My OS': Mac OS X Lion, Mac OS X Snow Leopard, Mac OS X Tiger, Mac OS 9.2.2, openSUSE 10.3
I was on the Mac-Forums honor roll for September 2007
QUOTE Thanks
mac57

 
mac57's Avatar
 
Member Since: Apr 29, 2006
Location: St. Somewhere
Posts: 4,560
mac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant futuremac57 has a brilliant future
Mac Specs: iMac 27" 3.4 GHz, 256 GB SSD, 2 TB HDD, 8 GB RAM

mac57 is offline
Another update folks. I went and checked the web site for Aqua4iTunes:

http://www.paul.barlow.ukonline.co.uk/

And sure enough, there is a new version that is compatible with 7.1.x. Apparently the older version was NOT compatible as I have seen, and had the known side effect of making the music library disappear.

Doh... I should have thought of that first!! Oh well, again, I hope that this may help others.

My Macs: iMac 27" 3.4 GHz, Mac Pro 3.2 GHz, PowerMac G5 Quad 2.5 GHz, G4 Cube with 1.2 GHz Upgrade
My iStuff: 64GB iPhone 5, 64GB iPad4, 30GB iPod Video, 16GB iPod Touch
My OS': Mac OS X Lion, Mac OS X Snow Leopard, Mac OS X Tiger, Mac OS 9.2.2, openSUSE 10.3
I was on the Mac-Forums honor roll for September 2007
QUOTE Thanks

Post Reply New Thread Subscribe


« 2gen nano and auto random fill? | iTunes Store error code 504 »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Apple Releases iTunes 4, QT 6.2, and iPod Update schweb Apple Rumors and Reports 2 12-17-2008 01:47 AM
iTunes is setting its own burn speeds... help! Manny Pantz iPod Hardware and Accessories 4 03-15-2007 02:41 AM
iTunes and Ripping Music arianaundomiel iPod Hardware and Accessories 0 10-14-2006 04:12 PM
iTunes missing a ton of songs after osx.4 upgrade MadSkillzMan Music, Audio, and Podcasting 3 09-16-2005 05:13 AM
iTunes 4.9 upgrade... pharme OS X - Apps and Games 1 07-19-2005 10:42 AM

All times are GMT -4. The time now is 06:01 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?