New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
iPod Hardware and Accessories All iPod hardware discussions.

itunes doesn't skip songs, but doesn't play all of the song...


Post Reply New Thread Subscribe

 
Thread Tools
VeritasCCT

 
Member Since: Jan 19, 2006
Posts: 37
VeritasCCT is on a distinguished road

VeritasCCT is offline
Hello, before people jump all over me, I did a search for my problem and I couldn't find anything that fit exactly. So here is the problem:

I transfered all of my music from my PC to my new PB. Well everything worked great and I was copying my cd's to itunes also. Well now for some reason, about 50% of my songs from cd's and copied from my other computer only play about 15 seconds of the song and then skip to the next song. This happens on my ipod too. Now if I fast forward through the song past the first 15 seconds or so, it will play, but still skips to the next song after a few seconds. I'm new to mac so I don't know if it's permissions issue and if so how to repair permissions (I'm sure I can do a search and figure that out though). Any input would be greatly appreciated as I'm sure you can understand the frustration!
Jared
QUOTE Thanks
yogi

 
yogi's Avatar
 
Member Since: Jan 14, 2005
Location: St. Gallen, Switzerland
Posts: 1,973
yogi is a name known to allyogi is a name known to allyogi is a name known to allyogi is a name known to allyogi is a name known to allyogi is a name known to allyogi is a name known to all
Mac Specs: iMac Core i5, iPad, iPhone 4

yogi is offline
I don't know exactly, but repairing permissions might be a start. Go to Applications > Utilities > Disk Utility and choose your PB's main HD. Repair the Permissions on it (the button down there).

Weird problem though, I'll do some searching.

Also, make sure you have no add-ons, widgets or scripts related to iTunes running currently. They might interfere. Try playing a song file in Quicktime, does it play fine?

If you liked this post, consider using the Reputation System.
QUOTE Thanks
VeritasCCT

 
Member Since: Jan 19, 2006
Posts: 37
VeritasCCT is on a distinguished road

VeritasCCT is offline
Ok this is even weirder. I just tried playing some of the same songs in quicktime, that I know skip in itunes. What is weird about it is when I play it in quicktime they song will play in it's entirerty, but has about a second and a half lull 15 seconds into the song...and that is where itunes makes the song skip. It's really weird and I've never heard of anything like it. I thought that it would fix itself when itunes 7 came out, but it didn't. And I can't remember there being an exact moment or action that I did on my PB to figure out what would have happened to it. I tried permissions and didn't work. I appreciate you looking into it. Thanks.
Jared
QUOTE Thanks
D3v1L80Y

 
D3v1L80Y's Avatar
 
Member Since: Feb 02, 2004
Location: PA
Posts: 12,459
D3v1L80Y has a reputation beyond reputeD3v1L80Y has a reputation beyond reputeD3v1L80Y has a reputation beyond reputeD3v1L80Y has a reputation beyond reputeD3v1L80Y has a reputation beyond reputeD3v1L80Y has a reputation beyond reputeD3v1L80Y has a reputation beyond reputeD3v1L80Y has a reputation beyond reputeD3v1L80Y has a reputation beyond reputeD3v1L80Y has a reputation beyond reputeD3v1L80Y has a reputation beyond repute
Mac Specs: MacBook

D3v1L80Y is offline
Quote:
Originally Posted by VeritasCCT
I transfered all of my music from my PC to my new PB.... Well now for some reason, about 50% of my songs from cd's and copied from my other computer only play about 15 seconds of the song and then skip to the next song.
Sounds like the song files became corrupted in the transfer.
Try reimporting a small sample of them again, to see if that makes a difference. If so, then you will have to reimport the rest and I would suggest doing so in batches and not all at once.

__________________________________________________
Posting and YOU|Forum Community Guidelines|The Apple Product Cycle|Forum Courtesy

mac: a waterproof raincoat made of rubberized fabric
MAC: a data communication protocol sub-layer, also known as the Media Access Control
Mac: a brand name which covers several lines of personal computers designed, developed, and marketed by Apple Inc.

QUOTE Thanks
flnycus

 
Member Since: Jan 02, 2007
Posts: 3
flnycus is on a distinguished road

flnycus is offline
Hey i have the exact same problem. ALl the songs play fine on my ipod, but SOME seem to have got corrupted or something on my macbook and play about 20 seconds then skip to the next one? Is this an itunes problem or is something wrong with my shiney new macbook? Please help?
QUOTE Thanks
Hippiekila

 
Member Since: May 08, 2008
Posts: 2
Hippiekila is on a distinguished road

Hippiekila is offline
Basically, the only thing i've found to work is to reformat the songs. Personally I use Audacity (freeware) with lame-3.97 (freeware)... download both on google. extract lame-3.97, install audacity, open the song in audacity, click file, export as MP3, it will pop up asking for "lame_enc.dll" with one of those browser things. Browse over to the exported folder called lame-3.97, and lame_enc.dll will be in there. Double click on that and it will encode it. Drag the file into itunes, and sync onto ipod... worked for me!
QUOTE Thanks
harleme

 
Member Since: Jan 12, 2011
Posts: 2
harleme is on a distinguished road

harleme is offline
Hey,

I know this is a really old thread but I've recently had the same problem with a number of CDs I've copied onto itunes. It plays the first 12-20 seconds of a song then skips to the next.

Did reformating the songs work or shall I try importing them again?

Thanks

Har
QUOTE Thanks
chas_m

 
chas_m's Avatar
 
Member Since: Jan 22, 2010
Location: Victoria, BC
Posts: 16,191
chas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond repute
Mac Specs: 2009 MBP, Black speakers, Black Benq second monitor, black(ish) iPhone 5s, Black 2012 iPad, etc.

chas_m is offline
Reformatting the songs -- whatever that means -- is a bad idea due to sound quality loss.

Re-import them. I personally use "iTunes Plus" settings (AAC 256kbps) and everything sounds awesome.
QUOTE Thanks
wolfeee

 
Member Since: Jan 16, 2011
Posts: 1
wolfeee is on a distinguished road

wolfeee is offline
What worked for me: Right click the problem song in iTunes, select create ACC version, (it creates a 2nd one in diff format) sort by file name in iTunes, look the the duplicates, add the ACC version to the playlist, delete the corrupt one and sync with Ipod.

It was time consuming, I had a bunch that were skipping. I disconnected my ipod from the laptop, used headphones to listen to the playlist, paused on the skipping song, go to the itunes playlist & apply the fix, unpause & find the next corrupt song, repeat. It's fixed though, didn't loose my playlists or my songs. Hope this helps someone!
QUOTE Thanks
louishen

 
louishen's Avatar
 
Member Since: Oct 22, 2007
Location: London
Posts: 8,930
louishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant futurelouishen has a brilliant future
Mac Specs: Mac Mini Core i7 2012 | White 2009 MacBook 2 Ghz | 733 Mhz G4 Quicksilver

louishen is offline
Quote:
Originally Posted by Hippiekila View Post
Basically, the only thing i've found to work is to reformat the songs. Personally I use Audacity (freeware) with lame-3.97 (freeware)... download both on google. extract lame-3.97, install audacity, open the song in audacity, click file, export as MP3, it will pop up asking for "lame_enc.dll" with one of those browser things. Browse over to the exported folder called lame-3.97, and lame_enc.dll will be in there. Double click on that and it will encode it. Drag the file into itunes, and sync onto ipod... worked for me!
Audacity does use the LAME encoder that can sometimes cause this skip bug.

Re-encoding (hopefully from the original CD) using iTunes's encoder will cure any songs of this skipping error

Member of the Month September 2008 & August 2012 | Found advice useful? use the rep system
QUOTE Thanks
harleme

 
Member Since: Jan 12, 2011
Posts: 2
harleme is on a distinguished road

harleme is offline
Thanks guys for the speedy replies! I'll probably try re-importing them as it sounds less complicated for me
QUOTE Thanks
dancin2nite

 
Member Since: Jul 04, 2011
Posts: 1
dancin2nite is on a distinguished road

dancin2nite is offline
I had the same problem-they played fine in itunes, but then when I started walking for exercise, they would play just a few seconds of the song and then switch to another, and so on. It drove me crazy. Then I restored, redid all of my music to no avail. Then I noticed it would play fine when I had it connected to my ipod player. I was telling my 15 yr old niece about it and she asked me if I had it on "Shake to Shuffle." Guess what? I did! And now it works fine! And who said teenagers didn't know anything! On ipod touch: Go to "Settings", Scroll down to Music, then unclick "Shake to Shuffle." Hope this works for some of you!
QUOTE Thanks

Post Reply New Thread Subscribe


« HELP! I'm very ignorant! | Will iPad accessories work with a iPod touch 4? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Most songs play thru AirTunes, some do not IanCT Internet, Networking, and Wireless 14 09-24-2009 01:16 AM
iTunes Library Randomly Jumps Songs When Skipping Track wicker_man iPod Hardware and Accessories 6 04-12-2009 01:47 PM
iTunes songs skipping like a bad CD scottie924 iPod Hardware and Accessories 3 11-27-2005 01:29 PM
iTunes missing a ton of songs after osx.4 upgrade MadSkillzMan Music, Audio, and Podcasting 3 09-16-2005 05:13 AM
iTunes copying each song to... shaun89 OS X - Apps and Games 5 03-05-2005 02:23 PM

All times are GMT -4. The time now is 07:19 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?