Results 1 to 8 of 8
  1. #1

    TomyDingo's Avatar
    Member Since
    May 29, 2005
    Location
    Austin, Texas
    Posts
    133
    Specs:
    20" 2.4 GHz iMac w/ 4GB RAM & 320GB HD
    problems with art for albums on iPod
    anyone ever have the problem of the wrong artwork being displayed for an artist on the iPod, but not on iTunes? It happens to me occasionally and I have to delete the artwork, then add it back to the album. Is there a way to fix this?

  2. #2


    Member Since
    Jan 18, 2006
    Posts
    232
    It sometimes depends on album title..
    iTunes using ITMS should not be a problem, but I do know that if you download from another site and try to get art using a widget, you must have the correct album title in that field in the iTunes library in order to retrieve art or the correct art.

    I wish I knew of a way to get all of the song info from Gracenote when I download from another site.

  3. #3

    TomyDingo's Avatar
    Member Since
    May 29, 2005
    Location
    Austin, Texas
    Posts
    133
    Specs:
    20" 2.4 GHz iMac w/ 4GB RAM & 320GB HD
    Quote Originally Posted by farmcock
    iTunes using ITMS should not be a problem, but I do know that if you download from another site and try to get art using a widget, you must have the correct album title in that field in the iTunes library in order to retrieve art or the correct art.

    I wish I knew of a way to get all of the song info from Gracenote when I download from another site.
    my problem is that I've had the correct artwork for the album and it will appear correct on the iPod, but then something changes and the artwork gets changed.

  4. #4

    Sobe's Avatar
    Member Since
    Aug 24, 2005
    Posts
    175
    Specs:
    17" 2.8ghz Macbook Pro, 32GB iPhone 4
    Deja Vu..

    They changed something...

  5. #5

    TomyDingo's Avatar
    Member Since
    May 29, 2005
    Location
    Austin, Texas
    Posts
    133
    Specs:
    20" 2.4 GHz iMac w/ 4GB RAM & 320GB HD
    Quote Originally Posted by Sobe
    Deja Vu..

    They changed something...
    what?

  6. #6

    TomyDingo's Avatar
    Member Since
    May 29, 2005
    Location
    Austin, Texas
    Posts
    133
    Specs:
    20" 2.4 GHz iMac w/ 4GB RAM & 320GB HD
    can someone help me with this problem?

    i'll try to better explain what happens.

    i'll rip a CD from my collection, then find the artwork online and add it to the album. it is displayed correctly on iTunes. Then when I upload it to my iPod, something gets messed up. When I play the album on my iPod, the artwork from a different album will be attached to my newly uploaded album. The artwork that is incorrectly attached to my new album is from artwork of an album already on my iPod.

    Does anyone experience this problem? I just restored my iPod to see if that will fix it

  7. #7


    Member Since
    Jan 17, 2005
    Location
    Vancouver, WA
    Posts
    68
    Specs:
    12" G4 1.2 GHz iBook 768mb
    Quote Originally Posted by TomyDingo
    can someone help me with this problem?

    i'll try to better explain what happens.

    i'll rip a CD from my collection, then find the artwork online and add it to the album. it is displayed correctly on iTunes. Then when I upload it to my iPod, something gets messed up. When I play the album on my iPod, the artwork from a different album will be attached to my newly uploaded album. The artwork that is incorrectly attached to my new album is from artwork of an album already on my iPod.

    Does anyone experience this problem? I just restored my iPod to see if that will fix it
    This just happened to me last night. To clear it up for those who misunderstood the first time: the album artwork is correctly matched in Itunes. On the iPod, however, it's all mixed up. I'm going to try unchecking album artwork the next time I update my 'pod, then checking it for the following update. Maybe that'll clear things up.

    How did the restore turn out?

  8. #8

    TomyDingo's Avatar
    Member Since
    May 29, 2005
    Location
    Austin, Texas
    Posts
    133
    Specs:
    20" 2.4 GHz iMac w/ 4GB RAM & 320GB HD
    what i think was screwing it up was the application Clutter I was using to add the artwork to itunes. I stopped using Clutter and now just manually add artwork and it hasn't messed up since

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. iPod won't play albums in order
    By Gumbo20 in forum iOS and Apps
    Replies: 2
    Last Post: 04-09-2009, 03:58 PM
  2. sync'g iPhoto albums on iPod
    By Daddy Elmis in forum iPod Hardware and Accessories
    Replies: 3
    Last Post: 03-13-2008, 05:19 PM
  3. Ipod art print
    By ipod lover in forum iPod Hardware and Accessories
    Replies: 1
    Last Post: 09-16-2007, 06:26 AM
  4. Shuffling albums w/ Ipod video
    By bobby_bishop in forum iPod Hardware and Accessories
    Replies: 0
    Last Post: 06-22-2006, 06:35 PM
  5. Chronological Albums for iPod
    By october in forum iPod Hardware and Accessories
    Replies: 3
    Last Post: 06-16-2005, 04:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •