New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
iPod Hardware and Accessories All iPod hardware discussions.

iPod sorting issues


Post Reply New Thread Subscribe

 
Thread Tools
DennisAlexis

 
Member Since: Jul 27, 2010
Posts: 9
DennisAlexis is on a distinguished road

DennisAlexis is offline
Hi!
I'm new to the forum. English isn't my native language but I hope you'll be able to understand me. I have attached a picture of what my tags look like.

I have ripped a Kim Wilde CD in iTunes. It includes a duet which I tagged as "Kim Wilde & Junior", in the artist field. To get iTunes to sort the all the songs in the same album, I used the "sort artist field" and entered Kim Wilde.

It works fine in iTunes, but when I put the album on my iPod, "Kim Wilde & Junior" get an entry of their own, with only the duet in it. And the duet doesn't show up at all in the "Kim Wilde" section.

Also, there are now two "Kim Wilde" in the iPod artist list. What have I done wrong?

I have tried several Swedish Mac forums but I never got any answers, so I would appreciate your help!

Thank you!
Attached Images
File Type: png KimWildeiTunesError2.png (369.2 KB, 4 views)
QUOTE Thanks
DennisAlexis

 
Member Since: Jul 27, 2010
Posts: 9
DennisAlexis is on a distinguished road

DennisAlexis is offline
Pretty please?
QUOTE Thanks
chas_m

 
chas_m's Avatar
 
Member Since: Jan 22, 2010
Location: Victoria, BC
Posts: 15,696
chas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond repute
Mac Specs: 2009 MBP, Black speakers, Black Benq second monitor, black(ish) iPhone 5s, Black 2012 iPad, etc.

chas_m is offline
Go into the tagging info for the song, and make sure that "Album Artist" is the same as it is for the rest of the album. If those fields are blank, fill them in with "Kim Wilde." That will group it together.
QUOTE Thanks
DennisAlexis

 
Member Since: Jul 27, 2010
Posts: 9
DennisAlexis is on a distinguished road

DennisAlexis is offline
Thanks for your reply. Sadly, it didn't work. There are still 2 "Kim Wilde" and none of them include the duet, it's under "Kim Wilde & Junior".

Do you think it would help to restore the iPod? I don't understand why it works in iTunes but not on the iPod.

Quote:
Originally Posted by chas_m View Post
Go into the tagging info for the song, and make sure that "Album Artist" is the same as it is for the rest of the album. If those fields are blank, fill them in with "Kim Wilde." That will group it together.
QUOTE Thanks
DennisAlexis

 
Member Since: Jul 27, 2010
Posts: 9
DennisAlexis is on a distinguished road

DennisAlexis is offline
I tried restoring the iPod (removed all the tracks ect) but the problem is still there.

I'll attach a new photo of what the tagging looks like on the iPod. Maybe you can find something I've missed.

Is it possible to choose sorting settings especially for the iPhone?
Attached Images
File Type: png iTunesError.png (58.6 KB, 3 views)
QUOTE Thanks
bobtomay

 
bobtomay's Avatar
 
Member Since: Dec 22, 2006
Location: Texas, where else?
Posts: 24,586
bobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond repute
Mac Specs: 15" MBP 2.33 C2D 256 4GB, MBA 13" i7 1.8, MB 2.0 2GB, Nano 4th, 3GS, iPad 1

bobtomay is offline
you need to make sure both the Artist and the Album fields are the same. I'd suggest highlighting all the tracks simultaneously, then do a 'Get Info' and re-type those two fields.

You could try just editing the Album field. But if you leave the artist field different for that one song, whenever you sort by artist, it's going to show up separately.

I have this sort of issue with my multi-part audio books all the time. Nowadays, I edit the entire book at once myself as soon as I import them.


edit:
Actually, from the pic, it looks like you have it all edited correctly. When you go to look based on artist in the iPod app, it's going to show that song separately. If you have re-synced already, I'd try removing that album from your iPod and sync again.

I cannot be held responsible for the things that come out of my mouth.
In the Windows world, most everything folks don't understand is called a virus.
QUOTE Thanks
DennisAlexis

 
Member Since: Jul 27, 2010
Posts: 9
DennisAlexis is on a distinguished road

DennisAlexis is offline
The strange thing is that it has worked before. When using the "sort artist" field I could access the whole album (including duets) by going in through a single artist. :S

I looked, and none of the older albums with duets work either. Could there be a setting issue?

Quote:
Originally Posted by bobtomay View Post
Actually, from the pic, it looks like you have it all edited correctly. When you go to look based on artist in the iPod app, it's going to show that song separately. If you have re-synced already, I'd try removing that album from your iPod and sync again.
QUOTE Thanks
DennisAlexis

 
Member Since: Jul 27, 2010
Posts: 9
DennisAlexis is on a distinguished road

DennisAlexis is offline
This is what it looks like on the iPod. Two "Kim Wildes" and none of them include the duet, even though I've used the "sort artist" field.
Attached Images
File Type: jpg P1010274.JPG (70.0 KB, 6 views)
QUOTE Thanks
bobtomay

 
bobtomay's Avatar
 
Member Since: Dec 22, 2006
Location: Texas, where else?
Posts: 24,586
bobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond repute
Mac Specs: 15" MBP 2.33 C2D 256 4GB, MBA 13" i7 1.8, MB 2.0 2GB, Nano 4th, 3GS, iPad 1

bobtomay is offline
Yep, remove them from your iPod and resync.

I cannot be held responsible for the things that come out of my mouth.
In the Windows world, most everything folks don't understand is called a virus.
QUOTE Thanks
DennisAlexis

 
Member Since: Jul 27, 2010
Posts: 9
DennisAlexis is on a distinguished road

DennisAlexis is offline
I tried, but it didn't work. Still looks the same as my last attachment. Maybe I need an iPod Touch to be able to scroll though and get all songs from one album in the same list (duets included)?
QUOTE Thanks
bobtomay

 
bobtomay's Avatar
 
Member Since: Dec 22, 2006
Location: Texas, where else?
Posts: 24,586
bobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond repute
Mac Specs: 15" MBP 2.33 C2D 256 4GB, MBA 13" i7 1.8, MB 2.0 2GB, Nano 4th, 3GS, iPad 1

bobtomay is offline
If you still have 'Kim Wilde' listed twice when browsing by artist, there is something different about the way they are typed into iTunes. A space at the end of one of them, or something. I've had some I never did figure out what was different.

You need to highlight all of those tracks at one time in iTunes, then right click and select Get Info. then you'll be editing the Artist box in all of them at one shot so you know they're all the same.
As long as you keep the other track with both artists names, it's going to appear as a separate artist when viewing by artist. If the Album name is correct, it will appear in the same album when viewing by album.

I cannot be held responsible for the things that come out of my mouth.
In the Windows world, most everything folks don't understand is called a virus.
QUOTE Thanks
DennisAlexis

 
Member Since: Jul 27, 2010
Posts: 9
DennisAlexis is on a distinguished road

DennisAlexis is offline
Thanks, I've tried that many times but there are still two Kim Wilde. It's the same with all artists that have a duet.
QUOTE Thanks
DennisAlexis

 
Member Since: Jul 27, 2010
Posts: 9
DennisAlexis is on a distinguished road

DennisAlexis is offline
Also, both "Kim Wilde" show exactly the same albums and tracks. :S I've tried everything...
QUOTE Thanks

Post Reply New Thread Subscribe


« Copying tracks from iPod to iMac | Transfering apps & music from old Ipod touch to new? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 08:35 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?