New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
iPod Hardware and Accessories All iPod hardware discussions.

ipod video classic


Post Reply New Thread Subscribe

 
Thread Tools
bruce101

 
Member Since: Mar 19, 2010
Posts: 2
bruce101 is on a distinguished road

bruce101 is offline
hi all,

i have an ipod video classic for a year now. what happen is that every time i turn it on it will only display the apple logo then will turn off. i have tried charging it many time but it seems not to load up completely the play list. any ideas?

Bruce
QUOTE Thanks
clayneal

 
clayneal's Avatar
 
Member Since: Mar 27, 2009
Location: Lincoln Nebraska
Posts: 2,146
clayneal is a glorious beacon of lightclayneal is a glorious beacon of lightclayneal is a glorious beacon of lightclayneal is a glorious beacon of lightclayneal is a glorious beacon of lightclayneal is a glorious beacon of light
Mac Specs: late 08 macbook 2.0 4gig 320hdd10.7.3 32 gig iPhone 4s

clayneal is offline
Hello and welcome to Mac-Forums ,

There are several steps you should / can take to try to resolve your issues and this is a great place for you to start:

Apple - Support - iPod classic

Hope this helps
Clay

MY ADVICE COMES WITH A DOUBLE YOUR MONEY BACK GUARANTEE!
QUOTE Thanks
bruce101

 
Member Since: Mar 19, 2010
Posts: 2
bruce101 is on a distinguished road

bruce101 is offline
this is really a lot of help. thanks a lot for it

Bruce
propellerhead reason
QUOTE Thanks

Post Reply New Thread Subscribe


« iPod creates several folders for one album | Synching ipod to a new computer »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 08:11 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?