New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
iPod Hardware and Accessories All iPod hardware discussions.

iPod Touch - iPod touch white screen?


Post Reply New Thread Subscribe

 
Thread Tools
deathtolife04

 
Member Since: Sep 02, 2006
Posts: 198
deathtolife04 is an unknown at this point

deathtolife04 is offline
I have read things about people having problems with their iPod touches freezing, and having a white screen pop up.


I have gotten the white screen 3 times now, but it doesn't totally freeze. It only happens when I'm trying to turn off my iPod. I'll hold the botton down, slide it over to shut it off, and it acts like it's shut off just fine. Then a few seconds later I get the white screen. Then I just turn it on, and shut it back off again and it's fine.


Do you think this is something to worry about? It doesn't really bother me, but if it's gonna lead to other problems I'm gonna go exchange it.


Also- if I ordered it online would they let me exchange it in-store if I had to?
QUOTE Thanks
deathtolife04

 
Member Since: Sep 02, 2006
Posts: 198
deathtolife04 is an unknown at this point

deathtolife04 is offline
OK so I exchanged it on Monday.
Now, on Wednesday, the new one is starting to do the same thing.

Any ideas?
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,493
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
I assume this is a 2G iPod Touch? I've yet to see this behavior, but then, I rarely turn mine completely off. Instead, I just hit the top button to blank the screen and let the power management do its thing. Are you running 2.2 on it?

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
deathtolife04

 
Member Since: Sep 02, 2006
Posts: 198
deathtolife04 is an unknown at this point

deathtolife04 is offline
Quote:
Originally Posted by cwa107 View Post
I assume this is a 2G iPod Touch? I've yet to see this behavior, but then, I rarely turn mine completely off. Instead, I just hit the top button to blank the screen and let the power management do its thing. Are you running 2.2 on it?

Yeah, it's the 2G and I'm running 2.2.
When I got the first one, I had to do a free software update in iTunes to get 2.2. With the second one I got, it was already on there. So I know the second one is a newer one.

I'm just really confused as to why I've had this problem with two in a row. One was ordered from online, and the other I got from the Apple store. So it's not like I just got a couple from one bad batch, ya know?

You don't think a certain app could be causing it do you?
QUOTE Thanks
chrisiw

 
chrisiw's Avatar
 
Member Since: Mar 06, 2007
Location: Isle of Wight UK
Posts: 252
chrisiw is on a distinguished road
Mac Specs: iMac, iPad, MacBook Pro.

chrisiw is offline
I have just got one, had it for 4 days and all is great, no problems, could it be an "App" that you have put on causing the problem?
QUOTE Thanks
ASUGeog

 
Member Since: Apr 25, 2008
Location: Boone NC
Posts: 42
ASUGeog is on a distinguished road
Mac Specs: 2.5 GHz 15" MacBook Pro

ASUGeog is offline
i have the white screen problem on mine, but it is frozen... i have the 32 GB touch. i posted in another thread but this seems more relevant. anyone know how to get this problem taken care of?
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,493
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
Quote:
Originally Posted by ASUGeog View Post
i have the white screen problem on mine, but it is frozen... i have the 32 GB touch. i posted in another thread but this seems more relevant. anyone know how to get this problem taken care of?
Interesting. I haven't had this problem yet - and in fact, what problems I did have were resolved by the 2.2 firmware (mostly related to volume settings and wi-fi issues with WPA encryption). It's possible that you just have a defective unit.

Does the problem occur after doing a restore and without any third party apps installed?

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
ASUGeog

 
Member Since: Apr 25, 2008
Location: Boone NC
Posts: 42
ASUGeog is on a distinguished road
Mac Specs: 2.5 GHz 15" MacBook Pro

ASUGeog is offline
Quote:
Originally Posted by cwa107 View Post
Interesting. I haven't had this problem yet - and in fact, what problems I did have were resolved by the 2.2 firmware (mostly related to volume settings and wi-fi issues with WPA encryption). It's possible that you just have a defective unit.

Does the problem occur after doing a restore and without any third party apps installed?
i haven't done a restore, and i do have some apps on there. i'm using the 2.2 firmware
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,493
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
Quote:
Originally Posted by ASUGeog View Post
i haven't done a restore, and i do have some apps on there. i'm using the 2.2 firmware
I would do a restore, but don't install any 3rd party apps. Test for a couple of days and see if you run into it again. If you do, it's likely you have a defective unit.

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
ASUGeog

 
Member Since: Apr 25, 2008
Location: Boone NC
Posts: 42
ASUGeog is on a distinguished road
Mac Specs: 2.5 GHz 15" MacBook Pro

ASUGeog is offline
problem reslved, for now. i let the battery die and when i started recharging it the touch worked just fine.
QUOTE Thanks
lui22

 
Member Since: Dec 31, 2008
Posts: 2
lui22 is on a distinguished road

lui22 is offline
i have gotton the same problem also but i did a sys. restore or restore from backup. and it worked for now
this is also my second one
QUOTE Thanks
lui22

 
Member Since: Dec 31, 2008
Posts: 2
lui22 is on a distinguished road

lui22 is offline
Quote:
Originally Posted by deathtolife04 View Post
Yeah, it's the 2G and I'm running 2.2.
When I got the first one, I had to do a free software update in iTunes to get 2.2. With the second one I got, it was already on there. So I know the second one is a newer one.

I'm just really confused as to why I've had this problem with two in a row. One was ordered from online, and the other I got from the Apple store. So it's not like I just got a couple from one bad batch, ya know?

You don't think a certain app could be causing it do you?
well lets see what apps all of us have in common im going to start another thread and lets start listing the apps we have in common
QUOTE Thanks
deathtolife04

 
Member Since: Sep 02, 2006
Posts: 198
deathtolife04 is an unknown at this point

deathtolife04 is offline
Quote:
Originally Posted by lui22 View Post
well lets see what apps all of us have in common im going to start another thread and lets start listing the apps we have in common


Here's a list of the apps I have right now:

AIM
AP Mobile News
Bible
BlocksClassic Lite
Brain Toot (free version)
Brain Tuner
Crash Bandicoot Nitro Cart
Facebook
Files Lite
Google Earth
Google Mobile App
Graphic Calculator
HiCalc Lite
i.TV
Jelly Car
Labrynth Lite Edition
Line Rider iRide
Mandelbrot
Myspace Mobile
NYTimes
Palringo
Quick Graph
Remote
Rock 'n' Roll Lite
Shakespeare
The Snow Report
Spore Origins
Tap Tap Revenge
Topple
Urbanspoon
US National Debt
The Weather Channel
WebMD Mobile
Wiki Tap
WordPress

And out of those, here is a list of apps I'm PRETTY sure I didn't have when I first started having the white screen problem:

BlocksClassic Lite
Jelly Car
Labrynth Lite Edition
Line Rider iRide
Mandelbrot
Rock 'n' Roll Lite
The Weather Channel
WebMD Mobile
QUOTE Thanks
wilsonstark

 
Member Since: Jan 05, 2009
Posts: 1
wilsonstark is on a distinguished road

wilsonstark is offline
Not to highjack, but since this was the top Google search for "white screen iPod touch 2g" I just thought I'd note that some of the 2G Touch units are having a hardware problem causing permanent white screen when on, even though they are NOT frozen.

I am in the process of returning mine to Apple and found others with similar problems when I looked. None of the normal resets, etc did anything, including a full reset to factory. Interestingly, even with the screen white the input part of the touch screen works. If I can guess which part of the page I am on I can turn up the speaker and hear it responding. iTunes also recognizes it and can tell me when it is charging, change what is installed on it, etc.

If someone is finding this from Google and is having a similar issue, make sure to call Apple care if resets and/or a backup/restore cycle doesn't do the job. Apple Care telephone and Genius bar folks both were unsurprised by the issue, although none went so far as to say it was a common problem.

Mine was a <2 month old 8GB iPod Touch 2G, not roughly treated and using a hard case and screen protector. Don't think apps were the cause as nothing changes when I reverted it to factory settings, reset, etc.

W
QUOTE Thanks
trapeze

 
Member Since: Dec 08, 2008
Posts: 21
trapeze is on a distinguished road

trapeze is offline
I guess I can be added to the list of people with this problem. I was sitting on a weight machine at the gym when I dropped it. It fell perhaps two feet onto a rubber coated floor. It had a hard case surrounding it. This seemed to be a pretty casual fall to me. Nevertheless, it would only display a white screen. When I returned home I connected it to my MacBook and did a complete restore. It failed to make a difference. I guess I will be calling Apple in the morning to see what they want to do about it. This iPod Touch (32 gig) is less than two months old and has worked flawlessly until this evening. I have to say that I am more than a little disappointed with the iPod's resistance to a very small drop. I am sure that Apple will take care of it but I was hoping for a little more durability than this. I never had a hardware failure like this with my previous PDA type devices.


Lifelong MS/PC user since 1984
Purchased first MacBook 11/17/2008
2.4gHz 2gRAM 250gb
I have burned the ships...there will be no return
QUOTE Thanks

Post Reply New Thread Subscribe


« Weird syncing thing... | Copying tracks from iPod to iMac »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
ipod touch - Dark Screen? nl74 iPod Hardware and Accessories 9 09-18-2007 06:35 PM

All times are GMT -4. The time now is 05:31 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?