Results 1 to 4 of 4
  1. #1

    Member Since
    Nov 25, 2013
    After iOS 7 I can't tether using usb ?
    Hello All

    After upgrading to iOS 7 on my iphone 4 I can no longer use my personal hotspot with a usb cable (wifi connection works)

    When I go to system preferences>Network>Ethernet (Macbook Pro ...0S 10.6.8 )

    It says "cable unplugged " but it is plugged because I can charge and transfer data using this cable

    Here is what I've tried so far on my Macbook Pro with OSX 10.6.8 and my iphone 4

    Tried a different cable ..... did not work

    Made ethernet setting inactive and active again .. did not work

    Deleted Ethernet setup and and created it again .. did not work

    Reset the iphone network settings twice did not work

    So what now ?

    I don't like the iOS 7 it slows my phone down

    Thanks All

  2. #2

    MacInWin's Avatar
    Member Since
    Jul 07, 2008
    Winchester, VA
    2011 MBP, 2008 iMac, iPhone 6, iPad mini, 13" MBP, AppleTV and MacMini
    Is the hotspot turned on in the iPhone? You didn't say.

  3. #3

    bobtomay's Avatar
    Member Since
    Dec 22, 2006
    Texas, where else?
    15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '11 1.8 i7 4GB 10.10; 21" iMac '13 2.9 i5 8GB 10.10; 5s & 5c
    Several users have noted several different fixes for them in this thread at apple's forums.
    I cannot be held responsible for the things that come out of my mouth.
    In the Windows world, most everything folks don't understand is called a virus.

  4. #4

    Member Since
    Nov 25, 2013
    thanks for the suggestion

    I went there and found a thread that was very helpful

    Here is what I did

    I Redownloaded Kext Utility mentioned earlier in this thread

    unzipped it using the unarchiver

    downloaded the AppleUSBEthernethost.kext file


    Unzipped it

    opened Kext Untility and dragged AppleUSBEthernethostkext file into it

    Restarted the computer

    Opened up system preferences > network settings

    clicked on the + at the bottom of the page and iphone USB option was there (wasn't before)

    Clicked Create and then Apply (bottom of box)

    And it worked It's great to have this feature back

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Tethering not working with IOS 7 usb
    By ryanlabe in forum iPhone Hardware and Accessories
    Replies: 11
    Last Post: 09-26-2013, 10:57 PM
  2. I can't tether iphone4s to my macbook via usb
    By aubayram in forum Internet, Networking, and Wireless
    Replies: 5
    Last Post: 08-19-2013, 03:36 PM
  3. Tether itouch
    By Lycangel in forum iOS and Apps
    Replies: 1
    Last Post: 01-17-2010, 05:42 PM
  4. Does anyone know how to Tether without jailbreaking?
    By Luminosity in forum iPhone Hardware and Accessories
    Replies: 13
    Last Post: 12-11-2008, 03:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts