New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
iPhone Hardware and Accessories Discuss iPhone hardware

Please help


Post Reply New Thread Subscribe

 
Thread Tools
rschamblee

 
Member Since: Jan 01, 2011
Posts: 9
rschamblee is on a distinguished road

rschamblee is offline
I have a iphone 3Gs and the speakers still work but the ringer does not work when someone calls. when I adjust the sound up and down it will ring letting you know where your volume is, but when someone calls me the phone only vibrates (will not ring).

I have downloaded the most recent software and its still not working!!
QUOTE Thanks
pendlewitch

 
Member Since: Sep 10, 2011
Location: Nelson,UK
Posts: 1,743
pendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of light
Mac Specs: iMac 27" Mid 2010, 3.2GHz Intel Core i3,4GB 1333 MHz DDR3, ATI Radeon HD5670 512MB, Yosemite 10.10.1

pendlewitch is offline
Hello there,

I've just tried replicating this by sliding the mute button off on the top left side of my iPhone so that the red line shows and yes, you are right, you can still hear music but the ringer will be mute.

Unslide the ringer mute and you should be back to normal.

iMac 27-inch Mid 2010 (wow....that old...eeeks!), WD My Book 1TB Firewire,WD My Passport Air 500GB, Magic Mouse,Magic Trackpad,
iPhone 5C, iPod Nano 4GB 3rd Gen, ATV2.
MOTM October 2012. These days normally happy with an occasional grumble.
QUOTE Thanks
rschamblee

 
Member Since: Jan 01, 2011
Posts: 9
rschamblee is on a distinguished road

rschamblee is offline
thanks for the reply pendlewitch but thats not the problem.. I have the mute button off or the sound switched to on on the top left part of the phone.. The volume is up.. It just will not ring when someone calls me, all the other sounds work perfectly fine!!! Its crazy, not sure what is going on with this phone...
QUOTE Thanks
pendlewitch

 
Member Since: Sep 10, 2011
Location: Nelson,UK
Posts: 1,743
pendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of light
Mac Specs: iMac 27" Mid 2010, 3.2GHz Intel Core i3,4GB 1333 MHz DDR3, ATI Radeon HD5670 512MB, Yosemite 10.10.1

pendlewitch is offline
Not sure either mate, unless the slider switch is fouled in some way so that it can't make the correct contact.

Have you tried doing a cold reset (powering down and then re-booting) ?

iMac 27-inch Mid 2010 (wow....that old...eeeks!), WD My Book 1TB Firewire,WD My Passport Air 500GB, Magic Mouse,Magic Trackpad,
iPhone 5C, iPod Nano 4GB 3rd Gen, ATV2.
MOTM October 2012. These days normally happy with an occasional grumble.
QUOTE Thanks
Eric559

 
Eric559's Avatar
 
Member Since: Jul 18, 2007
Location: Central California
Posts: 3,185
Eric559 is a glorious beacon of lightEric559 is a glorious beacon of lightEric559 is a glorious beacon of lightEric559 is a glorious beacon of lightEric559 is a glorious beacon of lightEric559 is a glorious beacon of light
Mac Specs: 2.16GHz C2D MacBook w/ 2GB RAM & 120GB HD. HTC Droid Incredible.

Eric559 is offline
Quote:
Originally Posted by rschamblee View Post
thanks for the reply pendlewitch but thats not the problem.. I have the mute button off or the sound switched to on on the top left part of the phone.. The volume is up.. It just will not ring when someone calls me, all the other sounds work perfectly fine!!! Its crazy, not sure what is going on with this phone...
Try going into the settings and selecting a different ring tone. Call the phone and see if that works.

Member Of The Month for December '08.
It's only the internet!
QUOTE Thanks

Post Reply New Thread Subscribe


« need iphone help, 2 phones 1 apple id 1 computer | New iPhone 4S - transfer contacts ex Nokia N95 »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 04:21 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?