New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
iPhone Hardware and Accessories Discuss iPhone hardware

So I might have a hardware failure on my iphone 3gs?


Post Reply New Thread Subscribe

 
Thread Tools
laura331

 
Member Since: Jun 14, 2011
Posts: 16
laura331 is on a distinguished road

laura331 is offline
When I first turned it on it wouldn't turn on. I thought I got it wet and I put it in a bag of rice for a couple of days. Now it turns on but it doesn't have any sound and it keeps coming up with this accessory is not optimized for this iphone. What should I do?
QUOTE Thanks
mrplow

 
mrplow's Avatar
 
Member Since: Oct 01, 2007
Location: UK
Posts: 6,643
mrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond repute
Mac Specs: 27" iMac i7 (2011) 10.9, iPhone5s, iPad Air, AppleTV2

mrplow is offline
Best bet is just to take it to an Apple store. If it's covered by warranty, great. If not the charge a flat-fee for replacing iPhones with a reconditioned model.

External hard disk acquisition addict - but admitting the problem is the first step to a robust backup

Please use the reputation system if you think you've been helped - top right of this post
QUOTE Thanks

Post Reply New Thread Subscribe


« can anyone help me find what i did wrong? | Reinstall the entire firmware on the iPhone? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 06:13 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?