Results 1 to 4 of 4
  1. #1

    Member Since
    Jun 18, 2011
    Reinstall the entire firmware on the iPhone?
    My sister dropped her iPhone 3Gs in the toilet the other day.
    After letting it dry out for a while we turned it on and it was fine.
    But as soon as you press any apps on the screen even the basic pre-installed ones it just loads 1% of them, just enough for you to see that the app opens and then freezes and restarts itself after some time.
    I decided to back it up, reset it, set it up as a new phone, updating it to the latest firmware (previously 4.3.1, updated to 4.3.3) and restore it to factory settings.

    Seemingly nothing has worked since after I restored it to factory settings (with out errors) it comes up with that screen where its the USB cable going to the apple sign and all you can do is emergency call.

    Now the way I fix my phone when that happens is by re-jailbreaking it but I havenīt tried that on this phone because I highly doubt that will work.

    After some trying around I managed to get past the USB to PC screen and have now gotten to the menu yet again.
    No personal apps are installed anymore and still it continues to fail to launch anything.
    The reason why I donīt think it has really reset to factory settings is because my sister set it to really low brightness just before her phone fell down the toilet because the battery was running low.
    And now when I start it, even after all the above mentioned it continues to be hardly visible.
    Now I am not entirely sure if that is because the settings havenīt been restored or because the backlight is damaged.

    Help would really be appreciated!
    Thank you a lot!

  2. #2

    Member Since
    Jun 18, 2011
    Does no one know a solution to this?

  3. #3

    chas_m's Avatar
    Member Since
    Jan 22, 2010
    Victoria, BC
    Mid-2012 MBP (16GB, 1TB HD), Monoprice 24-inch second monitor, iPhone 5s 32GB, iPad Air 2 64GB
    I think your sister started her own thread on this -- or else there's been an incredible epidemic of 3GS iPhones dropped in toilets of late -- so look there:

  4. #4

    Member Since
    Jun 18, 2011
    No thats just another random person with the same problem!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. iphone firmware 3.1.2 HELP!!!
    By blind_30 in forum iOS and Apps
    Replies: 2
    Last Post: 03-16-2010, 05:46 PM
  2. Reinstall Windows w/o formatting my entire drive?
    By fleurya in forum Running Windows (or anything else) on your Mac
    Replies: 4
    Last Post: 01-28-2009, 04:18 PM
  3. iPhone firmware 2.2 available
    By Eric559 in forum iOS and Apps
    Replies: 37
    Last Post: 12-06-2008, 05:52 AM
  4. Backing up ENTIRE iPhone? Is it possible?
    By ekologik in forum iPhone Hardware and Accessories
    Replies: 3
    Last Post: 03-22-2008, 06:07 PM
  5. iPhone firmware 1.1.3 leaked?
    By kaidomac in forum Apple Rumors and Reports
    Replies: 12
    Last Post: 01-01-2008, 05:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts