I have at the moment an iPhone 4, with the latest software. And these past few days my WiFi has suddenly acted up and stopped working properly. And i've tried everything to fix it.
What happens:
It lets me connect to the wifi and the little symbol comes up in the top left saying im connected. And i get about 10 seconds of onnection time before everything stops working. It still says im connected. But i cant accsess Safari/Youtube. But i can still go on mail. (And only mail.) Non of my internet apps work either.
What i've tried:
Restaring internet.
Forgetting network and reconnecting.
Rebooting Hub.
Static ip/subnet/DNS/Router IP
Removing the first DNS
System Restore
Retore to Backup
Foget Network Settings / Forget all Settings
And nothings worked.
What i know:
It's not my internet. Everything connects (xbox, ps3, mums iphone, ipad, brothers iphone, 2 laptops, netbook) But my iphone wont connect. And it only happened these past few days. Im not sure if it was the update seeing my mums iphone and my brother iphone havnt been updated. So wondering if the update messed up my internet somehow.

If anyone can shed some light on this. It would be much appreciated.