New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
iPhone Hardware and Accessories Discuss iPhone hardware

iphone 4 says "no sim"


Post Reply New Thread Subscribe

 
Thread Tools
phanastasio

 
Member Since: Jun 23, 2010
Posts: 2
phanastasio is on a distinguished road

phanastasio is offline
So I activated it by phone, got it all synced up w/ my iphone 3G stuff, made a few test calls, everything was going great. all of a sudden "no sim" popped up where my network indicator is. now it won't work at all...on phone w/ ATT trying to get help but this sucks. thoughts?
QUOTE Thanks
phanastasio

 
Member Since: Jun 23, 2010
Posts: 2
phanastasio is on a distinguished road

phanastasio is offline
did the obvious, found a paperclip, got it out and put it back in. works. troubling that it was shaken lose so easily...what happens if this occurs when i'm not near a paperclip. anyway, they should've included a tool w/ the phone. thanks apple...
QUOTE Thanks
mostro

 
mostro's Avatar
 
Member Since: Sep 05, 2009
Posts: 122
mostro will become famous soon enough

mostro is offline
i wouldnt worry about it unless it happens again. may have gotten jostled a lot in shipping.
QUOTE Thanks
Steeg

 
Member Since: Jun 24, 2010
Posts: 1
Steeg is on a distinguished road

Steeg is offline
Had similar experience. But did not have your luck.

Activation went well. Calls successful.
About an hour later No SIM.
Powered off and on.
Found SIM then 5 minutes later No SIM.
Took out SIM tray and replaced. No SIM.
Had AT&T replace the SIM. Worked for 1 hour then No SIM.
Powered off and on. Worked for 5 minutes then No SIM
AT&T indicated that it is an Apple support issue at this point.
Will call them tomorrow.
QUOTE Thanks
pmoorejr

 
Member Since: Jun 24, 2010
Posts: 3
pmoorejr is on a distinguished road

pmoorejr is offline
I also received my iPhone 4 yesterday, successfully activated it..., but when using it throughout the day experienced the NO SIM and call drops (if on a call at the time) numerous times. I tried reseating the SIM card multiple times.., didn't help. Every time I get the NO SIM a simple power cycle fixes it until the next occurrence. Frustrating. Would feel better knowing whether this was a software glitch or a hardware problem. Went to apple store last night but they don't have spare SIMs OR phones, so they couldn't do anything for me.
QUOTE Thanks
chas_m

 
chas_m's Avatar
 
Member Since: Jan 22, 2010
Location: Victoria, BC
Posts: 17,096
chas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond reputechas_m has a reputation beyond repute
Mac Specs: 2012 MBP, Black speakers, Black Benq second monitor, black(ish) iPhone 5s, Black 2012 iPad, etc.

chas_m is offline
IME, it's the tray that holds the SIM. Try getting them to replace that first.
QUOTE Thanks
jskipmac

 
Member Since: Jun 24, 2010
Posts: 1
jskipmac is on a distinguished road

jskipmac is offline
Quote:
Originally Posted by Steeg View Post
Had similar experience. But did not have your luck.

Activation went well. Calls successful.
About an hour later No SIM.
Powered off and on.
Found SIM then 5 minutes later No SIM.
Took out SIM tray and replaced. No SIM.
Had AT&T replace the SIM. Worked for 1 hour then No SIM.
Powered off and on. Worked for 5 minutes then No SIM
AT&T indicated that it is an Apple support issue at this point.
Will call them tomorrow.
-----
I have not had it go into 'no SIM' without placing in pocket/walking around.. I am testing now with it laying flat, will check back hourly.. see if it goes into 'no SIM' mode.. if it does then we have firmware problem.. if not then it could be tray or sim cards I guess..

Same deal here, haven't tried apple yet.. please let me know what you find out! I thought I had narrowed it to only occuring when I placed it into a holster (which had a magnetic clip) got rid of it and was good for an hour and then I pulled it out my pocket and bang no SIM ... Reboots always solve it. Have you ever seen it go from signal to no SIM? or does this only seem to happen when it is locked?
QUOTE Thanks
spiderguy84

 
Member Since: Jun 24, 2010
Posts: 2
spiderguy84 is on a distinguished road

spiderguy84 is offline
I have had the same issue. 2 times it did it while locked, 1 time it did it while unlocked and being held in my hands. AT&T suggested I go to a store and replace the micro sim card. I did that, and will probably do a software restore to see if that's the issue.
QUOTE Thanks
pmoorejr

 
Member Since: Jun 24, 2010
Posts: 3
pmoorejr is on a distinguished road

pmoorejr is offline
I've experienced the No Sim Card Installed when the phone is on the desk sitting idle, when holding it in my hand dialing a number (in mid dial, before attempting to dial), when on an active call, when reviewing contacts.., a bit of everything. I have figured out a simple Airplane Mode ON then OFF resets it... I need not reboot/power cycle -- which just makes it quicker to recover, but no less frustrating. This has happened to me about 20 times in the last 24 hours. Went to AT&T store to get a new sim, but it was insane, so will try going back later. I can't imagine it's the sim card itself. I am hoping it's just a software glitch that can be fixed easily. (but i doubt that would actually come quickly!)
QUOTE Thanks
pmoorejr

 
Member Since: Jun 24, 2010
Posts: 3
pmoorejr is on a distinguished road

pmoorejr is offline
I went to the AT&T store tonight and obtained a new SIM card. Replaced the SIM. Same problem has happened twice since I changed the sim card. Therefore, NOT THE SIM CARD. When I called in to both AT&T and APPLE, they tell me it's because the network is overloaded. Why, then, is this not happening to EVERY SINGLE IPHONE 4 user? I don't understand. It must be a defective phone. UGH!
QUOTE Thanks
justintact

 
Member Since: Jun 24, 2010
Posts: 1
justintact is on a distinguished road

justintact is offline
pmoorejr
I am having the same issue as you. I went to ATT and swapped the micro sim. As soon as I came back home, it happened again. I restored my phone thinking maybe that would work as well. Same thing. No sim installed. I am going to go to the apple store tomorrow and hopefully getting a new one. I have printed this thread! along with others from various forums to show them because when I called apple they acted like they have not heard of this problem.....
QUOTE Thanks
elyjs

 
Member Since: Jun 25, 2010
Posts: 1
elyjs is on a distinguished road

elyjs is offline
Got the same thing. Went the ATT store and tried 3 different SIM cards total. Sometimes reinserting the tray fixes it sometimes it doesn't. Have an appointment at Apple store tomorrow. Already put a ZAGG cover on really don't want to replace the phone but I am almost positive faulty hardware.
QUOTE Thanks
jacs813

 
Member Since: Jun 27, 2010
Posts: 1
jacs813 is on a distinguished road

jacs813 is offline
Not sure if this will help anyone else, but I ended up doing a NEW Restore to my iphone 4 through itunes, then restored it through my old backup. I was getting the "no sim" error at least 10 times a day, but haven't gotten it once after I did the restore. Hope this helps.
QUOTE Thanks
iphonefour

 
Member Since: Jun 27, 2010
Posts: 1
iphonefour is on a distinguished road

iphonefour is offline
I had same problem on 02 network with new iphone 4 . Had tried reloading software as new iphone and old iphone and reseated sim, but problem still existed. Returned phone to carphone warehouse and exchange for another new Iphone. Kept the same sim and problem now resolved. So take them back and insist on an exchange.
QUOTE Thanks
tdhanson

 
Member Since: Jun 27, 2010
Posts: 1
tdhanson is on a distinguished road

tdhanson is offline
Phone was only active a few hours before started saying No SIM. First reboot fixed it. Then shortly afterward it happened again. Reboot did not fix it.

I'm not sure whether to go to AT&T or Apple.
QUOTE Thanks

Post Reply New Thread Subscribe


« For someone with a jailbroken iphone! | Anyone seen these Atomic cases? Look like Element Vapor »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
1st Gen iPhone - Screen says "NO SIM" but i do have it installed fabianJ iPhone Hardware and Accessories 3 10-23-2009 05:40 PM

All times are GMT -4. The time now is 07:29 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?