New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
iPhone Hardware and Accessories Discuss iPhone hardware

iPhone won't connect to internet


Post Reply New Thread Subscribe

 
Thread Tools
stefkat_charme

 
Member Since: Apr 14, 2009
Posts: 39
stefkat_charme is an unknown at this point
Mac Specs: 13" MacBook Pro, iPod Nano 5th Gen. Yellow 16GB, iPhone 3G 16GB

stefkat_charme is offline
I'm in Canada on the Rogers network. I just recently switched to the iPhone 3G. I used to have a Nokia E71 and when I opened the browser it would always ask me if I wanted to "Search for WLAN or WiFi" or I could choose "Go Rogers" if there wasn't an open WiFi signal close enough. Now with the iPhone it just won't connect to the internet at all if I am not connected to WiFi. It's really starting to hinder the things I can do and the time I can use my phone and various apps. Any ideas?
QUOTE Thanks
stefkat_charme

 
Member Since: Apr 14, 2009
Posts: 39
stefkat_charme is an unknown at this point
Mac Specs: 13" MacBook Pro, iPod Nano 5th Gen. Yellow 16GB, iPhone 3G 16GB

stefkat_charme is offline
Just bumping this thread up. I'm still having this problem, hoping someone might have an idea.
QUOTE Thanks
mrplow

 
mrplow's Avatar
 
Member Since: Oct 01, 2007
Location: UK
Posts: 6,749
mrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond repute
Mac Specs: 27" iMac i7 (2011) 10.10, iPhone6, iPad Air, AppleTV2

mrplow is offline
I'm from the UK so I've no idea what the Rogers Network is exactly but I'd suggest you don't have the correct network settings for a 3g/edge connection. Have a look on your contract providers website or give them a call is the best suggestion I can make.

Maybe start here:
Setup Rogers EDGE Settings for the iPhone | iPhone in Canada Blog - Tips, Tricks, News, and Tutorials for Canadian iPhone Users
or here
How to get the iPhone working on Roger's EDGE network
or here
http://www.rogers.com/web/Rogers.por...upport_landing

Bon chance

External hard disk acquisition addict - but admitting the problem is the first step to a robust backup

Please use the reputation system if you think you've been helped - top right of this post
QUOTE Thanks
stefkat_charme

 
Member Since: Apr 14, 2009
Posts: 39
stefkat_charme is an unknown at this point
Mac Specs: 13" MacBook Pro, iPod Nano 5th Gen. Yellow 16GB, iPhone 3G 16GB

stefkat_charme is offline
Thanks for your help, unfortunately this didn't work. It said go to Settings>General>Network>Edge, but unfortunately I don't have the "Edge" option available :S
QUOTE Thanks
mrplow

 
mrplow's Avatar
 
Member Since: Oct 01, 2007
Location: UK
Posts: 6,749
mrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond repute
Mac Specs: 27" iMac i7 (2011) 10.10, iPhone6, iPad Air, AppleTV2

mrplow is offline
What did Rogers say when you called them? Again i know nothing of them as a company and no idea if they actually provide the service you need. So going straight to them would seem to be the most likely method of resolving your issue
QUOTE Thanks
mrplow

 
mrplow's Avatar
 
Member Since: Oct 01, 2007
Location: UK
Posts: 6,749
mrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond repute
Mac Specs: 27" iMac i7 (2011) 10.10, iPhone6, iPad Air, AppleTV2

mrplow is offline
Also the Edge option was the way it used to appear in the settings. All data settings are now in Network-cellular data network
QUOTE Thanks

Post Reply New Thread Subscribe


« Poll: Your iphone 4G hopes | Mark under iPhone screen, getting larger. »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 05:09 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?