Hey yeah i just registered after a long time of googling stuff and always ending up on this site

So my problem is this,when i plug my iphone into my macbook with OS x 10.6 or something rather, when i plug it in there is no chirp,no charging,and no iphone showing up on itunes,when i plug it into my dell with vista,woola same thing,when i plug into wall charger it charges,i even got a new usb cord with ethernet cable and still nothing,ive narrowed it down and its obviously something wrong with the phone,its jailbroke of course,has firmware 3.1.1 i used quickpwn,i think the problem is apple tring to F*** with jailbroken devices,ive been seeing alot of other people who are having the same issue and i think that apple is trying to get rid of jailbreaks,i really ****** off because i bough some stuff off itunes and i cant even put it on my iphone,and yes ive already tried all the stuff that people have recommended and all of the stuff on apple site,i tried dfu mode,different usb ports,restarting this,restarting that,re-installing this,installing that,resetting this,and nothing works,i was hoping that putting my iphone into dfu mode would do something but it didnt.Oh yeah and when i went to on apple support to try and get somone to call me, it said unable to submit request or something like that,5 times......

I also want to find out how many people are having the same issue,if any.if you have same issue,whats your device,firmware,computer,itunes version,etc.