New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus • Advice and insight from world-class Apple enthusiasts • Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
iPhone Hardware and Accessories Discuss iPhone hardware

How do I reset from 3.1 Beta 3 software?


Post Reply New Thread Subscribe

 
Thread Tools
iTone

 
iTone's Avatar
 
Member Since: Apr 28, 2009
Location: Humble, TX
Posts: 38
iTone is on a distinguished road

iTone is offline
Ok, I have a 3GS that is a development phone and I have the purple screen of death. The Genius bar says they don't know what to do and some of them won't even talk about DFU. They act like it's a National Security secret. DFU? what's that? Digital Font Underline? I don't know... we probably ought not talk about this sir!... it was ONLY a weather balloon!!!

Seriously? the developers are the ones that make the app store go 'round... and the app store is what sells millions of iPhones... is there really no solution when a developer's beta software iPhone goes belly up?

Anyone with the knowledge on how to reset to factory settings a Purple screened beta softwared iPhone 3GS?? Again, running 3.1 Beta 3

Much appreciated guys!

iTone - 17" MacBook Pro 2.4, Black MacBook 2.16, iPhone 3Gs
QUOTE Thanks
baggss

 
baggss's Avatar
 
Member Since: Oct 10, 2004
Location: Margaritaville
Posts: 10,309
baggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond repute
Mac Specs: 27" 3.4 Ghz i7 iMac-13" C2D Macbook-OSX 18.8.2-64Gb iPad 2-32 Gb iPhone 5-ATV 2-14Tb of Storage

baggss is offline
As a certified developer running a legal beta version through Apples Developer Program you should have a lifeline back to Apple for help. The fact that the folks at the Genius bar won't help and that you are coming here for help makes me wonder if you are doing everything on the "up and up".


QUOTE Thanks
iTone

 
iTone's Avatar
 
Member Since: Apr 28, 2009
Location: Humble, TX
Posts: 38
iTone is on a distinguished road

iTone is offline
Seriously? All you have to do is google the dadgum problem to see that developers all over are having the same issues. The only fixes, and I'm not even sure they are fixes, seem to be using Jailbreak software. Because I AM on the up and up, as you so accusingly put it, I'm not going to even consider putting jailbreak software on our phone. Tell you what... call apple yourself and say you're a developer with a beta software problem and they won't know which way is up. We've spoken to multiple apple reps, genius bar guys, Cupertino, even Scotland... they all seem confused and say they think you have to wait for 3.1 to be officially released... or they'll direct you to the apple developer website, which doesn't answer the problem... much less exchange a bum phone. Just seems like the support from apple should be a little better than this.

Hence the reason I'm posting in here, but if I'm just going to be met with skepticism and accusations, then forgive me for asking.

iTone - 17" MacBook Pro 2.4, Black MacBook 2.16, iPhone 3Gs
QUOTE Thanks
Doppler808

 
Member Since: May 31, 2009
Posts: 91
Doppler808 is on a distinguished road

Doppler808 is offline
You do not need to jailbreak the device to fix it. Are you trying to go back to 3.0.1? Or did you do a restore using 3.1 beta 2 and you thought you used 3? Give me some more detail please.

If you are trying to downgrade there is no official way to do it. You will need some knowledge is Terminal to downgrade, but your baseband is stay with 3.1 build, but have 3.0.1 OS.

If you just want to restore, you have to restore the same way as you how you put 3.1 on your iPhone.
QUOTE Thanks
iTone

 
iTone's Avatar
 
Member Since: Apr 28, 2009
Location: Humble, TX
Posts: 38
iTone is on a distinguished road

iTone is offline
We would prefer to get it back to 3.0.1, but didn't think it was possible. And I went to the apple developer site to download the latest version, which is 3.1 beta 3, tried using that and no-go. I did try to use the beta 2 and 1, but no luck on those either.

The restore method you're referring to didn't work either, we tried that first. To install the 3.1 originally we hooked to iTunes, held down the option key and clicked update. Which opens a finder window so you can direct it to the file you want to use as the update. Problem one is iTunes doesn't even see the phone since it's in the purple screen of death... iTunes keeps saying the SIM card is bad or missing. It's neither, we put 3 different SIM's in it that worked in other phones and got the same message.

Next thing we tried was the super scary national secret DFU mode. We entered DFU mode correctly and everything looked good to start with... iTunes saw the phone and we picked the beta 3 file, it started extracting the software but shortly into it we got an Error 23 and that was the end of that. That's as far as we've been able to get. I have some some Terminal knowledge, but our lead developer knows it well. What are your suggestions? Thanks a million for the input.

iTone - 17" MacBook Pro 2.4, Black MacBook 2.16, iPhone 3Gs
QUOTE Thanks
Doppler808

 
Member Since: May 31, 2009
Posts: 91
Doppler808 is on a distinguished road

Doppler808 is offline
when going into 3.0.1 from 3.1 the baseband can not be upgraded and it will give you the purple screen. from this point you need to go into an irecovery shell and fsboot the iPhone. This will fix the purple screen, but your baseband will stay 3.1. Are you sure the devices ID is part of the development program(registered) I muffed up one early morning and deleted the wrong ID.

I am assuming you guys are running Macs since you know what terminal is, you are on a mac forum, and application development for iphones can only be done on a mac

how to run iRecovery FSBOOT:
1. Plug your iPhone in and close iTunes.
2. Open Terminal
3. type - cd (whatever directory your iRecovery file is in) I have mine on desktop so for me would be cd desktop
3. type /.iRecovery - s
4. type fsboot (may need to do it a few times)

If you don't have iRecovery on your mac you can get the files here
I am sure you guys know where to put these files for it to work. If not just let me know.
QUOTE Thanks
iTone

 
iTone's Avatar
 
Member Since: Apr 28, 2009
Location: Humble, TX
Posts: 38
iTone is on a distinguished road

iTone is offline
I'm the rookie in the group so if you don't mind, give me more details on where the files go. Also I downloaded the libusb app and it "installed" but don't know where it went... not in apps folder or utilities folder.

thanks again for your help on this. we are on a tight deadline and we're stuck with just using the iPhone simulator. If we get it operational again I'll be most grateful.

iTone - 17" MacBook Pro 2.4, Black MacBook 2.16, iPhone 3Gs
QUOTE Thanks
MCMC

 
Member Since: Sep 18, 2009
Posts: 2
MCMC is on a distinguished road

MCMC is offline
Quote:
Originally Posted by Doppler808 View Post
when going into 3.0.1 from 3.1 the baseband can not be upgraded and it will give you the purple screen. from this point you need to go into an irecovery shell and fsboot the iPhone. This will fix the purple screen, but your baseband will stay 3.1. Are you sure the devices ID is part of the development program(registered) I muffed up one early morning and deleted the wrong ID.

I am assuming you guys are running Macs since you know what terminal is, you are on a mac forum, and application development for iphones can only be done on a mac

how to run iRecovery FSBOOT:
1. Plug your iPhone in and close iTunes.
2. Open Terminal
3. type - cd (whatever directory your iRecovery file is in) I have mine on desktop so for me would be cd desktop
3. type /.iRecovery - s
4. type fsboot (may need to do it a few times)

If you don't have iRecovery on your mac you can get the files here
I am sure you guys know where to put these files for it to work. If not just let me know.

Hi Doppler808, Hi all-

after i had bad iPhone 3GS crash (do not exactly know why) I had no other possibilty and updated my iPhone to firmware 3.1

Some hours later I collected all required information and the irecovery-tool to downgrade to 3.0.

Thx to all the different sites which step-to-step the preceeding.

My problem: when fsboot has to typed in (and press enter) nothing happens. I tried several times... see appropriate attachement.

Can you PLEASE help me; what is to do? Why is fsboot not working?

Thx in advance!
Marcus
Attached Images
File Type: jpg FS boot does not work.JPG (218.5 KB, 6 views)
QUOTE Thanks
Doppler808

 
Member Since: May 31, 2009
Posts: 91
Doppler808 is on a distinguished road

Doppler808 is offline
if it is recent then you have to go to 3.1 release as Apple does not sign any previous OS version. So if you plan to jailbreak it will not be possible to go to an older version. From what I can see you are having a NAND failure.

Since 3.1 organizes the NAND differently in 3.0 and in 3.1 this is what happens. You have to stick with 3.1, but you may want to try and restore 3.0 a second time and usually the NAND corrects itself.

once that is complete you should get a 1015 error(purple screen), and in irecovery you type in(IIRC):
auto-boot True

this
QUOTE Thanks
MCMC

 
Member Since: Sep 18, 2009
Posts: 2
MCMC is on a distinguished road

MCMC is offline
Quote:
Originally Posted by Doppler808 View Post
if it is recent then you have to go to 3.1 release as Apple does not sign any previous OS version. So if you plan to jailbreak it will not be possible to go to an older version. From what I can see you are having a NAND failure.

Since 3.1 organizes the NAND differently in 3.0 and in 3.1 this is what happens. You have to stick with 3.1, but you may want to try and restore 3.0 a second time and usually the NAND corrects itself.

once that is complete you should get a 1015 error(purple screen), and in irecovery you type in(IIRC):
auto-boot True

this
Hi, thx for quick response!

Generally I understand what to do- but one thing is not able to do.

Every time (tried ~5 times) when I try to restopre to 3.0 I got the information that operation ist not possible. The apple-check is responsible for that.

As a result I will not get the purple screen und thus I can´t type in "auto-boot true" in irecovery.

Did I understand you wrong (because of my english experience) or is there someting you did not considered in your solution?

Sorry for asking 2nd time...
QUOTE Thanks

Post Reply New Thread Subscribe


« Iphone screen cracked, home button not working | iPhone 2g »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Best Mac accounting software tinerinman OS X - Apps and Games 5 05-03-2010 01:21 PM
Paragon Snapshot for Mac OS X Public Beta Testing Anatoly OS X - Apps and Games 9 06-09-2009 08:01 AM

All times are GMT -4. The time now is 03:35 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?